BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-15-2009, 02:59 AM   #1 (permalink)
inv
New Member
 
Join Date: Dec 2009
Model: 8220
PIN: N/A
Carrier: beeline
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default created Message has "Received using: Unknown" mark

Please Login to Remove!

Hello,

I started developing of the BB application, and would like to use native mail client to work with messages from my application.

The process of message creation is simple:

Code:
ServiceBook sb = ServiceBook.getSB();
ServiceRecord[] sr = sb.findRecordsByName("Email"); // There is only one Email [CMIME] record in SB.

if(1 != sr.length) { throw new NoSuchServiceException; }

Session session = Session.getDefaultInstance(new ServiceConfiguration(sr[0]));
Store store = session.getStore();
Folder folder = store.getFolder(Folder.INBOX); // is it neccessary to use separate folder ?

Message msg = new Message(folder);
msg.setFrom(new Address("some@mail.com", "My Name"));
msg.setSubject("Test Subject");
msg.setInbound(true);
msg.setStatus(Message.Status.RX_RECEIVED, 0)
folder.appendMessage(msg);
And now I have a new message, but if I scroll up I see the top string is:
"Received using: Unknown". There is no Reply menu item for this message also.

The other messages is "Received using: EMail".

I also tried Invoke.invokeApplication( Invoke.APP_TYPE_MESSAGES, msg), but the result is the same.

Could you please clarify where is the problem? what does this message mean, and what is the best way to fix this problem?

Thank you.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.