BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   Developer Forum (http://www.blackberryforums.com/developer-forum/)
-   -   .Net SOAP webservice (http://www.blackberryforums.com/developer-forum/215434-net-soap-webservice.html)

krishnan 01-02-2010 06:08 AM

.Net SOAP webservice
 
1 Attachment(s)
Hi I am trying to access a SOAP based web service from Blackberry HttpDemo Application(Sample). I got Bad Request as the result. I tried the same URL in the Browser of the Simulator. I got the same error. Can Any one help me out of this problem.

The URL I used is attached. Sorry for the trouble.


SECOND PROBLEM:
1. I tried to access my local web service from Simulator. I got 403 "forbidden" as the result.


Please some one help me.


Regards,
krishnan.

Dougsg38p 01-02-2010 09:33 AM

I haven't used KSOAP so I can't help you there. However, if you search this forum for KSOAP you will probably find 100+ threads discussing this (or similar) issues.

krishnan 01-04-2010 12:51 AM

Quote:

Originally Posted by Dougsg38p (Post 1539394)
I haven't used KSOAP so I can't help you there. However, if you search this forum for KSOAP you will probably find 100+ threads discussing this (or similar) issues.

Hi Dougsg38p ,

Could you share how did you accomplish it with out using kSoap and please explain it.

Dougsg38p 01-04-2010 08:28 AM

I don't think you issue is really with KSOAP. '403' error is generated by the server - this sounds like an authentication issue to me.

First order of business: get a look at the server-side logs and see why you are being rejected.

krishnan 01-04-2010 08:37 AM

1 Attachment(s)
Quote:

Originally Posted by Dougsg38p (Post 1540379)
I don't think you issue is really with KSOAP. '403' error is generated by the server - this sounds like an authentication issue to me.

First order of business: get a look at the server-side logs and see why you are being rejected.

Hi Dougs38p,

Can u provide me your chat ID? I tried to access the following URL attached in the file.
But could get Bad request as the result. Now I use HttpConnection directly and not using kSOAP library. Is there any solution?


All times are GMT -5. The time now is 07:37 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.