BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   Developer Forum (http://www.blackberryforums.com/developer-forum/)
-   -   How to debug install/autorun part? (http://www.blackberryforums.com/developer-forum/216357-how-debug-install-autorun-part.html)

lzhang 01-11-2010 10:47 AM

How to debug install/autorun part?
 
Hello, there.


My application have several entry point, one of them is autorun at the startup, and it will all startEmailRegister to add my customized button.


Code:

  public void startEmailRegister() {
        ApplicationMenuItemRepository amir = ApplicationMenuItemRepository.getInstance();
        amir.addMenuItem(ApplicationMenuItemRepository.MENUITEM_EMAIL_VIEW, new MyEmailMenuItem());
    }



It works for all the other Blackberry phone I had, bold 9000, tour, curve, I will see my menu item in the email view and works great. But it didn't work for Bold 9700 (ATT) phone I had. There is no "my menu" in the email view. And because the addmenuitem happens during the install, I cannot debugging through it.


So, Two questions:


1 Why it works for all the other phones except bold 9700?

2 Is there a way to debugging the autorun part?


I am using JDE 4.6. Thanks a lot.


Lan

Dougsg38p 01-11-2010 10:22 PM

Two possibilities: first, try compiling under 5.0 (instead of 4.6) and see if this resolves the issue. We have had several issues like this in the early 5.0 releases.

Second, check application permissions. Make sure everything is "Allow".


All times are GMT -5. The time now is 11:04 AM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.