BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-12-2010, 12:13 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2009
Model: 8300
PIN: N/A
Carrier: Rogers
Posts: 43
Post Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation File is not a valid Java code file?

Please Login to Remove!

Hello all,

I get this error when trying to put my app on my blackberry.

Code:
file is not a valid Java code file
I use this command to load it (which always worked in the past) :

Code:
C:\Program Files\Research In Motion\BlackBerry JDE 4.2.1\bin>javaloader -u load c:\myApp\myApp.cod
I use the blackberry JDE version 4.2.1.41

It runs just fine in the simulator within the JDE (simulator 8310-Rogers-4.2.2.163)

My blackberry is the blackberry curve 8310 (OS version 4.2.2.163)

As far as I have read, mine should work. The error message I am getting is apparently cause I am using the wrong version of something... but everythign seems okay.

What did i do wrong? Thanks in advance!!
Offline  
Old 02-12-2010, 02:56 PM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Jan 2009
Location: New York, NY
Model: 9000
OS: 4.6.0.216
PIN: N/A
Carrier: AT&T
Posts: 40
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Last week I was getting the following error message upon booting up:

"uncaught exception: java.lang.illegalStateException"

with a button saying OK. I would press this button and have no problems.

Then my Blackberry 9000 totally locked up. No amounts of battery pulls would get it to boot up. Had AT&T help me update to newest version of OS. Then it would boot up, but still get the above error message.

After doing a Google search for people who had the same problem, here is the solution I tried, and it seems to work.

In Options, select Security Options, and then General Settings. Change Content Protection to Disabled.

Fixed my problem, may solve yours.
__________________
Kumar
Offline  
Old 02-15-2010, 04:35 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2009
Model: 8800
PIN: N/A
Carrier: Airtel
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by RyanRitten View Post
Hello all,

I get this error when trying to put my app on my blackberry.

Code:
file is not a valid Java code file
I use this command to load it (which always worked in the past) :

Code:
C:\Program Files\Research In Motion\BlackBerry JDE 4.2.1\bin>javaloader -u load c:\myApp\myApp.cod
I use the blackberry JDE version 4.2.1.41

It runs just fine in the simulator within the JDE (simulator 8310-Rogers-4.2.2.163)

My blackberry is the blackberry curve 8310 (OS version 4.2.2.163)

As far as I have read, mine should work. The error message I am getting is apparently cause I am using the wrong version of something... but everythign seems okay.

What did i do wrong? Thanks in advance!!
Two possible reasons:
1. Either main class name is not mentioned in your build script, or if no settign is present in build file, then the main class(UiApplication) name is not same as the cod file name.
2. The JDE version with which the build is done and the device OS version are not compatible.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.