BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-17-2010, 09:57 AM   #1 (permalink)
New Member
 
Join Date: Feb 2010
Model: 8900
PIN: N/A
Carrier: Dialog
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default App in use while deleting

Please Login to Remove!

I have a strange issue in some of the devices I installed my app.

The issue is when a user tries to uninstall my app in some devices they get the message that the app is in use and whether they would like to delete.

The app was tried in 3 8900 phones and in 1 phone this never comes, in another this comes every 3 times out of 5 and in another it comes always.

Any ideas for this?

We are using the following when closing our app.

Code:
system.exit(0)
--
Arjuna.
{TheArjuna.com, TheArjuna.net}
Offline  
Old 02-22-2010, 02:26 AM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2009
Model: 8800
PIN: N/A
Carrier: Airtel
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Where are you using this code? If it is in the onClose method of your application, you need to make sure that the user closes the application (through menu) before trying to uninstall.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.