BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-09-2010, 12:07 AM   #1 (permalink)
New Member
 
Join Date: Mar 2010
Model: 9530
PIN: N/A
Carrier: Verizon
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question Module Handle 7444 not found

Please Login to Remove!

I cannot get my app to run on my storm.

It is signed as I use the FileConnection API.

It works just fine in the Simulator.

I have tried loading it with javaloader and through Desktop Manager after creating an ALX file. Neither approach worked for me.

These are the imports for my project:
import javax.microedition.io.Connector;
import javax.microedition.io.file.FileConnection;
import javax.microedition.io.file.FileSystemRegistry;
import java.io.IOException;
import java.util.Hashtable;
import java.util.Enumeration;
import java.util.Vector;
import net.rim.device.api.ui.component.EditField;
import net.rim.device.api.ui.component.NumericChoiceField ;
import net.rim.device.api.ui.component.LabelField;
import net.rim.device.api.ui.component.ListField;
import net.rim.device.api.ui.component.ListFieldCallback;
import net.rim.device.api.ui.component.Menu;
import net.rim.device.api.ui.container.MainScreen;
import net.rim.device.api.ui.Field;
import net.rim.device.api.ui.FocusChangeListener;
import net.rim.device.api.ui.Graphics;
import net.rim.device.api.ui.MenuItem;
import net.rim.device.api.ui.Manager;
import net.rim.device.api.ui.UiApplication;
import net.rim.device.api.util.Persistable;
import net.rim.device.api.system.Characters;
import net.rim.device.api.system.Display;
import net.rim.device.api.system.PersistentObject;
import net.rim.device.api.system.PersistentStore;
import net.rim.device.api.system.KeypadListener;

It is a Storm 9530 (v5.0.0.328)

XP Professional using Eclipse 3.4.1 using "Blackbery JDE Component Package 4.7.0"

I can find other articles describing this issue, but they say the module name that is missing. Does '7444' correlate to a name?
Offline  
Old 03-09-2010, 10:11 PM   #2 (permalink)
New Member
 
Join Date: Mar 2010
Model: 9530
PIN: N/A
Carrier: Verizon
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question additional troubleshooting

I took a step back and created a new empty application. I kept adding each piece on until I got the program to error again.

When I add the imports to PersistenStore and PersistentObject is when my issue starts happening. Now it gives me a different module is missing.

I used the BDM to see if any updates are necessary and I don't see anything missing from the list of applications.

Why would my Storm not have the PersistentStore and PersisentObject modules not loaded?
Offline  
Old 03-10-2010, 07:34 AM   #3 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2008
Location: Austin, TX
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 1,644
Post Thanks: 0
Thanked 34 Times in 33 Posts
Default

Are you importing a 3rd party library? Or just RIM API's?
Offline  
Old 03-10-2010, 02:50 PM   #4 (permalink)
New Member
 
Join Date: Mar 2010
Model: 9530
PIN: N/A
Carrier: Verizon
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Dougsg38p View Post
Are you importing a 3rd party library? Or just RIM API's?
I only have these items as imports in my stripped down project. It worked fine until I added the bottom three items.

import net.rim.device.api.ui.component.EditField;
import net.rim.device.api.ui.component.NumericChoiceField ;
import net.rim.device.api.ui.component.Menu;
import net.rim.device.api.ui.container.MainScreen;
import net.rim.device.api.ui.Field;
import net.rim.device.api.ui.FocusChangeListener;
import net.rim.device.api.ui.MenuItem;
import net.rim.device.api.ui.Manager;
import net.rim.device.api.ui.UiApplication;
import net.rim.device.api.util.Persistable;
import net.rim.device.api.system.PersistentObject;
import net.rim.device.api.system.PersistentStore;

I also tried compiling the PersistentObject Demo that came with the JDE and that one does the same thing. I don't understand why my phone is missing modules, I only have the stock programs and its synced with gmail.
Offline  
Old 03-10-2010, 10:29 PM   #5 (permalink)
New Member
 
Join Date: Mar 2010
Model: 9530
PIN: N/A
Carrier: Verizon
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Lightbulb Issue Resolved

Ok, so I stepped back even further and decided to go through the sticky instructions at the beginning of the developers forum section. "Set up Eclipse for BlackBerry development". (I only performed section 3.1 to make things work)

I can now use my app on my phone.

Lessons learned? Yes, RTFM.

One would guess that if you run the install for eclipse provided by RIM, that it would work out of the box, but I digress.

Last edited by vtlamore : 03-10-2010 at 10:59 PM.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.