BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-19-2010, 02:23 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2010
Model: 8520
PIN: N/A
Carrier: T-Mobile
Posts: 25
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default JDE problem

Please Login to Remove!

Hello,

I'm new at developing so my question might sound a bit inapropriate and funny.
I own a 8520 (4.6.1) and I downloaded the 5.0 plugin. When I want to transfer my application to my device, it says it's not compatible (although it works on the 8520 simulator). Is it because of this difference or something else? If it is, how can I solve it?

Thanks
Offline  
Old 04-19-2010, 04:54 PM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2008
Location: Austin, TX
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 1,644
Post Thanks: 0
Thanked 34 Times in 33 Posts
Default

Your JDE level must be less than or equal to the OS level on the device.

Since you have OS 4.6.1 on your device, you'll need to download the JDE 4,6 (or lower), or possibly upgrade your device to OS 5.0.

If you are writing a commercial application, then you need to be cognizant of the device population. Most devices in the field are running 4.5 or lower. Howerver, most devices now shipping are running OS 4.6 or higher.
Offline  
Old 04-19-2010, 05:38 PM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2010
Model: 8520
PIN: N/A
Carrier: T-Mobile
Posts: 25
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Dougsg38p View Post
Your JDE level must be less than or equal to the OS level on the device.

Since you have OS 4.6.1 on your device, you'll need to download the JDE 4,6 (or lower), or possibly upgrade your device to OS 5.0.

If you are writing a commercial application, then you need to be cognizant of the device population. Most devices in the field are running 4.5 or lower. Howerver, most devices now shipping are running OS 4.6 or higher.
thanks mate, but at the bb site only 5.0 is available to download
Offline  
Old 04-19-2010, 06:41 PM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2008
Location: Austin, TX
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 1,644
Post Thanks: 0
Thanked 34 Times in 33 Posts
Default

All of the version are available back to 4.2.1

BlackBerry - Java Development Environment

http://na.blackberry.com/eng/develop...javaplugin.jsp

Last edited by Dougsg38p : 04-19-2010 at 06:42 PM.
Offline  
Old 04-20-2010, 12:23 PM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2010
Model: 8520
PIN: N/A
Carrier: T-Mobile
Posts: 25
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

oh my, where was I looking?
thank you mate.

just this, if I install 4.6.1 JDE, I would be able to choose (at the start of every new program) what plugin to use, right? (in my case, already installed 5.0 and the new installed 4.6.1)
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.