BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-03-2010, 02:05 AM   #1 (permalink)
New Member
 
Join Date: Jul 2010
Model: 8520
PIN: N/A
Carrier: Orange, T-Mobile
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default .Net Webservice response error

Please Login to Remove!

Hi!
I'm trying to connect to a .NET webservice. The http connection works fine, I send my Post xml, I get the response, but the response isn't what it should be. (I've tried it locally, so it's not the WS that malfunctions).
Can it be that the differences between my request xml and the xml defined in my wsdl doesn't let the parameters pass to the ws?
I'm using ksoap2-j2me-core-prev
and Eclipse 3.5.2 with BlackBerry plugin

This is MY request xml:

Code:
<?xml version="1.0" encoding="utf-8" ?> 
<v:Envelope xmlns:i="h t t p : / / w w w .w3.org/2001/XMLSchema-instance" xmlns:d="h t t p : / / w w w .w3.org/2001/XMLSchema" xmlns:c="h t t p : / / schemas.xmlsoap.org/soap/encoding/" xmlns:v="h t t p : / / schemas.xmlsoap.org/soap/envelope/">
  <v:Header /> 
  <v:Body>
  <n0:startMap id="o0" c:root="1" xmlns:n0="h t t p : / / tempuri.org">
  <x>659284.165580949</x> 
  <y>241175.197092903</y> 
  <mapScale>2300</mapScale> 
  <defaultPosition>false</defaultPosition> 
  </n0:startMap>
  </v:Body>
  </v:Envelope>
And this is what the WS expects:

Code:
<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:xsi=" h t t p : / / w w w .w3.org/2001/XMLSchema-instance" xmlns:xsd="h t t p : / / w w w .w3.org/2001/XMLSchema" xmlns:soap="h t t p : / / schemas.xmlsoap.org/soap/envelope/">
  <soap:Body>
    <startMap xmlns="h t t p : / / tempuri.org/">
      <x>659284.165580949</x>
      <y>241175.197092903</y>
      <mapScale>2300</mapScale>
      <defaultPosition>false</sedefaultPosition>
    </startMap>
  </soap:Body>
</soap:Envelope>
can the problem be the tag: id="o0" and root:c="1"??
If it is, anyone knows how to remove them?
Please help!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.