BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-09-2011, 01:45 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2009
Model: 8130
PIN: N/A
Carrier: don't know
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Current UI updation from java script causes a problem on JDE 6.0.0

Please Login to Remove!

Hi All,



I am executing java script through BrowserField's ScriptEngine API without showing BrowserField on the display. One of my scriptable function shows popup screen to say, some process is going please wait for some time.



I am calling following function from script:



function doSomething(){

startProgress();



// Some business



}



On JDE 6.0.0, popup displays after my script function gets executed while on JDE 5.0.0 popup displays immediately after calling startProgress() API.



Is there any interation between ScriptEngine and UI thread that popup doesn't display??



I have observed this behavior on JDE 6.0.0 simulator and Torch device also.



Thanks in advance.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: Current UI updation from java script causes a problem on JDE 6.0.0
Thread Thread Starter Forum Replies Last Post
Vodafone and Dimension Today Installation Information (7130e) zarza Media Center 42 06-12-2006 09:14 PM
Problem W/ the O2 Theme on 7100i Stress BlackBerry Themes 24 01-31-2006 08:32 AM
jde 4.1 problem markodjurovic Developer Forum 3 10-16-2005 07:19 PM
Java Script enable? schlepers General Legacy Device Discussion 2 09-28-2005 06:10 PM
Java Script error and MDS seven BES Admin Corner 0 08-26-2005 09:18 AM





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.