BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-21-2011, 12:49 PM   #1 (permalink)
New Member
 
Join Date: Nov 2011
Model: Sim
PIN: N/A
Carrier: None
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Mobile Site Works Fine in Simulator, but Client Having Problems

Please Login to Remove!

I've been developing this mobile website, which works fine on iPhone and Droid phones. But my client's clients are having trouble viewing the site on Blackberry devices. One of them says they can't see any images and the links don't work, and another says only some images show up. When the images don't show up there's red X's in their place.

Here's the staging server: foe.stage.liquid9.tv/ (I can't post links yet)

I downloaded a Blackberry Curve simulator and the MDS service software, and the images and links worked fine. Based on what I've read online, their cache might be full so the browser is refusing to download any images, so I asked them to clear their cache, but that hasn't helped.

Can anyone help me figure out what's going wrong? Or at least verify that the images and links work on your device?
Offline  
Old 11-21-2011, 01:05 PM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: Jan 2006
Model: LEZ10
OS: 10.0.10
Carrier: Rogers CA
Posts: 1,704
Post Thanks: 20
Thanked 77 Times in 68 Posts
Default Re: Mobile Site Works Fine in Simulator, but Client Having Problems

Nice site BTW

It works fine from my Torch using Wi-Fi. The Torches (and other OS 6 and OS 7 devices) use a webkit based browser.

Not quite as well on my development 9700 running OS 5.0.

I notice you are using Google Gears. I don't think that is supported on BlackBerry prior to OS 5, but I may be mistaken. Something to check.

They may have their browser options set to not download images. Or they may have JavaScript turned off. Older BlackBerry browsers were very basic in their JavaScript support, and many had it turned off.
__________________
My other Blackberry is a PlayBook.
Offline  
Old 11-21-2011, 01:38 PM   #3 (permalink)
New Member
 
Join Date: Nov 2011
Model: Sim
PIN: N/A
Carrier: None
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Mobile Site Works Fine in Simulator, but Client Having Problems

Thanks.

I found a few pages where the images were missing from the staging server, so that explains the one client seeing most but not all images. Now I just need to figure out why the other person can't see anything.

I'm using Persist JS so I can get localStorage type functionality on browsers that don't support it, and it uses Google Gears as one of its fallback options, though I thought I had that option disabled.

Thanks again for the help/sanity check.
Offline  
Old 11-21-2011, 07:28 PM   #4 (permalink)
New Member
 
Join Date: Nov 2011
Model: Sim
PIN: N/A
Carrier: None
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Mobile Site Works Fine in Simulator, but Client Having Problems

Quote:
Originally Posted by hrbuckley View Post
Not quite as well on my development 9700 running OS 5.0.
I missed that earlier. What sort of problems are there on the 9700?
Offline  
Old 11-21-2011, 07:43 PM   #5 (permalink)
BlackBerry Extraordinaire
 
Join Date: Jan 2006
Model: LEZ10
OS: 10.0.10
Carrier: Rogers CA
Posts: 1,704
Post Thanks: 20
Thanked 77 Times in 68 Posts
Default Re: Mobile Site Works Fine in Simulator, but Client Having Problems

The logo? (top centre of the main page) was only half there. That could be from missing images though. The links worked OK. The site was certainly useable.

If I remember I'll have another look at it on the 9700 when I get into work.
__________________
My other Blackberry is a PlayBook.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: Mobile Site Works Fine in Simulator, but Client Having Problems
Thread Thread Starter Forum Replies Last Post
Best Travel/Flight Status Mobile Site? rudyo General BlackBerry Discussion 6 07-18-2005 02:32 PM





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.