BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-27-2012, 03:06 AM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: May 2007
Location: berlin, germany
Model: 8310
PIN: N/A
Carrier: vodafone
Posts: 163
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default NoClassDefFound after adding some vars

Please Login to Remove!

Hi,
in my App I have got some classes (wow) with some getters and setters(double wow).

When I develop my App and Test it on my Blackberry (BB 9360 v. 7.1) it is all fine.

But after adding some new vars to one of my classes I get the "NoClassDefFound" exception. I just add some new vars and try to run the App.

After removing the new vars it's still the same problem... wtf is BB doing?

Does anyone have some ideas? I'm using eclipse under win7 x64.

Thank you.
__________________
My English is so bad, that makes me nobody so quickly after
Offline  
Old 09-27-2012, 10:22 AM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2008
Location: Austin, TX
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 1,644
Post Thanks: 0
Thanked 34 Times in 33 Posts
Default Re: NoClassDefFound after adding some vars

The first thing to do is detemine which class it is complaining about.

This should be in your stack trace (simulator) or in the event log (device)
Offline  
Old 09-28-2012, 02:51 AM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: May 2007
Location: berlin, germany
Model: 8310
PIN: N/A
Carrier: vodafone
Posts: 163
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: NoClassDefFound after adding some vars

It is while my MainScreen is initializing. There are no more information about this error :/

I wiped my device and tried to add a test-app, everything is fine. I try my app, still the same error :(
__________________
My English is so bad, that makes me nobody so quickly after
Offline  
Old 09-28-2012, 08:49 AM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Mar 2008
Location: Austin, TX
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 1,644
Post Thanks: 0
Thanked 34 Times in 33 Posts
Default Re: NoClassDefFound after adding some vars

Did you check the event log?

You can view it on the device or download via javaloader...

No way for anyone to help you with 1) no error info, and 2) no source code
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads for: NoClassDefFound after adding some vars
Thread Thread Starter Forum Replies Last Post
Having Issues adding contact from a message. HELP! Cheryll BlackBerry Help 1 06-17-2011 08:02 AM
BlackBerry Messenger - problem adding contacts Jadey General BlackBerry Discussion 98 09-05-2010 07:48 AM
Bes 5 - Wrong messaging server when adding users TRmartin BES Admin Corner 0 11-18-2009 02:09 PM
Im having trouble adding a menuitem to the mainscreen menu flameheels Developer Forum 5 07-23-2008 12:12 AM
Adding another carrier to BES ARXXBES BES Admin Corner 2 01-25-2008 09:19 AM





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.