BlackBerry Forums Support Community
              

Closed Thread
 
LinkBack Thread Tools
Old 12-04-2004, 01:10 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Jan 2005
Location: Australia
Model: 8700G
Carrier: Telstra
Posts: 34
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Please Login to Remove!

Offline  
Old 12-04-2004, 02:08 PM   #2 (permalink)
CrackBerry Addict
 
WorldIRC's Avatar
 
Join Date: Oct 2004
Location: Toronto
Model: 9900
OS: 5.0.0.0
Carrier: Rogers Wireless
Posts: 916
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

__________________
Brian Bader
MSN / Email: [email address]
AOL: WorldIRC1986
Offline  
Old 01-28-2005, 06:10 PM   #3 (permalink)
New Member
 
Join Date: Jan 2005
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Newbie - cannot access web w/ simulator

Sorry to post this, as I'm sure it's a previously-answered problem, but I could not find anything on the board.

I'm a web designer and our site is having some problems, apparently, viewing pages with the Blackberry. I don't have a BlackBerry, just the QA guys (who are in a different city), so I can't see the problems they see with the site.

So I grabbed the simulator, installed, clicked the "Start MDS Simulator" shortcut and then have run the 7700 series simulator. I am getting the "Unable to connect to Mobile Data Service, please try again later".

On installation, I did not put it in local or remote host information, just left the defaults. I am using Win2000 Pro. I can't really tell if the MDS Simulator IS running - I see the command window open, the close, and then it launches a Windows Explorer window. Is that normal?

Any tips for this newbie?
Offline  
Old 01-28-2005, 10:54 PM   #4 (permalink)
New Member
 
Join Date: Oct 2004
Location: Vancouver
Posts: 12
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

It's been a few months since I last did bb dev but last I recall when using the MDS sim this is what happens:
-> start MDS sim through start menu
-> a command window opens and stays open during the durration of your testing, it's basically a customized tomcat server and you can see the traffic in there as you app runs in the sim and hits it on it's way out to the internet
-> I didn't have to put in any customized local or remote host information as ithe MDS sim seems to just use the default path out to the internet

Since you are getting an unable to connect to MDS I would venture a guess that either your MDS is failing (as seems indicated by the fact the command window closes) or possibly firewall settings are interfering with you ability to connect (this seems more unlikely to me but might be worth a look). I would say check your MDS it sounds like it is crashing out. Are you using the 4.0 SDK? my experience is with the 3.x SDK so perhaps they've changed the way the MDS sim behaves.

good luck!

Darren
Offline  
Old 01-29-2005, 12:30 AM   #5 (permalink)
Thumbs Must Hurt
 
Join Date: Aug 2004
Location: Metro NYC
Posts: 175
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

It is *NOT* normal for the MDS window to open and then close.

The problem with the simulator is because the MDS is not launching properly. There should be no need to change any settings (unless you are already running a web server on port 8080).

Do you have Java2 v1.4 installed on the computer?

It could be a problem with your CLASSPATH setting.

You can try run the MDS Simulator batch file manually and see if this sheds any light.
__________________
-- Aric Rosenbaum
BlackBerry consulting, BlackBerry development
www.arconsultinginc.com
BlackBerry consulting and development (RIM SI Partner)
Offline  
Old 01-31-2005, 12:13 AM   #6 (permalink)
Thumbs Must Hurt
 
Join Date: Dec 2004
Posts: 60
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Newbie - cannot access web w/ simulator

Quote:
Originally Posted by bbnewbie
Sorry to post this, as I'm sure it's a previously-answered problem, but I could not find anything on the board.

I'm a web designer and our site is having some problems, apparently, viewing pages with the Blackberry. I don't have a BlackBerry, just the QA guys (who are in a different city), so I can't see the problems they see with the site.

So I grabbed the simulator, installed, clicked the "Start MDS Simulator" shortcut and then have run the 7700 series simulator. I am getting the "Unable to connect to Mobile Data Service, please try again later".

On installation, I did not put it in local or remote host information, just left the defaults. I am using Win2000 Pro. I can't really tell if the MDS Simulator IS running - I see the command window open, the close, and then it launches a Windows Explorer window. Is that normal?

Any tips for this newbie?
I think you might not have java 1.4 installed or not have the class path settings done correctly. If this is the case, I think you have to right click my computer->advanced->environmental variable. Then you edit the system variable and add full path of the java bin folder (like c:\j2sdk1.4.0\bin). Then I think you should be fine :D
Offline  
Old 01-31-2005, 03:14 PM   #7 (permalink)
New Member
 
Join Date: Jan 2005
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Fixed

Ah! Installing J2SE 5.0 fixed it. They don't call me "newbie" for nothin'...

Thanks so much for the help!
Offline  
Old 02-01-2005, 04:11 PM   #8 (permalink)
Thumbs Must Hurt
 
Join Date: Aug 2004
Location: Metro NYC
Posts: 175
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Glad to hear you got it working, but J2SE 5.0 is not supported with the JDE. Numerous people have reported problems compiling their applications with 5.0. However, it might work if all you want to do is browse web pages.

Just my two cents.
__________________
-- Aric Rosenbaum
BlackBerry consulting, BlackBerry development
www.arconsultinginc.com
BlackBerry consulting and development (RIM SI Partner)
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Simplicity Vintage Desk 18 Month Calendar Jul'18/Dec'19 Vintage Fashion Pattern
$12.0
Simplicity Vintage Desk 18 Month Calendar Jul'18/Dec'19 Vintage Fashion Pattern picture8x10 UNFRAMED Merry Bright/Burlap Print Sign/Vintage Shabby Chic Rustic Wall Dec
$17.62
8x10 UNFRAMED Merry Bright/Burlap Print Sign/Vintage Shabby Chic Rustic Wall Dec pictureVINTAGE DEC 5016674-01C1 CONTROLLER CARD * USED *
$92.0
VINTAGE DEC 5016674-01C1 CONTROLLER CARD * USED * pictureDEC 304E 21-15542-01 AND 21-17311-02 VINTAGE CERAMIC
$179.99
DEC 304E 21-15542-01 AND 21-17311-02  VINTAGE CERAMIC pictureDEC / AMI 304E 21-15542-01 vintage ceramic IC - KTF11 Chip *NEW* 40278101
$60.0
DEC / AMI 304E 21-15542-01 vintage ceramic IC - KTF11 Chip *NEW* 40278101  picture






Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.