BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-06-2007, 07:33 PM   #1 (permalink)
New Member
 
Join Date: Mar 2007
Model: 8700c
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Eclipse generates smaller (and apparently wrong) jar.

Please Login to Remove!

I am not having much luck in getting Eclipse to work with JDE 4.2.0. Any help will be sincerely appreciated. Here is the scenario:

1) I followed instructions in "BlackBerry Application Developer Guide", Section "Using the Eclipse development environment" to set up Eclipse 3.2 to work with JDE 4.2.0. Needed to make a couple of changes to the directions therein:
- Lowered Java compiler level to 1.4 to get rid of a build error message
- Used "codfile=..." instead of "codefile=..." in configuring the rapc builder.

2) Test code compiles on Eclipse, rapc command generates cod, Eclipse connects to simulator over JDWP, but the application does not show up on the simulator.

3) Wondering if my JDE installation was at fault, I built and ran the same code using JDE itself (no Eclipse). Everything works as expected. The test app does show up on the simulator.

4) Then I noticed that the jar generated by Eclipse is only about 80% the size of the jar generated by JDE. The cod file is also proportionately smaller.

What gives?

Thanks in advance.

-DS

Last edited by dsaha : 03-06-2007 at 08:57 PM.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.