BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-21-2007, 05:49 AM   #1 (permalink)
New Member
 
Join Date: May 2007
Model: 7100t
PIN: N/A
Carrier: Maxis
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Which version of JDE should be used?

Please Login to Remove!

Hi,

I'm new to this forum as well as blackberry development. I want to develop and build a J2ME-app in blackberry. I notice, one of the way is using BlackBerry provided JDE to do the development.

FYI, my J2ME app will be just a simple app which only required MIDP 1.0 and CLDC 1.0 in a purely J2ME platform.
Now, if I port the same thing to BlackBerry I have following doubts:
Which version of JDE I should used?
My concern is if I download the latest version of JDE, will the compiled J2ME-app wont support some older version of blackberry devices? Should I go for the older version of JDE and hope the compiled app should run on newer BlackBerry devices.
Offline  
Old 05-22-2007, 02:09 AM   #2 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2007
Model: 8707
PIN: N/A
Carrier: Proximus
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi flyingfire,

I'd go for the eldest version, ie the lowest version you want to have supported, and then it should work for newer versions too. There's an knowledge base article about this issue: Livelink - Redirection

Just curious: what app are you trying to develop?

Success, L J.
Offline  
Old 05-22-2007, 03:13 AM   #3 (permalink)
New Member
 
Join Date: May 2007
Model: 7100t
PIN: N/A
Carrier: Maxis
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you Jorissen,

Before reading your reply, I had actually got JDE v4.2 downloaded and tried. My project got compiled and cod, jar, jad got created successfully. Everything were fine. Then again I downloaded and installed the JDE v3.7 without uninstall the v4.2, which mean I got 2 versions of JDE installed. I repeat everything in v3.7, but it given me this error during compilation of the project:

javac: target release 1.1 conflicts with default source release 1.5
Error: java compiler failed: javac -target 1.1 -g -O -d C:\DOCUME~1\flying\LOCALS~1\Temp\rapc_61083.dir -bootclasspath D:\MyWorkSp ...
Error while building project


Base on the error above, I can understand that, is the JDE v3.7 only supported JDK 1.1? FYI, I got JDK 1.5 installed. Or it is caused by something else?

Please help me on this, anyone got an idea? If possible, I want to remain my JDK 1.5 installed.


Quote:
Originally Posted by L Jorissen View Post
Hi flyingfire,

I'd go for the eldest version, ie the lowest version you want to have supported, and then it should work for newer versions too. There's an knowledge base article about this issue: Livelink - Redirection

Just curious: what app are you trying to develop?

Success, L J.
Offline  
Old 05-23-2007, 05:02 AM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: May 2007
Model: 8707
PIN: N/A
Carrier: Proximus
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Flyingfire,

I'm quite sure it's the version of JDK that's causing these problems. Have a look over here: BlackBerry - BlackBerry Developer Program | BlackBerry Java Development Environment Downloads

Success
Offline  
Old 05-23-2007, 05:49 AM   #5 (permalink)
Talking BlackBerry Encyclopedia
 
Skipper_Joe's Avatar
 
Join Date: Jan 2007
Location: Kharkov, Ukraine
Model: 8300
Carrier: N/A
Posts: 237
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

JDE 3.7 is designed to work with JDK1.4.
You need to install JDK1.4 and edit your environment variables:
1) define path to JDK1.4 in your JAVA_HOME variable.
2) add /bin folder of JDK to your PATH.

Problem is that JDE 4.0 and later are designed to work only with JDK1.5.

I did a small trick and created bat file, which uses setlocal directive, modified PATH and JAVA_HOME locally and starts JDE. In this way you can run different JDE versions without editing PATH and JAVA_HOME each time. I can't find this bat file right now, but it should be trivial to implement.
Offline  
Old 05-23-2007, 10:03 PM   #6 (permalink)
New Member
 
Join Date: May 2007
Model: 7100t
PIN: N/A
Carrier: Maxis
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is really a problem for me. I installed JDE v3.7 instead of the latest version which I believe is v4.2, my intension is trying to cover as many blackberry device as possible to support my J2ME app.

And JDK 1.5 is needed for me as well, since I do have some other developments required that. I think we cant have 2 different version of JDK installed at once in a same windows, am I rite?

Anyone have any idea?
Offline  
Old 05-23-2007, 11:41 PM   #7 (permalink)
Talking BlackBerry Encyclopedia
 
Skipper_Joe's Avatar
 
Join Date: Jan 2007
Location: Kharkov, Ukraine
Model: 8300
Carrier: N/A
Posts: 237
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

No, you can install different JDK versions on the same machine side-by-side.
You only need to edit PATH and JAVA_HOME variables - see my previous post.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.