BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-13-2007, 01:47 PM   #1 (permalink)
New Member
 
Join Date: Sep 2007
Model: Storm
PIN: N/A
Carrier: Verizon
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Compile in 4.2 for 4.1 OS

Please Login to Remove!

Hi Everyone,

I'm not new to Java, but new to BB development. I have an 8703e with version 4.1 of the OS. Does that mean I have to use the JDE version 4.1? None of te newer API's in 4.2 will work with my 8703e?

Thanks,

Nick
Offline  
Old 09-13-2007, 02:54 PM   #2 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Oct 2006
Model: 7103
Carrier: Verizon
Posts: 259
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

That is the case yes. it works the other way around, in that you can build in 4.1 for 4.0 os devices, but no 4.2 classes will be available for you in 4.1
Offline  
Old 09-13-2007, 03:06 PM   #3 (permalink)
New Member
 
Join Date: Sep 2007
Model: Storm
PIN: N/A
Carrier: Verizon
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks. I found that I may be able to use 4.2.0 JDE on my 4.1.0 device. I'm not able to use 4.2.1 JDE though.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.