BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-08-2005, 01:39 AM   #1 (permalink)
jwb
New Member
 
Join Date: Jun 2005
Model: Many
Carrier: T-Mobile
Posts: 14
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default JDE 4.0.1 with location API

Please Login to Remove!

Does ANYONE have 4.0.1 working with the location API on the 7520 simulator? I find it absurd that the 4.0.1 update has no installer, and requires the user to copy dozens of files by hand. I finally got to where I can compile the "gspdemo" (HA! nice QA department!) but I can't load the simulator. It complains that the locationapi library is either unavailable or duplicated, depending on how I do it.

Any help appreciated.
Offline  
Old 06-28-2005, 03:42 PM   #2 (permalink)
New Member
 
Join Date: Apr 2005
Model: 8320
Carrier: T-Mo
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Having a similar problem...

I'm able to compile a demo that uses location api code, and it runs on a real 7520, but in the simulated 7520 it fails with:

Brittle timestamp mismatch with 'net_rim_cldc'
Linker error: 'VerifyError' for net_rim_locationapi
Brittle timestamp mismatch with 'net_rim_cldc'
Linker error: 'VerifyError' for TestLocation
Error starting TestLocation: Brittle timestamp mismatch with 'net_rim_cldc'

I'd updated the JDE with 4.0.1 per the directions.
Any ideas???
Offline  
Old 06-28-2005, 04:18 PM   #3 (permalink)
New Member
 
Join Date: Jun 2005
Model: n/a
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

There was a note associated with the release (somewhere - just been searching, unable to locate) that states that the location APIs ONLY work on a live device, and not in the simulator.
Offline  
Old 06-29-2005, 08:06 AM   #4 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Sep 2004
Model: 8700r
Carrier: Rogers
Posts: 221
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

TokenUser - You are absolutely correct only works on live devices...this will be a pain!
Offline  
Old 06-29-2005, 02:23 PM   #5 (permalink)
New Member
 
Join Date: Jun 2005
Model: 7520
Carrier: Nextel
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

dzeims, where did you get the demo and what does it allow you to do? Is this the demo that came with the install? When I compiled the demo that came with the update and ran it on my phone it said I was missing components or something like that.
Offline  
Old 06-30-2005, 01:51 PM   #6 (permalink)
New Member
 
Join Date: Jun 2005
Model: n/a
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by LateNighter
dzeims, where did you get the demo and what does it allow you to do? Is this the demo that came with the install? When I compiled the demo that came with the update and ran it on my phone it said I was missing components or something like that.
Just to be clear - you know that these APIs ONLY work on a live phone, and the only phone that curretnly supports this API set is the 7520, which is Nextel only.

A lot of people are hanging out for GPS integration with other devices. Until then, you need to attach an external GPS via cable or BlueTooth.
Offline  
Old 07-01-2005, 12:37 PM   #7 (permalink)
New Member
 
Join Date: Jun 2005
Model: 7520
Carrier: Nextel
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, but has anyone been able to get the demo to work on a live 7520? When I ran it on my 7520 it said I was missing modules on the phone. Maybe I didn't install those?
Offline  
Old 07-09-2005, 09:57 PM   #8 (permalink)
New Member
 
Join Date: Jul 2005
Model: 7520
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 7520 gspdemo

ok, so does this thing work in either the simulator or the device? I would like to do both, but at the moment can get neither to work. Help please...
Offline  
Old 07-13-2005, 01:59 PM   #9 (permalink)
New Member
 
Join Date: Jul 2005
Model: 7520
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have a 7520, and have the jde, but can't seem to find this "locator" class..

any samples? I would love to play around.
Offline  
Old 07-13-2005, 04:49 PM   #10 (permalink)
New Member
 
Join Date: Jul 2005
Model: 7520
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am using a live 7520 and am getting the Error:
Error starting SPOT: Brittle timestamp mismatch with 'net_rim_cldc'

My 7520 had no net_rim_locationapi loaded so I loaded the one from the ...\BlackBerry JDE 4.0.2\simulator\Java directory.

Any ideas as to what's happening?

Thanks!
Offline  
Old 07-13-2005, 07:09 PM   #11 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2005
Model: 7280
Carrier: cingular, no wait, AT&T
Posts: 300
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Im sure its obvious, but update the phone's OS to 4.0.1 first.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.