BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 10-16-2007, 07:58 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2007
Model: 8100
Carrier: Unicel
Posts: 32
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Pearl w/red blinking LED won't charge??

Please Login to Remove!

A couple of days ago I plugged my phone in to charge, all was well (or so I thought). After it charged overnight, I unplugged it, turned it off and set it on the table since I didnt plan to use it yesterday. Today I noticed the red blinking LED. I attempted to turn it on but nothing happened. I plugged it in to charge and it won't charge. I took the battery out and have been attempting to recharge it ever since. The red led won't stop blinking regardless of whether the phone is plugged in or not and it won't turn on and won't charge. Do you think I need to buy a new battery or do you think it's something else?
Offline  
Old 10-16-2007, 08:04 PM   #2 (permalink)
BlackBerry Extraordinaire
 
david9962000's Avatar
 
Join Date: May 2007
Location: Los Angeles, CA
Model: 9360
OS: 7.1.0.694
Carrier: at&t
Posts: 1,377
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Are you using an OEM charger?I have seen this happen with Moto RAZR charger.
Offline  
Old 10-16-2007, 08:15 PM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2007
Model: 8100
Carrier: Unicel
Posts: 32
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I use the Blackberry charger that came with the phone (purchased new from Tmo)
Offline  
Old 10-16-2007, 09:16 PM   #4 (permalink)
EPIC MOD
 
ezrunner's Avatar
 
Join Date: Mar 2006
Location: Virginia Beach
Model: ZED10
OS: DOS 3.1
PIN: INK STICK
Carrier: Tmobile
Posts: 12,214
Post Thanks: 9
Thanked 6 Times in 6 Posts
Default

Wirelessly posted (BlackBerry8700/4.2.1 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/100)

How old is phone?

Any physical or liquid damage?

I have seen this on an 8800 that had water exposure!

Take back off remove battery there shoul be a white square or circle tab if it is pink or red it was been exposed to moisture! Let it dry following step in BBFaq! And cross your fingers
__________________
ZED 10

Last edited by ezrunner : 10-16-2007 at 09:21 PM.
Offline  
Old 10-16-2007, 09:24 PM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2007
Model: 8100
Carrier: Unicel
Posts: 32
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

It's 7 months old, no physical or liquid damage. I rarely use it actually -- it sits on a shelf unused 6 out of 7 days a week b/c I live in the boonies with no cell service whatsoever. Service kicks in about 18 miles south so I only use the phone if I head south to do some shopping or if I'm travelling.
Offline  
Old 10-16-2007, 09:45 PM   #6 (permalink)
EPIC MOD
 
ezrunner's Avatar
 
Join Date: Mar 2006
Location: Virginia Beach
Model: ZED10
OS: DOS 3.1
PIN: INK STICK
Carrier: Tmobile
Posts: 12,214
Post Thanks: 9
Thanked 6 Times in 6 Posts
Default

Wirelessly posted (BlackBerry8700/4.2.1 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/100)

Contact service provider! If no physical or liquid damage do a warranty claim
__________________
ZED 10
Offline  
Old 10-16-2007, 09:49 PM   #7 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2007
Model: 8100
Carrier: Unicel
Posts: 32
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm no longer with Tmo though. Do you think I can still contact them since that's where I bought it or can I contact RIM directly?
Offline  
Old 10-16-2007, 10:39 PM   #8 (permalink)
Knows Where the Search Button Is
 
jawbrkr's Avatar
 
Join Date: Jul 2007
Location: NYCity
Model: 8900
OS: 4.6.1.114
PIN: 24AA4660
Carrier: T-Mobile
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sux, same thing happened to me and couldnt find a way to resolve the problem no matter what i did. I tried to wipe the handheld and all but still came up empty. I ended up calling T-Mo and they sent me a new pearl. My phone had no damage whatsoever. It was sitting on my desk and all of a sudden it went off and upon restart couldnt restart. I kept getting the red led and the hourglass.
Offline  
Old 10-16-2007, 10:52 PM   #9 (permalink)
EPIC MOD
 
ezrunner's Avatar
 
Join Date: Mar 2006
Location: Virginia Beach
Model: ZED10
OS: DOS 3.1
PIN: INK STICK
Carrier: Tmobile
Posts: 12,214
Post Thanks: 9
Thanked 6 Times in 6 Posts
Default

Wirelessly posted (BlackBerry8700/4.2.1 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/100)

If you are no longer with TMO probably gonna have to talk directly with RiM! I would at least give TMO a call
__________________
ZED 10
Offline  
Old 10-16-2007, 11:10 PM   #10 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2007
Model: 8100
Carrier: Unicel
Posts: 32
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you everyone. I will call tmo tomorrow and then if need be, contact RIM.
Offline  
Old 10-18-2007, 04:23 PM   #11 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2007
Model: 8100
Carrier: Unicel
Posts: 32
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm getting the feeling I might be SOL. I called Tmobile -- yes the phone is under warranty but as I am not a Tmo customer anymore they can't help me. They tell me to call my current service provider. My current service provider doesn't support BB's so they told me to call the manufacturer. I called RIM but they don't support end users, you must call your service provider. Back to square one. I'm not sure what else I can do.

Edited to add:
I emailed RIM support so I will keep my fingers crossed that they'll know how to assist me.

Last edited by divabeadz : 10-18-2007 at 04:25 PM. Reason: added text
Offline  
Old 10-18-2007, 09:57 PM   #12 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2007
Model: 8100
Carrier: Unicel
Posts: 32
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

response from RIM was to contact my service provider despite the fact that my service provider said they cannot assist as they do not support BB/RIM products. Nice. Not sure what else to do at this point.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.