BlackBerry Forums Support Community               

Reply
 
LinkBack Thread Tools
Old 11-05-2008, 10:26 PM   #61 (permalink)
Thumbs Must Hurt
 
Join Date: Dec 2007
Model: 9700
PIN: N/A
Carrier: AT&T
Posts: 67
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Please Login to Remove!

Quote:
Originally Posted by John Clark View Post
Wirelessly posted (BB 11020)

HorizonWirelessOnline.com - Horizon Wireless, The World’s Cellular Repair Center

A BB Forums sponsor and all-around good guy.
Shipping is outrageous from this vendor! They did ship it really fast though.

Last edited by Yippee38 : 11-07-2008 at 12:39 PM.
Offline   Reply With Quote
Old 11-20-2008, 06:24 AM   #62 (permalink)
Thumbs Must Hurt
 
Join Date: Jun 2007
Model: 8100
PIN: N/A
Carrier: tmobile
Posts: 171
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

is there any way to get the feel of the old trackball back? as in, when you first get it there's some resistance to the scrolling. now that my pearl is about a year old, the trackball doesn't have that "clicking" feel to it. would cleaning or replacing the ball/pads underneath do anything to restore that "clicking" feeling when scrolling the ball?
__________________
Officially a blackberry addict.
Offline   Reply With Quote
Old 12-18-2008, 10:37 PM   #63 (permalink)
No longer Registered.
 
Join Date: Dec 2008
Model: 8100
PIN: N/A
Carrier: movistar
Posts: 14
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks
Offline   Reply With Quote
Old 01-02-2009, 06:06 PM   #64 (permalink)
New Member
 
Join Date: Mar 2007
Model: 8100
Carrier: T-Mobile
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I broke both rings when following these instructions but was able to purchase a new outer ring with a trackball for $9 at Cellular National Network (cnn.cn). It didn't include the inner ring but it works fine without it. This place is in Hong Kong, so it take a while to arrive but it is very cheap and the trackball seems like it is brand new.
Offline   Reply With Quote
Old 01-16-2009, 04:32 PM   #65 (permalink)
New Member
 
Join Date: Jan 2009
Model: 8100
PIN: N/A
Carrier: Alltel
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Track ball

I tried cleaning my track ball on my Blackberry and when i took everything off, the white plastic piece came apart from the piece with the rollers. How do I fix this?
Offline   Reply With Quote
Old 01-31-2009, 09:15 AM   #66 (permalink)
Thumbs Must Hurt
 
Join Date: Oct 2008
Location: Pisa, Italy
Model: 9000
OS: 5.0
Carrier: 3 Italy
Posts: 183
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

and what about if the trackball does snap but does not select nothing when pressing directly on the metal tab on the motherboard under the trackball??

thank you.
Offline   Reply With Quote
Old 01-31-2009, 11:14 AM   #67 (permalink)
Thumbs Must Hurt
 
Join Date: Oct 2008
Location: Pisa, Italy
Model: 9000
OS: 5.0
Carrier: 3 Italy
Posts: 183
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, here is the final fix! I already made it on my device while waiting for some replies, and it worked good! ;)

The problem is the copper push plate underneath the trackball that is placed directly onto the motherboard of the device.

The problem is that underneath this plate there must be some corrosion or some kind of dust or some glue slipped due to the heat of the device (you'll understand why the presence of glue by reading ahead in the post).

In my device there was some glue and some corrosion!

The part we are talking about is a little black plastic square with a round metal plate in the centre.
This square is placed at the centre of the 4 leds and 4 trackball sensors.
The round plate we need to clean is placed up on the plastic base and is keeped still with a light brown square tape that is glued on to of all (there goes the glue!).


Here is what you need to do:
  1. turn off the device and remove the battery, the sim card and the memory card (if used).
  2. disassemble the 8100 so to reach the motherboard easly (8100 Disassembly photos and instructions).
  3. from just one corner of the base and with a sharp knife CAREFULLY pry the tape up so to reach the plate and pry up that too -- as you could see the plate is only touching the black square base and is keeped still by been glued at the tape on top of the base.
  4. remove the plate from the tape WITHOUT removing complitely the tape from the square plastic base -- just slip the plate away from underneath the tape.
  5. now act on the plate with a small metal object and scrap off everything you have underneath it -- you must act unlit you see the plate as clear as possible -- it does not matter if you scratch the metal of the plate because it will work anyway -- JUST DON'T BEND IT!!!
  6. when finished, just clean the base contacts with a really clean piece of paper and finally blow air on it with your mouth just to remove the dust -- there sould be no dust between the plate and the base!!
  7. replace the plate underneath the tape and up on the black square base in the same position as it was before -- just centre the base!!!
  8. replace down the light brown tape and check if it glues back on the base corner from wich you lift it up -- instead NOT just use a little piece of black tape on the corner and on any other corner that does not glue any more.

That's it!! now it should work. It took me about 15 minutes to do everything (same time as writing this post!)

Hope this could help.
Thank you all.
Offline   Reply With Quote
Old 02-08-2009, 09:23 PM   #68 (permalink)
New Member
 
Join Date: Feb 2009
Model: 8100
PIN: N/A
Carrier: rogers
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 1qeqeqeqe

can anyone help with my trackball problem
i press the trackball and it doesnt go into a sms but shows 1 on the dial screen and after that when i press it again it show 1qe and for every click on the trackball it show more qe letters and i have no idea why did that start
sorry for bad english i hope u know what i talk about
Offline   Reply With Quote
Old 02-09-2009, 04:43 AM   #69 (permalink)
Thumbs Must Hurt
 
Join Date: Oct 2008
Location: Pisa, Italy
Model: 9000
OS: 5.0
Carrier: 3 Italy
Posts: 183
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by darkohardi View Post
can anyone help with my trackball problem
i press the trackball and it doesnt go into a sms but shows 1 on the dial screen and after that when i press it again it show 1qe and for every click on the trackball it show more qe letters and i have no idea why did that start
sorry for bad english i hope u know what i talk about
open your blackberry and clean it.
it might be sole dust or water.
Offline   Reply With Quote
Old 02-15-2009, 02:16 PM   #70 (permalink)
New Member
 
Join Date: Feb 2007
Model: 8100
Carrier: Tmo
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the great tutorial! I just cleaned my trackball and things are working grand. I had one tip to share with other BB owners- to clean in between keys and around tiny parts- I use a wooden cuticle/manicure stick (aka "orange" stick). Dip the pointed tip in a tiny bit of alcohol and use it to remove bits of dirt and grime. Works super for cleaning in grooves, corners and between keys.
Offline   Reply With Quote
Old 05-09-2009, 05:29 AM   #71 (permalink)
New Member
 
Join Date: May 2009
Model: 8100
PIN: N/A
Carrier: TMO
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by John Clark View Post
Well, if the ball has no "click" when pressing down on it then the actual contact on the circuit board has lost it's "snap." You have a defective device.
Here is my fix for putting the snap back in the click. I wouldn't do this on a phone under warranty.

On my phone (8100) the trackball worked perfectly, the problem was the contact underneath the trackball on the main board (see picture step 8 above). Part of the copper colored tape had peeled away from the switch and let dirt and lint in not allowing the trackball to do its job.

I figured it doesn't work now so I couldn't make it worse. Take the battery out or you wont be able to see what you are doing with the LED blasting holes in your eyeballs. I took forceps and peeled it the rest of the way off. What I ended up with was a small square piece of tape with a smaller round slightly dish shaped piece of metal.

I cleaned the switch contact point on the main board. I then peeled the tape from the small round metal disk. I took some electrical tape (hoping to find something better later) and cut it into a small square. Placed the small metal disk on the tape and trimmed it a little more so it wouldn't cover the LEDs. Then I positioned it over the switch, pressed it down (you could use a pencil eraser) to the switch base. Put the battery and trackball back in.

Guess what happened then. No....it worked just like new.

Even if it came loose the magnets would catch it and keep it from falling out. I am hoping to find some other kind of tape that is thinner but will stay put for the long haul. If you have an idea for something better please post it.
__________________
If you can't pay attention, pay someone who can.

Last edited by justpassntime : 05-09-2009 at 05:30 AM. Reason: spelling error
Offline   Reply With Quote
Old 05-13-2009, 01:58 PM   #72 (permalink)
New Member
 
Join Date: May 2009
Model: 8100
PIN: N/A
Carrier: tmbl
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Post An extra step that worked for me...

....i took apart and cleaned the tracker ball like everyone recommended. it got 3 of my 4 directions working. i found i had lint rapped around the arm of one of the black directional wheels. i got to that by very carefully taking a needle under the silver metal tab right above that arm. i got a ton of lint from that arm and now it works. hope this helps!

Last edited by fleazur : 05-13-2009 at 02:00 PM.
Offline   Reply With Quote
Old 06-16-2009, 01:32 AM   #73 (permalink)
New Member
 
Join Date: Jul 2008
Location: Sydney Aus
Model: 8820
PIN: N/A
Carrier: optus (Singtel)
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Worked perfectly for me after losing the ability to scroll down.

Perfect now, cheers!
__________________
Theres no place like 127.0.0.1...
Theres no place like 127.0.0.1...
Theres no place like 127.0.0.1...
Offline   Reply With Quote
Old 06-22-2009, 11:50 AM   #74 (permalink)
New Member
 
Join Date: Jun 2009
Model: 8300
PIN: N/A
Carrier: AT&T
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Talking Cleaning sometimes helps, unless it doesn't!

I cleaned my trackball a few times (didn't break it!) But finally it just stopped scrolling too much. I tried cleaning it again and no go. Anyone else have same problem? Am I the only Klutz?
Offline   Reply With Quote
Old 06-27-2009, 06:03 PM   #75 (permalink)
New Member
 
Join Date: Jun 2009
Model: Pearl
PIN: N/A
Carrier: Verizon
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Good stuff!! Excellent additional comments too! Glad I didn't get rid of the alcohol and Qtips after getting rid of all the cassette players (!)

My wife has a Pearl (which is what this applied to) and I have a Curve. My battery overheated in the Curve and took out the trackball circuit, so sometimes you do have to replace the phone.

Thanks so much!

Z

Quote:
Originally Posted by dmcman73 View Post
Great tutorial but I would like to add a few comments to it if I may.

- Before attempting to clean your trackball shut the phone off and remove the battery so you donxxx8217;t risk shorting out anything on the exposed sensors located under the trackball when you remove it.

EDIT: Just realized that there is indeed a metal clip on the older style Pearls but not on the newer ones.- After removing the plastic chrome ring from around the trackball, you do not need to remove the metal retaining ring located around the trackball. The whole assembly should just pop out by turning the phone around. The metal ring only holds the trackball in the white xxx8220;cagexxx8221; that also holds the rollers in place. If you need to remove the retaining ring to clean the rollers and ball, take out the assembly first and then remove the metal clip from the sides of the cage assembly. Youxxx8217;ll see the clips that hold the ring on, just gently pry them away front the plastic cage.

- Yes, the little black rollers are magnets which interact with the small magnetic proximity sensors inside the phone. Unfortunately after cleaning them with Alcohol you remove the very small amount of lubrication that is on them. Since the magnets come into close contact with the sensors, it will sometimes prevent the magnets from rotating hence the reason why some people have to keep repeating this cleaning procedure almost on a weekly basis or the cleaning just doesnxxx8217;t work for them.

After cleaning the track ball by using this guide, before popping the track ball back into your phone, get a clean Q-Tip and a can of Dry Silicone lubricating spray. Do not use WD-40 or any other type of spray lube, use only dry Silicone spray as this stuff will dry (so it wonxxx8217;t drip) and leaving a lubricated surface. Spray some of it onto the Q-Tip, shake the Q-Tip out to remove any excess then gently and lightly apply the lubricant directly to the 4 magnetic rollers ONLY. Do not apply it to the actual trackball, only the black magnets. Also, don't use to much of it just enough to "dampen" the black magnets.

Once done re-assemble and rotate the track ball around to dispers the lubricant, you may find that you will have to apply another coating of lubricant after this step, just repeat (don't clean it) the lubrication step.

I've done this to my blackberry and afterwards, it works better then new.

Last edited by T. B. Player : 06-27-2009 at 06:05 PM.
Offline   Reply With Quote
Old 07-18-2009, 01:32 PM   #76 (permalink)
New Member
 
Join Date: Mar 2009
Model: 8100
PIN: N/A
Carrier: ATT
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks very much for putting this together. It was very helfpul and great to get better results after cleaning the track ball.

Cheers,

abd
Offline   Reply With Quote
Old 07-24-2009, 12:09 PM   #77 (permalink)
New Member
 
EL_CHUCKY's Avatar
 
Join Date: Jul 2009
Location: PUERTO RICO
Model: 8120
OS: V4.3.0.11
PIN: N/A
Carrier: T-MOBILE
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Nice

Nice Tutorial It Is The Best One That I Have Seen!!!

Offline   Reply With Quote
Old 09-05-2009, 09:26 PM   #78 (permalink)
New Member
 
Join Date: Sep 2009
Model: 8130
PIN: N/A
Carrier: Virgin Mobile
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

my trackball was scrolling but not "selecting" when i clicked it. thank you for this tutorial! all works fantastic now.
Offline   Reply With Quote
Old 09-20-2009, 10:40 AM   #79 (permalink)
Knows Where the Search Button Is
 
Daethian's Avatar
 
Join Date: Sep 2007
Location: near St Louis
Model: 8100
OS: 4.5.0.37
PIN: 2411D42E
Carrier: AT&T
Posts: 22
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Am I the only one who can't see the pics? I need to do this but would prefer to see the pics. *fret*
__________________
BB noob
My blog
Offline   Reply With Quote
Old 10-19-2009, 06:38 AM   #80 (permalink)
New Member
 
Join Date: Oct 2009
Model: 7100T
PIN: N/A
Carrier: others
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

hey thanks for sharing your ideas it will helpful for me for cleaning my 8100 trackball.
Offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.