BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-27-2008, 09:41 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2006
Location: Canada
Model: 9000
Carrier: Rogers
Posts: 30
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Huge problems with my 8100

Please Login to Remove!

Okay, so I just purchase this thing from a guy for $130. At the time is sounded like a decent deal, however, a deal it is not. First of all, I ordered a new Blackberry battery for it (C-M2 from Shop Almost Free: item) and put it in the Pearl. I should mention at this point that I've successfully run a Motorola RAZR V3 with it as well as my HTC Touch...no probs (except the Touch couldn't give me a level indication). Anyway, I insert the batter and it says there is 5% left. Then I try to charge it via USB and it shows the plug icon for about 4 seconds then stops. Is this related to the battery or to the device?

Next up is the SIM/memory card compartment. The metal bands holding the two in place (as seen is this picture) are not in my device. The SIM is held in place by the battery, the mem card is not (at least, it doesn't show up in "Advanced Options > Media Card"). Is there are way to replace this? Is this common in any way?

Finally, Vista won't recognize the device, even with BB Desktop manager and the drivers installed its a no go.

Any help on any of these issues would be of tremendous aid.

I have both a Windows (Vista) and Mac I can use with this phone if there is some way of saving it or figuring out where the various issues lie.
Offline  
Old 02-27-2008, 09:55 PM   #2 (permalink)
BlackBerry Extraordinaire
 
TheBigNewt's Avatar
 
Join Date: Oct 2006
Location: Prescott, AZ
Model: 8900
OS: 5.0.0.411
Carrier: Tmobile
Posts: 1,641
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

The SIM locks in there, not held merely by the battery. The card locks in there too. If you aren't locking them in there properly the thing ain't gonna work with your pc. So download the manual and do it right (it's kind of tricky). Can't say what's up with the battery. I hope you're not using the wrong one. And be sure and format the card first so it's blank before you lock it in place. Then format it on the phone.
__________________
BB 8900 Tmobile, Moto Droid Verizon
Offline  
Old 02-27-2008, 09:58 PM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2006
Location: Canada
Model: 9000
Carrier: Rogers
Posts: 30
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

There is no lock for the SIM or mem card. The Metal peice shown in the picture over top of the two compartments are is not there at all.

As for the battery, its the same model, and it was advirtised as a "Pearl" battery. It has the same reactions as the other battery which leads me to believe the problem is the device.

Oh I'm so frustrated, I wish I had payed via a credit card.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.