BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-29-2008, 11:54 PM   #1 (permalink)
r3g
Thumbs Must Hurt
 
r3g's Avatar
 
Join Date: Feb 2008
Location: Bay Area, California
Model: 8320
PIN: 26275A0C
Carrier: T-Mobile
Posts: 53
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Help Needed Bad!

Please Login to Remove!

My LCD somehow got damaged so I ordered a replacement LCD. I took the phone apart and swapped the LCD out for the new one but for some reason when I go to turn the phone on the red light lights up for a second like it normal does during boot up but the LCD will not come on. I tried the old LCD as well but no luck. I was very careful to not damage the motherboard or anything on it while swapping them out. Am I doing something wrong or did I just screw myself into having to buy another phone?
__________________
Bold 9700 OS 5.0.0.536
Curve 8900 OS 4.6.1.231


Jawbone Prime, Blueant Q1, BlueAnt V1
Offline  
Old 03-30-2008, 12:00 AM   #2 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

There's very little way for any of us to tell what is wrong with your device. The Pearls use several different lcd's (according to websites I've read) so maybe it's possible you got the wrong one. Did you get the ribbon cable attached properly?
Offline  
Old 03-30-2008, 12:01 AM   #3 (permalink)
Retired BBF Moderator
 
Sith_Apprentice's Avatar
 
Join Date: Aug 2005
Model: 9000
OS: 4.6.0.xxx
Carrier: AT&T
Posts: 10,149
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

one way to tell if you damaged the device. wait until the device powers up completely (give it 10-15min) and then try and dial a number. if it goes through, its just the LCD, if it doesnt, then you are having a problem with the device itself.
Offline  
Old 03-30-2008, 12:30 AM   #4 (permalink)
r3g
Thumbs Must Hurt
 
r3g's Avatar
 
Join Date: Feb 2008
Location: Bay Area, California
Model: 8320
PIN: 26275A0C
Carrier: T-Mobile
Posts: 53
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I fired the phone up and called it and it rang.

UPDATE: connector on the LCD wasnt going in all the way because the ribbon was bent. Its working perfectly now thanks for all the help!
__________________
Bold 9700 OS 5.0.0.536
Curve 8900 OS 4.6.1.231


Jawbone Prime, Blueant Q1, BlueAnt V1

Last edited by r3g : 03-30-2008 at 12:53 AM.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.