BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-04-2008, 09:35 AM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Nov 2006
Model: 8320
Carrier: T-Mobile
Posts: 141
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Pearl just up and died?

Please Login to Remove!

My Pearl was working just fine last night, then I looked at it again and it was off. I thought it was strange, so I tried to turn it on. No go. I took the battery out, then re-inserted. Nothing. I plugged it into the charger. Still nothing. I can't think of why it would just stop working. It's never been tampered with (as far as unlocking, hacking, etc.), never dropped in water, etc.

Does anyone know what the warranty is on these things? I looked at getting another from T-Mobile, but it's going to be $350! At least on ebay, it's a bit cheaper.
Offline  
Old 04-04-2008, 09:43 AM   #2 (permalink)
Retired BBF Moderator
 
Thatzmister2u's Avatar
 
Join Date: Feb 2007
Location: Nor Cal
Model: 9000
PIN: ups! ;)
Carrier: AT&T
Posts: 5,890
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by p nut View Post
My Pearl was working just fine last night, then I looked at it again and it was off. I thought it was strange, so I tried to turn it on. No go. I took the battery out, then re-inserted. Nothing. I plugged it into the charger. Still nothing. I can't think of why it would just stop working. It's never been tampered with (as far as unlocking, hacking, etc.), never dropped in water, etc.

Does anyone know what the warranty is on these things? I looked at getting another from T-Mobile, but it's going to be $350! At least on ebay, it's a bit cheaper.
No red LED or anything at all? What happens if you remove the battery and plug into the charger?

Do you know anyone else with a pearl that you might borrow their battery for a minute to check and see if their works in yours?
E-
__________________
Unlocked | AT&T BES
*gasp* Un-protected...


www.horizonwirelessonline.com - Unlocks and Repairs
Offline  
Old 04-04-2008, 10:41 AM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Nov 2006
Model: 8320
Carrier: T-Mobile
Posts: 141
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Thatzmister2u View Post
No red LED or anything at all? What happens if you remove the battery and plug into the charger?

Do you know anyone else with a pearl that you might borrow their battery for a minute to check and see if their works in yours?
E-
No red LED. Nothing. It's just dead. If I remove the battery and plug into the charger, still nothing comes up.

Unfortunately, I don't know anyone with a Pearl to borrow a battery from. But have you ever heard of a battery just dying like that? It had 3/4 of charge left the last time I looked at it. And 10 minutes later, it's gone. I hope I can get this phone fixed somehow. It's been my faithful companion for 2 years. I really don't want a new phone.
Offline  
Old 04-04-2008, 11:12 AM   #4 (permalink)
Thumbs Must Hurt
 
Join Date: Nov 2006
Model: 8320
Carrier: T-Mobile
Posts: 141
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, update. I took out the battery, SIM, and memory card and put them all back in. Now, the red LED comes on, the screen goes to boot up, but it turns off 10 seconds after that. So, I think the culprit is the battery. It is the original battery, so I'm guessing that it might be dead. It's strange that it would go out like that. It showed no signs of fatigue or anything. Will update when I get a new battery (or go to a T-Mo store to test out their battery).
Offline  
Old 04-04-2008, 12:41 PM   #5 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

Does this cycle repeat over and over? Does the device begin to boot then turns off and begins to boot again? If so, then the OS needs to be reloaded. If it just started to boot, then turned off and stayed off I'd say you have a bad battery or the battery isn't charging for some reason.
Offline  
Old 04-04-2008, 02:35 PM   #6 (permalink)
Thumbs Must Hurt
 
Join Date: Nov 2006
Model: 8320
Carrier: T-Mobile
Posts: 141
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yeah, it's the latter. It just shuts off completely--no rebooting. I did leave the battery in and after a few minutes, it was hot (the whole phone!). I quickly took out the battery. I ordered a new battery (OEM $7 through ebay!) and hopefully it will solve the problem.
Offline  
Old 04-05-2008, 02:41 AM   #7 (permalink)
Thumbs Must Hurt
 
Join Date: Nov 2006
Model: 8320
Carrier: T-Mobile
Posts: 141
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

UPDATE: Okay, I went to a T-Mobile Store and tried out a new battery. The battery read 1/2 charged in the T-Mobile Store phone. I put it in mine and it powered up, but it said "Low Battery Warning" and started getting hot. The rep said it was unusual. Any of you know what could be going on here? Again, no water damage, drops, or anything. Very gently used phone.
Offline  
Old 04-05-2008, 09:41 AM   #8 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2008
Model: 8530
Carrier: Verizon
Posts: 455
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Which was getting hot? The battery or the phone? Either way , it would indicate a very high current draw, aka a dead short on the circuit board since it does it with another battery.

If it's still under warranty, you should try to get them to replace it.
Offline  
Old 04-05-2008, 09:55 AM   #9 (permalink)
CrackBerry Addict
 
Join Date: Jul 2006
Location: Pembroke Pines, FL
Model: 9700
PIN: 21BFC0A1
Carrier: T-Mobile
Posts: 953
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

When did you get it wet?
Offline  
Old 04-05-2008, 10:37 AM   #10 (permalink)
New Member
 
Join Date: Nov 2007
Model: 8130
PIN: N/A
Carrier: Verizon
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I believe he said he didn't get it wet.
Offline  
Old 04-05-2008, 10:48 AM   #11 (permalink)
CrackBerry Addict
 
Join Date: Jul 2006
Location: Pembroke Pines, FL
Model: 9700
PIN: 21BFC0A1
Carrier: T-Mobile
Posts: 953
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by richpjr View Post
I believe he said he didn't get it wet.
I know what he said, and no offense to him, but everyone says that. I worked in phone repair for a long time. When this happens, its usually because there's corrosion on the board. Corrosion only happen when it gets wet. That could mean simply he lives in a very humid climate. In Florida the litmus sticker in phones would change just from walking outside.
Offline  
Old 04-05-2008, 11:18 AM   #12 (permalink)
Thumbs Must Hurt
 
Join Date: Nov 2006
Model: 8320
Carrier: T-Mobile
Posts: 141
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

No, I live in Salt Lake City, where humidity is virtually zero. I wouldn't lie to you guys. Why would I? Never got it wet or dropped it. It was working perfect, then all of the sudden, this happens. I looked at my records and I got it in Nov. of 2006. Out of warranty, I think. Such BS that I am still under contract, yet I have to fork out $200-$300 for a new phone. Already paid them $200 for this phone to begin with....

Thanks for the inputs, though.
Offline  
Old 04-05-2008, 11:20 AM   #13 (permalink)
Thumbs Must Hurt
 
Join Date: Nov 2006
Model: 8320
Carrier: T-Mobile
Posts: 141
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Phranc View Post
Which was getting hot? The battery or the phone? Either way , it would indicate a very high current draw, aka a dead short on the circuit board since it does it with another battery.

If it's still under warranty, you should try to get them to replace it.
I believe both the battery and the phone. When I take out the battery, there is a metal plate by where the 4-prongs are for the battery. That plate gets hot and eventually, the whole phone.
Offline  
Old 04-05-2008, 11:21 AM   #14 (permalink)
CrackBerry Addict
 
Join Date: Jul 2006
Location: Pembroke Pines, FL
Model: 9700
PIN: 21BFC0A1
Carrier: T-Mobile
Posts: 953
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted (At&t curve)

I'm not trying to call you a liar. I'm just saying maybe one day a couple of months ago you ran out to your car on the phone in the rain and completely forgot about it, and it just started acting up now.

Of course, I coukld be wrong and its just the phone being stupid because its out of warranty.
Offline  
Old 04-05-2008, 12:20 PM   #15 (permalink)
Thumbs Must Hurt
 
Join Date: Nov 2006
Model: 8320
Carrier: T-Mobile
Posts: 141
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I know you're just trying to help and I appreciate that. I really can't recall a single time that it got wet. I am very careful with the phone.
Offline  
Old 04-05-2008, 01:02 PM   #16 (permalink)
Knows Where the Search Button Is
 
Join Date: Jan 2007
Location: Hanoi
Model: 8xGSM
PIN: FFFFFFFF
Carrier: VNM and Viettel, VN Mobifone
Posts: 28
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by p nut View Post
I know you're just trying to help and I appreciate that. I really can't recall a single time that it got wet. I am very careful with the phone.
I think the mainboard of your phone was bent. May the reason is it was in the back-pocket of your trousers
Sorry about my bad English.
Offline  
Old 04-05-2008, 01:33 PM   #17 (permalink)
Thumbs Must Hurt
 
Join Date: Nov 2006
Model: 8320
Carrier: T-Mobile
Posts: 141
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I actually just keep it in my front pocket, most of the time. But maybe it did get bent, like you are saying. Who knows. I thought these were a bit more sturdy. It's disappointing that it only lasted 1.5 years...
Offline  
Old 04-05-2008, 02:34 PM   #18 (permalink)
Knows Where the Search Button Is
 
Join Date: Jan 2007
Location: Hanoi
Model: 8xGSM
PIN: FFFFFFFF
Carrier: VNM and Viettel, VN Mobifone
Posts: 28
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

okey. Now can you plug charge to phone without batt, and touch your finger to mainboard (where label was stick, and where label not stick). If the phone become to hot, you can feel where.
I think your phone have a harware problem, it can be bent or not, but it's old.
I can repair this phone, but I'm in Vietnam
Offline  
Old 04-05-2008, 02:53 PM   #19 (permalink)
CrackBerry Addict
 
coldconfession13's Avatar
 
Join Date: Apr 2007
Location: san antonio,tx
Model: 9550
OS: 5.0.0.230
PIN: 30fd8208
Carrier: Verizon
Posts: 904
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

HorizonWirelessOnline.com - Horizon Wireless, Canada’s Cellular Repair Center

They should be able to fix your phone for ya
__________________
http://www.horizonwirelessonline.com
Unlock codes, Parts, Repair just tell them Albert sent ya

http://www.blackberryfaq.com
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.