BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-10-2008, 08:38 AM   #1 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8100
PIN: N/A
Carrier: AT&T
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Help Unlocked Ebay 8100 data service not working

Please Login to Remove!

Please help, i purchased an unlocked 8100 off of Ebay, from the logon screen it was previously used on the UK Orange network.

I have an AT&T Sim which has a data plan, the phone service will work, but it will not register the data plan. It has the latest firmware available, it has been wiped and i have read about similar issues on these forums, but have yet to find a solution.

Could anyone please help?

Thanks
Offline  
Old 04-10-2008, 08:44 AM   #2 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Welcome to the BBF!

Do you have a BB Data Plan, or which?

Are you positive it is unlocked?
Quote:
1. On your BlackBerry, go to Options > Advanced Options > Sim Card.

2. At that screen type MEPD (see note below) on your keyboard. A new menu will pop up.

3. Look for Network in the list.

4. If your device is "unlocked", it should say Disabled or Inactive. If it says Active, it's still locked to that carrier.
Is there an IT Policy on the device that could be restricting it?
Look at Options > Security > General Settings > scroll to bottom, is there anything listed under "SERVICES"?
Offline  
Old 04-10-2008, 08:49 AM   #3 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8100
PIN: N/A
Carrier: AT&T
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the welcome.

Yes, I have a BB data plan with AT&T.

Definately unlocked, all five items show Disabled.

There are no services and to ensure i tried the policy.bin fix
Offline  
Old 04-10-2008, 09:46 AM   #4 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

ok, the best first place to start is two things... Go to Options > Advanced > HRT. Press Menu > Register. Remove the battery on the BB (while powered on) and replace to reboot.

If this is a BRAND NEW account, meanwhile call AT&T and double-check that the BB Data Plan has been added on your account, confirm. You will not be the first that it just mysteriously did not get added to your account.
Offline  
Old 04-10-2008, 09:54 AM   #5 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8100
PIN: N/A
Carrier: AT&T
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks, I tried the first item while on the phone to customer support.

The Sim i was using was an old account and i added the BB data plan through AT&T's Premier online website. I also tried another Sim that is working in a Pearl currently and that wont register as well.
Offline  
Old 04-10-2008, 10:20 AM   #6 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

So have you called ATT to confirm the plan is on your account, and did you pull the battery.

Have you not gotten the registration message in your inbox?
Offline  
Old 04-10-2008, 10:49 AM   #7 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8100
PIN: N/A
Carrier: AT&T
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, i spent half hour on the phone with them yesterday and yes have pulled the battery.

When you talk about registration message are you referring to the HRT table, if yes, nothing is in there.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.