BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-22-2008, 12:51 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2007
Model: 7100x
PIN: N/A
Carrier: Telstra
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default My trackball is stuffed

Please Login to Remove!

It is constantly thinking that the trackball is being pushed in, so it activates menus and sends emails without me wanting it to.

I have done the compressed air/clean the trackball thing and it is making no difference. It is frustrating the $%&^& out of me! Can anyone let me know what to do? It is no longer under warranty. It happens intermittently as well. It was no good on the weekend but it was better this morning and again it is no good. PPPPPPPPPPPPPPLLLLLLLLLLLLLLLLLLLLLLLLLLEEEEEEEEEE EEEEEEEEEEEEEEAAAAAAAAAAAAAAAAAAAAAAASSSSSSSSSSSSS SSSSSSSSSEEEEEEEEEEEEEEEE help me!

Cheers
Tim
Offline  
Old 04-22-2008, 01:15 AM   #2 (permalink)
Retired BBF Moderator
 
Thatzmister2u's Avatar
 
Join Date: Feb 2007
Location: Nor Cal
Model: 9000
PIN: ups! ;)
Carrier: AT&T
Posts: 5,890
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did you get the device wet? If so there is not much you can do. Otherwise, try taking the trackball out and gently prying the contact underneath up a little, it may be making incidental contact.

Good Luck!
__________________
Unlocked | AT&T BES
*gasp* Un-protected...


www.horizonwirelessonline.com - Unlocks and Repairs
Offline  
Old 04-22-2008, 01:22 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2007
Model: 7100x
PIN: N/A
Carrier: Telstra
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

No, it didn't get wet. I will try prying the contact up, but I'm not holding out much hope.
Offline  
Old 04-22-2008, 02:29 AM   #4 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2007
Model: 7100x
PIN: N/A
Carrier: Telstra
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK, after a lot more searching, it seems that the issue is corrosion under the orange square bit on the motherboard. The advice is to lift it up and scrape underneath it, but I'm not entirely sure how to lift it up. Has anyone had any experience with this?
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.