BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-25-2008, 12:46 PM   #1 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8100
PIN: N/A
Carrier: o2
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy help my blackberry 8100 only shows sos!

Please Login to Remove!

I cannot connect to my service provider my phone is unlocked and is not blocked the signal shows sos and will not connect does anone know why this is happening this is my first blackberry so I don't know much about them Thanks in advance
Offline  
Old 04-25-2008, 12:51 PM   #2 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: i5s
Carrier: AT&T
Posts: 27,803
Post Thanks: 33
Thanked 441 Times in 381 Posts
Default

A few questions:

Is this a new BB or was it bought second hand or on eBay
Do you have a SIM card installed (properly) in the 8100?
Offline  
Old 04-25-2008, 12:53 PM   #3 (permalink)
Retired BBF Moderator
 
Thatzmister2u's Avatar
 
Join Date: Feb 2007
Location: Nor Cal
Model: 9000
PIN: ups! ;)
Carrier: AT&T
Posts: 5,890
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by spraggy72 View Post
I cannot connect to my service provider my phone is unlocked and is not blocked the signal shows sos and will not connect does anone know why this is happening this is my first blackberry so I don't know much about them Thanks in advance
Was it working before? Have you tried a battery pull?
__________________
Unlocked | AT&T BES
*gasp* Un-protected...


www.horizonwirelessonline.com - Unlocks and Repairs
Offline  
Old 04-25-2008, 01:03 PM   #4 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8100
PIN: N/A
Carrier: o2
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Thanks for you reply

yes it was bought second hand on ebay and yes I have tried a battery pull the sos is coloured blue if that helps
Offline  
Old 04-25-2008, 01:06 PM   #5 (permalink)
Retired BBF Moderator
 
Sith_Apprentice's Avatar
 
Join Date: Aug 2005
Model: 9000
OS: 4.6.0.xxx
Carrier: AT&T
Posts: 10,149
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

welcome to the forums. with the SIM in do you see "Invalid SIM" across the top of the screen?
Offline  
Old 04-25-2008, 01:18 PM   #6 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8100
PIN: N/A
Carrier: o2
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default yes

Yes the phone says invalid sim when inserted in the phone
Offline  
Old 04-25-2008, 01:19 PM   #7 (permalink)
Retired BBF Moderator
 
Sith_Apprentice's Avatar
 
Join Date: Aug 2005
Model: 9000
OS: 4.6.0.xxx
Carrier: AT&T
Posts: 10,149
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

its not unlocked. go to the third link in my sig and get it unlocked
Offline  
Old 04-25-2008, 01:42 PM   #8 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8100
PIN: N/A
Carrier: o2
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default The phone is branded o2

The phone is branded o2 and I have also tried that sim card but same thing happens the sos in blue shows when you say go to the 3rd link in your sig is that your website?
Offline  
Old 04-25-2008, 01:46 PM   #9 (permalink)
Retired BBF Moderator
 
Sith_Apprentice's Avatar
 
Join Date: Aug 2005
Model: 9000
OS: 4.6.0.xxx
Carrier: AT&T
Posts: 10,149
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

not my website.
when the device boots is it showing an O2 splash screen, not the theme but before that. If you are trying an O2 sim in an O2 device and getting invalid SIM there are other issues
Offline  
Old 04-25-2008, 01:56 PM   #10 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8100
PIN: N/A
Carrier: o2
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy yes shows the o2 splash screen

yes when the device boots it does show the o2 splash screen I have checked the advanced options and it does state it is active so it is locked to o2 but I have an o2 sim that is in my contract phone and put it into the blackberry but it still displays the sos message do you have any other ideas what the issues might be and thanks for your help so far!! I am new to this type of phone and would be grateful for whatever advice i can get Regards
Offline  
Old 04-25-2008, 01:56 PM   #11 (permalink)
CrackBerry Addict
 
Dinan3's Avatar
 
Join Date: Oct 2007
Location: The Land of Ferraris, Moviestars, and Bumbs
Model: 9000
PIN: & Teller
Carrier: AT&T
Posts: 590
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

try replacing your sim card.
__________________
When you turn on your phone, does it return the favor? Welcome to BlackBerry!
________________
ubuntu-LINUX 8.04
Offline  
Old 04-25-2008, 01:57 PM   #12 (permalink)
Retired BBF Moderator
 
Sith_Apprentice's Avatar
 
Join Date: Aug 2005
Model: 9000
OS: 4.6.0.xxx
Carrier: AT&T
Posts: 10,149
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

it could be the SIM card, but it also could be the device itself (hardware or software related). try the SIM card route first and see if that helps.
Offline  
Old 04-25-2008, 02:18 PM   #13 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8100
PIN: N/A
Carrier: o2
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Thanks tried a new sim card now no sos but

When I try to dial out it says call failed any more ideas?
Offline  
Old 04-25-2008, 02:25 PM   #14 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8100
PIN: N/A
Carrier: o2
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry but the sos has now come back on so it did not stay off for long lol I think I need to take it to a mobile phone shop for some advice but thanks for your help
Offline  
Old 04-27-2008, 09:48 AM   #15 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8100
PIN: N/A
Carrier: o2
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default hello still having problems please help!!

phone checked out by o2 and not stolen and is active but still getting sos anyone know what the problem is?????
Offline  
Old 04-27-2008, 09:51 AM   #16 (permalink)
Retired BBF Moderator
 
Thatzmister2u's Avatar
 
Join Date: Feb 2007
Location: Nor Cal
Model: 9000
PIN: ups! ;)
Carrier: AT&T
Posts: 5,890
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did the carrier replace the SIM card with a new one?
__________________
Unlocked | AT&T BES
*gasp* Un-protected...


www.horizonwirelessonline.com - Unlocks and Repairs
Offline  
Old 04-27-2008, 01:39 PM   #17 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8100
PIN: N/A
Carrier: o2
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default hello

no as I use this sim card with my other phone and its fine the shop put a few codes in my phone and the sos went off but after 10 min there it was again
Offline  
Old 04-27-2008, 01:53 PM   #18 (permalink)
Retired BBF Moderator
 
Sith_Apprentice's Avatar
 
Join Date: Aug 2005
Model: 9000
OS: 4.6.0.xxx
Carrier: AT&T
Posts: 10,149
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

have you tried to update the OS on the device? check the 8100 series forum at the top, it will show you the latest OS and instructions how to load it. If that doesnt work get a new SIM. just because it works in another device doesnt mean it doesnt have a problem.
Offline  
Old 04-29-2008, 06:21 PM   #19 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8100
PIN: N/A
Carrier: o2
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Talking thanks sith blackberry off for repair

thanks for your help but phone now sent to blackberry repairs as it is still under warrantry so they are going to repair the phone for free maybe a problem with the signal chip
Offline  
Old 04-30-2008, 02:42 AM   #20 (permalink)
CrackBerry Addict
 
Dinan3's Avatar
 
Join Date: Oct 2007
Location: The Land of Ferraris, Moviestars, and Bumbs
Model: 9000
PIN: & Teller
Carrier: AT&T
Posts: 590
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

glad to hear, good luck!!
__________________
When you turn on your phone, does it return the favor? Welcome to BlackBerry!
________________
ubuntu-LINUX 8.04
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.