BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 07-11-2008, 07:54 PM   #1 (permalink)
New Member
 
Join Date: Jul 2008
Model: 8100
PIN: N/A
Carrier: Vodafone New Zealand
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question Trackball problems

Please Login to Remove!

Hi All,
My trackball works up, down and left. But not when I roll it to the right, no response. has anyone else experianced this? is there a fix?

Olin
Offline  
Old 07-11-2008, 08:31 PM   #2 (permalink)
Thumbs Must Hurt
 
Verapakill's Avatar
 
Join Date: Mar 2008
Location: So Cal
Model: Storm
PIN: 318DAE46
Carrier: Verizon
Posts: 132
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did you try cleaning it?
Offline  
Old 07-11-2008, 10:38 PM   #3 (permalink)
Talking BlackBerry Encyclopedia
 
li2327's Avatar
 
Join Date: Jan 2005
Location: Philly
Model: 9530
OS: 4.7.0.148
PIN: 30504C7A
Carrier: T-Mobile
Posts: 363
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted (7130e)

I had the same problem with my 8120. I eventually had to send it back and get a warranty replacement.
__________________
Facebook: [email address]
Offline  
Old 07-12-2008, 07:17 PM   #4 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8100
PIN: N/A
Carrier: att
Posts: 12
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

you can attempt to clean it using the sticky instructions in the pearl forum, or, you can buy a replacement trackball off of ebay.
Offline  
Old 07-12-2008, 07:28 PM   #5 (permalink)
CrackBerry Addict
 
The BlackBerry Kid's Avatar
 
Join Date: Apr 2008
Location: Natick Mass
Model: 9700
PIN: it is under my battery, and status page
Carrier: T-Mobile
Posts: 741
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

did you drop it?
__________________
Anthony
T-Mobile BlackBerry Bold 9700. blackberry used as of 4-21-08 I love my
Offline  
Old 07-13-2008, 06:26 PM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Jul 2008
Model: 8100
PIN: N/A
Carrier: t-mobile
Posts: 24
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default hi

clean it !!!!!
Offline  
Old 07-14-2008, 06:49 PM   #7 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8100
PIN: N/A
Carrier: T-Mobile
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Had same problem. cleaned it and it went back to working.
Offline  
Old 07-14-2008, 07:03 PM   #8 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2007
Location: Atlanta
Model: 8320
PIN: N/A
Carrier: t mobile
Posts: 45
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

you should try a battery pull first, i dont know why, but it solves it sometimes
__________________
www.spaceagecorporation.com
Offline  
Old 07-14-2008, 07:56 PM   #9 (permalink)
Knows Where the Search Button Is
 
Join Date: Jul 2008
Location: Chicago
Model: 8100
OS: 4.5.0.52
PIN: 24129C9B
Carrier: T-Mobile
Posts: 28
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I used to get this problem every once in a while. I would resolve it by pushing the ball IN and turning it in the direction I needed. It usually worked. Then I cleaned the housing using the sticky in this section, and it made a HUGE difference.

Good Luck
Offline  
Old 07-14-2008, 08:07 PM   #10 (permalink)
New Member
 
Join Date: Dec 2006
Model: 8130
Carrier: Verizon
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

If cleaning it doesn't work, you can buy a new one on ebay for $9.99. Some sites sell them for upwards of $50.

I had to replace mince because when I took it out to clean it, I discovered that one of the rollers wasn't budging.
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.