BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-16-2008, 11:26 PM   #1 (permalink)
New Member
 
Join Date: Aug 2008
Model: 8100
PIN: N/A
Carrier: T-Mobile
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Call Forward and ID issue - Please Help!

Please Login to Remove!

I have been dealing with this strange issue for over a year - since I got my phone. I'm hoping there will be some real experts on here that can help me - this issue has gone well over the head of level 1 and level 2 blackberry tech support at T-Mobile, and even a RIM technical representative who happened to be at their facility one time when I called.

I forward calls from my work-issued Nextel to my personal phone when I'm at home - my personal phone is my Blackberry Pearl 8100.

When someone calls the Nextel, it will forward to my personal phone but the caller ID shows up "Private Number".

There have been random instances during the last year when the caller ID started working for a day or two - these instances have been completely random and without any consistency.

I have tried having my nextel forward calls to my friend's Pearl 8100, which is identical to mine and has the same software versions. His phone shows the caller ID of the forwarded call just fine.

I went through literally every setting on my phone and my firend's phone - ensuring that they match. Yes, this was a very long and tedious process.

I tried putting the SIM card from my phone in his phone, and vice versa. The Caller ID showed up fine on his phone still (with my SIM), but still failed to show up on mine (with his SIM). This obviously seems to indicate the phone is the problem.

I tried changing my SIM card (just to be safe), wiping the handheld completely, and resetting all settings - with no success.

I tried forwarding calls from my wife's t-mobile RAZR to my phone to ensure it wasn't something about Nextel, and the same issue continued.

I finally got T-mobile to replace my phone. So I now I have a new SIM card, a new phone, and newly updated software. Here's the kicker - the call forwarding still shows Private Number when it comes up on my BRAND NEW PEARL 8100. It still shows up fine on other Blackberry Pearls.

I am completely lost on this one - if replacing the phone completely didn't fix it, what could be the issue (unless I got another defective phone, which would be a really weird coincidence).

Somebody please help!
Offline  
Old 08-17-2008, 01:44 AM   #2 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Have you set the Smart Dialing options at Phone > Options?
My Caller ID name/number do not show when I get a call or SMS - BlackBerryFAQ
Offline  
Old 08-18-2008, 09:06 PM   #3 (permalink)
New Member
 
Join Date: Aug 2008
Model: 8100
PIN: N/A
Carrier: T-Mobile
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Jsanders,

Sorry for the delayed reply. I have previously tried every option available in all of the things you mentioned there. The only thing I'd mention is that my phone does not have a menu called smart dialing - I did try messing with my phone number where it is defined for the SIM though. Thanks for the input - please give some more ideas if you have any.
Offline  
Old 08-18-2008, 10:01 PM   #4 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2008
Model: 8530
Carrier: Verizon
Posts: 455
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Smart Dialing is in the Phone Options. Press the Geen Send button, then the Menu button (left of the trackball) then choose Options. Smart dialing should be about half way down.
Offline  
Old 08-18-2008, 10:17 PM   #5 (permalink)
New Member
 
Join Date: Aug 2008
Model: 8100
PIN: N/A
Carrier: T-Mobile
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Phranc

I see now - thanks. I tried, and everything in there is set as specified. Still no luck. Any other ideas?
Thanks so much for your help.
Offline  
Old 08-19-2008, 05:38 PM   #6 (permalink)
New Member
 
Join Date: Aug 2008
Model: 8100
PIN: N/A
Carrier: T-Mobile
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

bump. Anybody? Bueller?
Offline  
Old 08-19-2008, 05:40 PM   #7 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Quote:
Originally Posted by mm1334 View Post
I see now - thanks. I tried, and everything in there is set as specified. Still no luck. Any other ideas?
Thanks so much for your help.
So review the Smart Dialing settings... how is yours set?
Offline  
Old 08-19-2008, 05:51 PM   #8 (permalink)
New Member
 
Join Date: Aug 2008
Model: 8100
PIN: N/A
Carrier: T-Mobile
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Country code: +1
Area Code: 678 (I also tried this blank)
National number length: 10

I don't use the office extensions thing, but here's how it is by default:

within my corporation call: 142
Wait for: 3 seconds
Ext. Length: Unknown

To access ext. in all other...
3 seconds
Offline  
Old 08-19-2008, 05:59 PM   #9 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Do you have Options > Security Options > General Settings > Content Protection > Include Address Book set to yes?
Offline  
Old 08-19-2008, 06:10 PM   #10 (permalink)
New Member
 
Join Date: Aug 2008
Model: 8100
PIN: N/A
Carrier: T-Mobile
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Nope, include address book is set to NO. It was previously that way, but fixing that was the first thing suggested to me by a RIM tech support guy that was at Tmobile one day when I called. It doesn't work with that set to yes or no.
Offline  
Old 08-19-2008, 06:24 PM   #11 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

I just don't know. Those two fixes are the most common and often do the trick.
Offline  
Old 08-19-2008, 06:27 PM   #12 (permalink)
New Member
 
Join Date: Aug 2008
Model: 8100
PIN: N/A
Carrier: T-Mobile
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Can you refer me to somplace or someone who might be able to help? I have posted the same thing on Pinstack and supportforums.blackberry.com - with no success
Offline  
Old 08-19-2008, 06:41 PM   #13 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Honestly, no.

If a user here can't solve it, you won't find a better place for help.

Give the thread here sometime and let's see if anyone else has ideas for you.
Offline  
Old 08-19-2008, 07:23 PM   #14 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2008
Model: 8530
Carrier: Verizon
Posts: 455
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by mm1334 View Post
Country code: +1
Area Code: 678 (I also tried this blank)
National number length: 10

I don't use the office extensions thing, but here's how it is by default:

within my corporation call: 142
Wait for: 3 seconds
Ext. Length: Unknown

To access ext. in all other...
3 seconds
How about "Use "1" for National Dialing? Is that set to NO?
Offline  
Old 08-21-2008, 06:50 PM   #15 (permalink)
New Member
 
Join Date: Aug 2008
Model: 8100
PIN: N/A
Carrier: T-Mobile
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I don't see that option anywhere.

SOMEBODY PLEASE HELP, THIS ISSUE IS DRIVING ME CRAZY!
Offline  
Old 08-21-2008, 07:06 PM   #16 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Try removing the the "within my corporation call: 142" if you don't use that.
Offline  
Old 08-21-2008, 07:12 PM   #17 (permalink)
New Member
 
Join Date: Aug 2008
Model: 8100
PIN: N/A
Carrier: T-Mobile
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

didn't work. Thanks though. anything else?
Offline  
Old 08-24-2008, 02:52 PM   #18 (permalink)
New Member
 
Join Date: Aug 2008
Model: 8100
PIN: N/A
Carrier: T-Mobile
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

bump
Offline  
Old 09-10-2008, 03:44 PM   #19 (permalink)
New Member
 
Join Date: Sep 2008
Model: 8100
PIN: N/A
Carrier: tmobile
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Call Forwarding on T-Mobile Not Working (CallerID not working)

i'm having the same problem. i've been forwarding my # to my business partners phone for years but as of this spring it no longer shows the callers #, it now shows my #. i have it set that if i hit ignore it goes to my vm but if i don't answer then it goes to the business partners phone. i was on the phone with tmobile for an hour but still no solution. i'm with tmobile and my business partner is also with tmobile. tmobile must have changed a internal setting in the spring if we are all having the same issue.
Offline  
Old 10-14-2008, 03:23 PM   #20 (permalink)
New Member
 
Join Date: Oct 2008
Model: 8230
PIN: N/A
Carrier: tmobile
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm also having this call forwarding issue - has the OP or anyone else been able to fix it?

Thanks.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.