BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-16-2008, 03:54 PM   #1 (permalink)
Knows Where the Search Button Is
 
rxfeng's Avatar
 
Join Date: Oct 2007
Location: New York, NY
Model: 8100
OS: 4.2.1.107
PIN: N/A
Carrier: T-Mobile
Posts: 38
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Repeatedly Getting 543

Please Login to Remove!

Hi guys, I'm trying to fix an 8100 for a coworker and am running into a brick wall - multiple wipe/reinstalls and I constantly go from 507 to 543 and back again. Here's the history:

I get the phone with a 543 error, no apparent water damage, figure it's an easy fix. I wipe with JL_Cmdr and get 507, start up DM 4.2 (vendor.xml deleted) and install the OS, get the "successful install" message. I get hourglass on the phone for about 5 minutes before it goes back to 543. Now I'm confused. I check the phone specs using JL and vendor ID reads CellularOne (the housing says AT&T, don't ask) so I go to blackberry.com, grab the CellularOne version of DM (4.2 also) and wipe/reinstall. 543. I use Javaloader to do VM_DLFX and VM_DLPS, wipe/reinstall. 543. Now I got nothing.

I'm pretty sure I ran through the full gamut of standard fixes. Anyone have a tip on this one?
Offline  
Old 12-17-2008, 01:29 AM   #2 (permalink)
New Member
 
Join Date: Oct 2006
Location: 916
Model: 8120
Carrier: T-Mobile
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by rxfeng View Post
Hi guys, I'm trying to fix an 8100 for a coworker and am running into a brick wall - multiple wipe/reinstalls and I constantly go from 507 to 543 and back again. Here's the history:

I get the phone with a 543 error, no apparent water damage, figure it's an easy fix. I wipe with JL_Cmdr and get 507, start up DM 4.2 (vendor.xml deleted) and install the OS, get the "successful install" message. I get hourglass on the phone for about 5 minutes before it goes back to 543. Now I'm confused. I check the phone specs using JL and vendor ID reads CellularOne (the housing says AT&T, don't ask) so I go to blackberry.com, grab the CellularOne version of DM (4.2 also) and wipe/reinstall. 543. I use Javaloader to do VM_DLFX and VM_DLPS, wipe/reinstall. 543. Now I got nothing.

I'm pretty sure I ran through the full gamut of standard fixes. Anyone have a tip on this one?
Is there a micro-SD card installed in the phone?
I had problems after I updated the OS on my 8100 ... somehow the micro-SD card got corrupted and I had to copy the files to my desktop, then re-format it.
Offline  
Old 12-17-2008, 08:09 AM   #3 (permalink)
Knows Where the Search Button Is
 
rxfeng's Avatar
 
Join Date: Oct 2007
Location: New York, NY
Model: 8100
OS: 4.2.1.107
PIN: N/A
Carrier: T-Mobile
Posts: 38
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Nope, no SD card. I think it's a compatibility issue with the Java architecture, e.g. the OS is there, but the phone can't boot it. I'm trying to figure out why
Offline  
Old 12-17-2008, 03:39 PM   #4 (permalink)
Knows Where the Search Button Is
 
rxfeng's Avatar
 
Join Date: Oct 2007
Location: New York, NY
Model: 8100
OS: 4.2.1.107
PIN: N/A
Carrier: T-Mobile
Posts: 38
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Bump. Anyone? I reeaaalllyy hope the phone isn't dead.
Offline  
Old 12-19-2008, 04:53 PM   #5 (permalink)
Knows Where the Search Button Is
 
rxfeng's Avatar
 
Join Date: Oct 2007
Location: New York, NY
Model: 8100
OS: 4.2.1.107
PIN: N/A
Carrier: T-Mobile
Posts: 38
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Bump
Offline  
Old 12-19-2008, 05:01 PM   #6 (permalink)
Retired BBF Moderator
 
Thatzmister2u's Avatar
 
Join Date: Feb 2007
Location: Nor Cal
Model: 9000
PIN: ups! ;)
Carrier: AT&T
Posts: 5,890
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is all I could find on it, not sure if it will help you at all. As far as I can tell your only option is to do what you have done. Wipe the phone and reload the OS. I would try again and see if you get a different result.

KB article

Error 543 (VM_FS_MISMATCH): Incompatible Java filesystem installed
The VM has detected that the OS binary is different than the OS binary used to create the Java file system. This means that the Java native methods may not be linked properly and as such, the integrity of the system cannot be guaranteed. The system can be recovered by using the VM DLFX and DLPS commands to delete the fixups and persistent store. This will clear all data and fixups and let the filesystem relink to match the new OS binary. The recovery order is important: 1) Delete Fixups 2) Delete Persistent Store 3) Reset device.

http://www.blackberry.com/knowledgec...00443&vernum=3
__________________
Unlocked | AT&T BES
*gasp* Un-protected...


www.horizonwirelessonline.com - Unlocks and Repairs
Offline  
Old 12-22-2008, 10:49 AM   #7 (permalink)
Knows Where the Search Button Is
 
rxfeng's Avatar
 
Join Date: Oct 2007
Location: New York, NY
Model: 8100
OS: 4.2.1.107
PIN: N/A
Carrier: T-Mobile
Posts: 38
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks - if I get it sorted, I'll post the fix here.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.