BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 01-08-2009, 10:21 PM   #1 (permalink)
New Member
 
Join Date: Jan 2009
Location: Clackamas
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default The infamous "usb current is not sufficient..." message

Please Login to Remove!

I have researched this issue and tried all solutions and I still get the message 'usb current is not sufficient verify that your handheld is connected to a powered USB charging source and that the proper USB driver is installed."
My BB is connected to my laptop usb port (I tried all four) laptop is plugged into electric outlet. I have installed and reinstalled the DM 4.7 3 times. The BB shows in the Device manager as Blackberry SD under 'Portable Devices' and says it is working properly. The BB Desktop manager does not see the device at all.
I am running Vista Home premium 64 bit version. The laptop is brand new the blackberry brand new. Oh AND I made sure the power management for the usb's "Allow the computer to turn off this device to save power" is deselected.
I even tried installing just the USB and Modem driver off of the Blackberry site which ended up totally wipping out the Desktop Manager and still didn't work.
So now what? I am getting really frustrated. This has taken hours to try to fix. Any ideas?
Offline  
Old 01-08-2009, 10:36 PM   #2 (permalink)
Talking BlackBerry Encyclopedia
 
djxedxd's Avatar
 
Join Date: Oct 2006
Location: A-Town PA
Model: 9530
OS: .109
PIN: bic,no ball point,wait its blue
Carrier: Verizon
Posts: 352
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well crap thought this would be an easy fix. Say install DM and away you go but Ya covered all the bases I was gonna suggest. I know vista can be a pain in the arse my kids comp is vista and I'm pretty sure I didn't even need to install DM to get it to charge and access the SD card. Haven't touched it in awhile thought maybe I'm remembering wrong but I'm pretty sure. I think I'm sure. May need more testing <--- willy wonka.
Offline  
Old 01-08-2009, 10:53 PM   #3 (permalink)
New Member
 
Join Date: Jan 2009
Location: Clackamas
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Crap is right. I was afraid I may be up a creek. I can charge my BB and can access the SD card but that is it. I wanted to update the OS but can't without the Desktop Manager and I want to sync it with my calendar and contacts on my laptop, so kinda need it to work.
Offline  
Old 01-09-2009, 05:08 AM   #4 (permalink)
Thumbs Must Hurt
 
Join Date: Jun 2008
Location: Wolves, UK
Model: 8110
OS: 4.5.0.124
PIN: 20688648
Carrier: Orange UK
Posts: 59
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

unfortunatly the problem is Vista 64bit, I had the same problem with DM.

I tried everything I could think off until I just reinstalled XP and worked first time and everytime since then.
Offline  
Old 01-10-2009, 01:12 AM   #5 (permalink)
New Member
 
Join Date: Jan 2009
Location: Clackamas
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well I stumbled on a solution, at least for me, and I am posting it incase someone else would like to try it.

I was NOT getting any indication of the blackberry in the device manager under the USB controllers, no Blackberry Smartphone nothing. Only Blackberry SD under 'Portable Device' which just shows that vista was seeing the mass media card in the blackberry. DM didn't see the BB and my BB was giving me infamous message mentioned in my post.

Anyway, with the Blackberry plugged into the USB port I did a Windows update. Not really thinking that it would do anything. Well, I was wrong....among all the updates for Windows was the update for RIM Blackberry Smartphone. So I installed it and poof the computer started installing the device driver and now I am in business! No where in my research did I see performing a Windows Update with the Blackberry plugged in. I don't even know why I tried it but I am glad I did. Hope this helps others
Offline  
Old 01-10-2009, 08:22 PM   #6 (permalink)
New Member
 
Join Date: Jul 2008
Location: Denver
Model: 8800
OS: 4.5.0.140
Carrier: T-MOBILE
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Also make sure under advanced power settings that you have usb set correctly under plugged in if its is not vista may be disabling some usb abilities to save power just make sure that you have usb set to maximum preference under plugged in under advanced power settings
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.