BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-01-2009, 08:02 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2009
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Error message: Bad Gateway 502

Please Login to Remove!

Hi all,

I'm new to this forum since I only bought a BlackBerry 8110 yesterday and I'm already a huge BB fan by now.

However, I keep encountering a problem when I'm on the internet. When I try to access my web based e-mail for Gmail and Yahoo, I get an error message that says 'bad gateway 502' .
I can visit several other sites without any problems such as Google and Hotmail.

Does anyone know what's causing this problem and, more importantly, how to fix it?
It would be a great help, thanks in advance!
Offline  
Old 02-01-2009, 09:01 AM   #2 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App6+
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,038
Post Thanks: 52
Thanked 777 Times in 737 Posts
Default

Google is your friend. Did a quick search on your error message. This one of the links I found. Suggest you give Goole Search a try:

502 Bad Gateway - 502 Bad Gateway Error Message Displays in Browser Window - 502 Error

Also did a search using the Forum Search function and found a few possible solutions as well. One of which is replacing the SIM card on the device.

Do you have a BB data plan? If so, loading the email accounts in BIS if possible, would also resolve the issue and save you from having to check email all the time.
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 02-02-2009, 05:59 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2009
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thnx a lot for taking the time to answer me even though this problem has been discussed before. I checked the other threads about this issue but I have yet to find a solution that works for me. By the way, today I get this error message with every site I try to visit instead if just a few.

I do not have a data plan. Thing is, I'm currently using a carrier that does not support BB. I have to wait until my contract ends before I can switch carriers and get a data plan. But since I needed a new phone now and I wanted a BB anyway, I got this one and planned to use the web based e-mail for the time being. But as you can tell, it's not exactly working out as planned...

Are there perhaps some settings I can check, do you know? I will also keep searching on Google and maybe try to install a different browser but I do not want to be downloading a whole bunch of things I won't be able to use. So I'm hoping you guys can help me out.
I saw that several people with the same problem managed to fix it but I couldn't find how they did it??
Offline  
Old 02-02-2009, 09:19 AM   #4 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App6+
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,038
Post Thanks: 52
Thanked 777 Times in 737 Posts
Default

I think you just answered your own question: carrier doesn't support the bB abd no BB data plan.
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 02-02-2009, 10:17 AM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2009
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I considered this but then I thought, I should be able to use web based email regardless of my carrier, right? Also, I assumed that, if that's the actual problem, none of the sites would be working.

Last edited by Lizzle : 02-02-2009 at 10:19 AM.
Offline  
Old 02-03-2009, 04:40 AM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2009
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thought I'd let you know that I tried two different sim cards in my BB last night. First a T-Mobile card without data plan, didn't work.
Then a Vodafone card with BB data plan and it still didn't work!

So it seems to me that the problem is not with the carrier...
Offline  
Old 03-05-2009, 04:12 AM   #7 (permalink)
Knows Where the Search Button Is
 
Join Date: Feb 2009
Model: 9700
PIN: N/A
Carrier: T-Mobile
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Dubdub View Post
I think you just answered your own question: carrier doesn't support the bB abd no BB data plan.
I wanted to let you know that I managed to solve the problem. Just to help anyone else with this problem and to inform you that even though my carrier doesn't support BB and I don't have a data plan, that was not the problem.

I found new APN settings through Google. Admittedly, it was a matter of trial and error but I eventually found settings that worked for my phone. Also, I installed Opera Mini.
After I did both things, it worked just fine. I can browse the internet and open any site I like and even e-mail applications I downloaded to my phone (like Yahoo!) and maps work perfectly.
Offline  




Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.