BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 01-05-2010, 02:17 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2008
Model: 8100
PIN: N/A
Carrier: mtn nigeria
Posts: 19
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Please Login to Remove!

Wirelessly posted

My 8100 pearl has a problem completing the charging to 100%. It usually stops at 85% and each time I take out the battery, it is usually drained out before the phone completes loading. After this, I need to keep the phone charging for about 2hrs before it starts getting charge from the charger. The charge is not retained for long before it is drained again. I hope someone here has a solution for me.
Offline  
Old 01-05-2010, 03:21 PM   #2 (permalink)
BBF Moderator
 
akosnitzky's Avatar
 
Join Date: Jul 2005
Location: Southern Florida
Model: 9650
OS: 6.0.0.333
Carrier: Verizon BIS
Posts: 14,484
Post Thanks: 6
Thanked 7 Times in 7 Posts
Default

Pardon me if I seem to simplistic but have you tried another battery?
__________________
------
Follow @akosnitzky on Twitter

LET'S GO CANES!
Offline  
Old 01-05-2010, 03:25 PM   #3 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: Z10
OS: 10.2.1
Carrier: T-Mobile USA
Posts: 13,732
Post Thanks: 15
Thanked 500 Times in 487 Posts
Default

Ditto askosnitzky.

If battery life is severely low -- battery doesn't seem to hold a charge -- try a new battery. And don't buy a knockoff. Shop around for original equipment blackberry battery at a reasonable price.
__________________
- Ira
Offline  
Old 01-05-2010, 04:10 PM   #4 (permalink)
BBF Moderator
 
akosnitzky's Avatar
 
Join Date: Jul 2005
Location: Southern Florida
Model: 9650
OS: 6.0.0.333
Carrier: Verizon BIS
Posts: 14,484
Post Thanks: 6
Thanked 7 Times in 7 Posts
Default

Wirelessly posted (Lets Go Canes!)

I had bought a refurb with same symptoms. Solution was the new battery. . Hooray!
__________________
------
Follow @akosnitzky on Twitter

LET'S GO CANES!
Offline  
Old 01-05-2010, 11:18 PM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2008
Model: 8100
PIN: N/A
Carrier: mtn nigeria
Posts: 19
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks guys, but even with a new battery off the pack, the problem persists. I think some people must have had this ***** issue someway back who should be able able to assist.
Offline  
Old 01-06-2010, 05:59 AM   #6 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: Z10
OS: 10.2.1
Carrier: T-Mobile USA
Posts: 13,732
Post Thanks: 15
Thanked 500 Times in 487 Posts
Default

Look, you seem to be talking about two problems, the battery charge indication may not be accurate, and the battery life is very, very, short. I'm focusing on the second issue first.

There are three possibilities if the battery life isn't what it should be. Either (1) you have applications running that are consuming a lot of power, which in particular would be applications that are accessing data frequently; or (2) you have a hardware problem that is draining the battery; or (3) you have a bad battery that won't take a charge or won't hold a charge.

Since it sounds like the battery life is severely short, I'm guessing #3. But if you say you tried a battery that you know is good, then I'm guess #2 if the battery seems to go dead and the blackberry stops work very, very soon after turning it on.
__________________
- Ira
Offline  
Old 01-06-2010, 01:34 PM   #7 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2008
Model: 8100
PIN: N/A
Carrier: mtn nigeria
Posts: 19
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted

Thanka aiharknes, it seems to be either of 2 and 3 but it looks more like no3 to me. So how do I go about isolating the hardware issue I am suspecting. I love this phone!
Offline  
Old 01-06-2010, 01:39 PM   #8 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: Z10
OS: 10.2.1
Carrier: T-Mobile USA
Posts: 13,732
Post Thanks: 15
Thanked 500 Times in 487 Posts
Default

Can't help you with hardware. I imagine the informed answer as to what it could be is, "Many possibilities." There's a forum sponsor who does repairs. You might consider asking for an estimate. See what others say.

If I were in your shoes, with an 8100, I'd say it's time for a new blackberry. But that's me, of course.
__________________
- Ira
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.