BlackBerry Forums Support Community               

Closed Thread
LinkBack Thread Tools
Old 01-28-2010, 09:49 PM   #1 (permalink)
New Member
Join Date: Jan 2010
Model: PEARL
Carrier: BELL
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default I can't charge my phone.

Please Login to Remove!

The charge signal will pop up for like 4 seconds when plugged in, then vanish. I also can't connect it to any PC. I have tried about 6 cords that work fine with other devices so that isn't the problem. I notice it'd sometimes work after a reboot but even that isn't working so well anymore. The phone is in good shape, never been dropped or anything, also the battery life is still good lasting all day when charged, its only 13 months old.
Old 01-29-2010, 06:26 AM   #2 (permalink)
Dubdub's Avatar
Join Date: Nov 2005
Location: New Hampshire
Model: App6+
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,038
Post Thanks: 54
Thanked 783 Times in 743 Posts

First of all, will it charge when plugged into a wall outlet?

Was it working correctly in the past? If so what did you do just before it stopped?

Do you have Desktop Manager installed on the PC? You need that for the proper drivers.

Please update your profile to reflect which Pearl you have, there are several different flavors, 8100, 8120, 8130, etc.
-->>BB FAQ

-->>Stinsonddog's Tip Site!


If someone helps, tell them by clicking the Thanks button.!!
Closed Thread

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Copyright 2004-2014
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.