BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-24-2010, 05:21 AM   #1 (permalink)
New Member
 
Join Date: Mar 2010
Model: 7100g
PIN: N/A
Carrier: Loop Mobile
Posts: 14
Post Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs down Can't enable mass storage mode on the 8100

Please Login to Remove!

I've just stuck in an 8GB MicroSDHC card into the Pearl 8100. It recognizes it just fine - I've even formatted it using the Pearl itself - but I can't seem to enable mass storage mode. I've set it to enable the mode on connect and/or prompt, but it doesn't do it and it doesn't prompt me. I've looked around and everyone says that option comes up when you click the Menu button while in this settings page, but I don't get that option.

What do I do?

I'm running OS 4.5.0.174.
Offline  
Old 04-24-2010, 06:50 AM   #2 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: Z10
OS: 10.2.1
Carrier: T-Mobile USA
Posts: 13,720
Post Thanks: 15
Thanked 500 Times in 487 Posts
Default

First doublecheck.

options > media card > media card support > on

> mass storage mode support > on

> auto enable mass storage when connected > prompt (or yes)

Are those your settings?
__________________
- Ira
Offline  
Old 04-24-2010, 08:13 AM   #3 (permalink)
New Member
 
Join Date: Mar 2010
Model: 7100g
PIN: N/A
Carrier: Loop Mobile
Posts: 14
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by aiharkness View Post
First doublecheck.

options > media card > media card support > on

> mass storage mode support > on

> auto enable mass storage when connected > prompt (or yes)

Are those your settings?
Yep. I've been checking it repeatedly in different scenarios (USB connected, USB disconnected, with network on, with network off, connected to mains...) but its as if this mode doesn't exist in my firmware.

Another thing - I just put about 300mb of music into the music folder on the memory card, but the berry refuses to detect any of it. It's all AAC music straight from the iTunes library. No, not DRM'd.

Offline  
Old 04-24-2010, 08:21 AM   #4 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: Z10
OS: 10.2.1
Carrier: T-Mobile USA
Posts: 13,720
Post Thanks: 15
Thanked 500 Times in 487 Posts
Default

Wirelessly posted

Let's backup. You are able to see the card from the computer using My Computer or a media player application?

Are you trying to play the files on the blackberry while the blackberry is still connected to the computer with mass storage mode enabled? If so, that is thhe problem. The blackberry cannot access the card at the same time the blackberry is connected in mass storage mode.
__________________
- Ira
Offline  
Old 04-24-2010, 08:24 AM   #5 (permalink)
Appleinator
 
Dubdub's Avatar
 
Join Date: Nov 2005
Location: New Hampshire
Model: App5
OS: AJBR549
PIN: Ask
Carrier: ATT & Verizon
Posts: 20,030
Post Thanks: 54
Thanked 782 Times in 742 Posts
Default

Don't know if this will help or not. I don't have a Pearl nor do I use my BB for music.

Playing iTunes music on BB
__________________
-->>BB FAQ

-->>Stinsonddog's Tip Site!

-->>Twitter


If someone helps, tell them by clicking the Thanks button.!!
Offline  
Old 04-24-2010, 08:51 AM   #6 (permalink)
New Member
 
Join Date: Mar 2010
Model: 7100g
PIN: N/A
Carrier: Loop Mobile
Posts: 14
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just checked it again - all the files showed up fine AACs as well as MP3s. There was this "scanning" status bar at the bottom which didn't go away for a while, but now it's gone, and now I can see/play all music.

Still no dice with the USB mass storage support though...
Offline  
Old 04-24-2010, 08:56 AM   #7 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: Z10
OS: 10.2.1
Carrier: T-Mobile USA
Posts: 13,720
Post Thanks: 15
Thanked 500 Times in 487 Posts
Default

Wirelessly posted

I'm still not clear on what you are trying to do an can't do with regard to mass storage.

Did you install desktop manager on the computer? Does the computer recognize the blackberry? Can you sync, backup, and so forth, that is do everything else?
__________________
- Ira
Offline  
Old 04-24-2010, 01:17 PM   #8 (permalink)
New Member
 
Join Date: Mar 2010
Model: 7100g
PIN: N/A
Carrier: Loop Mobile
Posts: 14
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yeah, I've got BBDM installed. On Mac OS X. It syncs the contacts, calendar, this, that etc. just fine. It can't sync music, because it says it needs the phone to be in mass storage mode.

I've got a ton of music in my iTunes which I previously synced to my iPhone. I'm trying to get some of those playlists onto the BB. For now, I'll have to yank out the phone battery, pluck out the memory card, slide it into a memory card reader, shove it into the Mac and manually copy files to it. Then repeat the procedure in reverse. Then wait for 5 minutes for the BB to boot up.

If I can get BBDM to sync music to the BB, life will be so much easier...
Offline  
Old 04-24-2010, 03:33 PM   #9 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: Z10
OS: 10.2.1
Carrier: T-Mobile USA
Posts: 13,720
Post Thanks: 15
Thanked 500 Times in 487 Posts
Default

Wirelessly posted

So, if you have the settings set as I wrote above, then the blackberry should either prompt to allow mass storage mode or switch automatically, depending on which setting you use for auto enable. You are saying neither happens when you connect to the computer?

If so, I don't know. I don't know about Macs.
__________________
- Ira
Offline  
Old 08-12-2010, 04:26 AM   #10 (permalink)
New Member
 
Join Date: Aug 2010
Model: 8100
PIN: N/A
Carrier: Digicel
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi, did you reach solution now?
I have the same problem as you, I'm on windows vista, desktop manager reconized my blackberry 8100, that mean I can Install applications on it. But never go throught mass storage on the computer...
All I remember, I updated my device, and unlocked it from t-mobile... I'm stuck!
Please if someone faced this problem, help!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.