BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-06-2006, 05:09 PM   #1 (permalink)
New Member
 
Join Date: Nov 2006
Location: Switzerland
Model: 8100
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy HELP: Changing Carrier ID on BB 8100 ?

Please Login to Remove!

Hi

I'm sorry I'm new here. I 'upgraded' from bb 7100v to a 8100, really a great phone exept (!!) : I can't use it with BES.

The problem is, I work for a subsidiary of Vodafone in Switzerland, so our phones should be from Vodafone (Carrier ID 130). In Switzerland they will not be release before February 07. I was in Germany last Friday and past a T-Mobile shop, and saw this 8100 smiling at me.. I couldn't resist !!!

Came into the office, called the support center and tried to activate it with the Enterprise activation. After 2h of trying different things, even the experts gave up, till one of them said 'what is strange is, that your phone has carrier ID 114 and all others 130'... I turned red and admitted that it was a T-Mobile phone.

So what can I do ? Do I have to put the Firmware of Vodafone on my phone (I wouldn't mind, it's all I was used too), if yes -> where can I find it ? Or is there a possibility that I can change the carrier ID from 114 to 130 ?

Help from you guys would really be appreciated very much!

Thank you
Offline  
Old 11-06-2006, 05:24 PM   #2 (permalink)
BlackBerry Extraordinaire
 
kasperapd's Avatar
 
Join Date: Jul 2006
Location: Austin, TX
Model: 9700
Carrier: AT&T
Posts: 1,946
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here is a link to different OS from various carriers. Not sure if this will help your issue or not.

BlackBerryOS 4.x Download FAQ - UPGRADE DOWNLOADS
__________________
CrackBerry

Please try a Search
Offline  
Old 11-06-2006, 05:52 PM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Oct 2006
Model: 9000
Carrier: at&t
Posts: 75
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Seems like unlocking the phone might allow its use on any network. Not really sure though. I've never had to deal with changing the carrier id code, I just make sure they are unlocked before trying different carriers. Maybe someone else knows about the carrier ID.
Offline  
Old 11-06-2006, 06:16 PM   #4 (permalink)
CrackBerry Addict
 
MythmbHurts's Avatar
 
Join Date: Jun 2006
Location: New York City
Model: 8100
Posts: 642
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

if your phone is unlocked and you have a vodafone SIM card in it it will have the right provider ID.. its just a matter of putting the right SIM card in it and making sure the phone is unloacked.. there is a link to a good unloacking place on this forum the OS has anything to do with it since I have O2's OS on my t-mobie pearl and my provider ID is still 100... Try a SIM card from vodafone and just make sure that SIM has Blackberry plan on it or you can put a blackberry plan on that SIM card..!!
__________________
PIN:204D7C8C - USE THE SEARCH BUTTON!!!!
Yahoo: Whips_n_licks
Email:whips_n_licks@yahoo.com-Don't email me unless you searched!!
BB 8100 4.2.0.69
Offline  
Old 11-06-2006, 06:32 PM   #5 (permalink)
Spam Reporter
 
dc/dc's Avatar
 
Join Date: Oct 2005
Location: IAD
Model: 6230
Carrier: Voicestream
Posts: 14,530
Post Thanks: 220
Thanked 345 Times in 311 Posts
Default

Quote:
Originally Posted by MythmbHurts
if your phone is unlocked and you have a vodafone SIM card in it it will have the right provider ID.. its just a matter of putting the right SIM card in it and making sure the phone is unloacked.. there is a link to a good unloacking place on this forum the OS has anything to do with it since I have O2's OS on my t-mobie pearl and my provider ID is still 100... Try a SIM card from vodafone and just make sure that SIM has Blackberry plan on it or you can put a blackberry plan on that SIM card..!!
Yep.

The original provider of the device won't matter as long as the unit is unlocked.
__________________
I h8 txtspk.
Offline  
Old 11-07-2006, 03:45 PM   #6 (permalink)
New Member
 
Join Date: Nov 2006
Location: Switzerland
Model: 8100
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Carrier ID locked ?

I'm sorry, but something is wrong here...

One is SIM Locked, there I agree, this is not a problem. The phones are not SIM locked, because we use Vodafone SIM cards in it and I can make calls, send SMS and so on... that's not the problem...

The problem is, when I want to do the Enterprise activation, it's not coming up.. and the guys where the server is, said that all the other BB users of our company have a carrier code 130 in the database, just mine has a 114. So I assume that the bb Enterprise Software is licensed only to serve bb with code 130 (our carrier) and nothing else, so the gprs services do not come up, we can't use them on our phones.. right now our Pearl is just like a very nice looking 'normal' phone, without the bb services...

If I press ALT+race I see on the first line Carrier ID 114. So I think it's actually called Carrier branded. So my question is, how can I change it ?

I think maybe there are 2 possibilities :

1. We erase the firmware completely, but I mean really empty and load the VF firmware on it (we downloaded that).

2. We find a tool that can edit just that code

We put the firmware of VF on it, everything changed, exept of the carrier ID

Any help, hint, idea ?

Thanks
Offline  
Old 11-07-2006, 03:50 PM   #7 (permalink)
Spam Reporter
 
dc/dc's Avatar
 
Join Date: Oct 2005
Location: IAD
Model: 6230
Carrier: Voicestream
Posts: 14,530
Post Thanks: 220
Thanked 345 Times in 311 Posts
Default

Quote:
Originally Posted by sapguru
I'm sorry, but something is wrong here...

One is SIM Locked, there I agree, this is not a problem. The phones are not SIM locked, because we use Vodafone SIM cards in it and I can make calls, send SMS and so on... that's not the problem...

The problem is, when I want to do the Enterprise activation, it's not coming up.. and the guys where the server is, said that all the other BB users of our company have a carrier code 130 in the database, just mine has a 114. So I assume that the bb Enterprise Software is licensed only to serve bb with code 130 (our carrier) and nothing else, so the gprs services do not come up, we can't use them on our phones.. right now our Pearl is just like a very nice looking 'normal' phone, without the bb services...

If I press ALT+race I see on the first line Carrier ID 114. So I think it's actually called Carrier branded. So my question is, how can I change it ?

I think maybe there are 2 possibilities :

1. We erase the firmware completely, but I mean really empty and load the VF firmware on it (we downloaded that).

2. We find a tool that can edit just that code

We put the firmware of VF on it, everything changed, exept of the carrier ID

Any help, hint, idea ?

Thanks
All RIM devices are branded, but the Vendor ID shouldn't matter. BES is carrier agnostic, and should just need the PIN of your device in order to begin activation. Perhaps your IT folks just don't want to do it for you.

In any case, you cannot change the Vendor ID. I have O2 UK software on mine, and it still says my Vendor ID is 100, indicating that it is from T-Mobile USA.
__________________
I h8 txtspk.

Last edited by dc/dc : 11-07-2006 at 03:53 PM.
Offline  
Old 11-07-2006, 04:13 PM   #8 (permalink)
New Member
 
Join Date: Nov 2006
Location: Switzerland
Model: 8100
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Red face

Quote:
Originally Posted by dc/dc
All RIM devices are branded, but the Vendor ID shouldn't matter. BES is carrier agnostic, and should just need the PIN of your device in order to begin activation. Perhaps your IT folks just don't want to do it for you.

In any case, you cannot change the Vendor ID. I have O2 UK software on mine, and it still says my Vendor ID is 100, indicating that it is from T-Mobile USA.
Hi dc/dc

now that sounds interesting... a light at the horizon.. I wish it would be that easy.. it seems that you understand a lot..

Why they said that is, because we tried to activate our bb ok ? on the display we always have 'edge' written in small letters and in the middle there is a message 'Data connection refused'... and we (me and IT people) apparently tried everything but we didn't make it.. So their message was that it must be something with the 8100..

Because if I take my 7100v and put my SIM card in, then it works (or at least it just worked till I changed). We called the operator and let all my services rights delete on my card and re-set them, so that we're sure that we have the right to use bb services.. everything seems to be ok.

So you're saying that if I give them my PIN they should be able to activate it with that ?

Is it possible that our BES does not support 8100 yet, because I'm the first one having one, they will be released officially only in 3 months in Switzerland.

Thanks for your help.
Offline  
Old 11-07-2006, 05:18 PM   #9 (permalink)
CrackBerry Addict
 
MythmbHurts's Avatar
 
Join Date: Jun 2006
Location: New York City
Model: 8100
Posts: 642
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

your BB PIN number has to have the BES plan on it wich is given by your provider (vodafone correct) call them and make sure your SIM and BB PIN have and are able to have BES. What ever SIM card you put in tells the BB what Carrier ID should be... If you get data connection refused that means that there is no data service on that SIM card period. I dont think its a problem of the 8100 not being supported yet since many people in the states and over there have the 8100 on there BES and all BES software is the same. If the SIM card works in your 7100 it will work in your 8100 I still really think it a matter of the right services not being "turned on" by your provider... What carrier ID is shown with your SIM card in the 7100? Is your 8100 Unlocked? It has to be unlocked for it to work on another provider than it was issued from. Look up Blackberry carrier unlocking and you will see what I mean. If that 8100 is not unlocked it will not work!! Please check and make sure that the BB is. If you bought it from T-mobile then its locked to T-mobile period you have to pay like $30 to get it unlocked - then you can put what ever SIM in it you want and things will be fine. I can not stress the unlocking part enough since it wont work unless the BB is unlocked from the T-mobile network! Or as you put it SIM locked - YES they are!!!! Untill you get an unlock code and unlock the phone it will not work!
__________________
PIN:204D7C8C - USE THE SEARCH BUTTON!!!!
Yahoo: Whips_n_licks
Email:whips_n_licks@yahoo.com-Don't email me unless you searched!!
BB 8100 4.2.0.69
Offline  
Old 11-07-2006, 05:19 PM   #10 (permalink)
Spam Reporter
 
dc/dc's Avatar
 
Join Date: Oct 2005
Location: IAD
Model: 6230
Carrier: Voicestream
Posts: 14,530
Post Thanks: 220
Thanked 345 Times in 311 Posts
Default

Quote:
Originally Posted by sapguru
Hi dc/dc

now that sounds interesting... a light at the horizon.. I wish it would be that easy.. it seems that you understand a lot..

Why they said that is, because we tried to activate our bb ok ? on the display we always have 'edge' written in small letters and in the middle there is a message 'Data connection refused'... and we (me and IT people) apparently tried everything but we didn't make it.. So their message was that it must be something with the 8100..

Because if I take my 7100v and put my SIM card in, then it works (or at least it just worked till I changed). We called the operator and let all my services rights delete on my card and re-set them, so that we're sure that we have the right to use bb services.. everything seems to be ok.

So you're saying that if I give them my PIN they should be able to activate it with that ?

Is it possible that our BES does not support 8100 yet, because I'm the first one having one, they will be released officially only in 3 months in Switzerland.

Thanks for your help.
They should be able to activate it with your PIN. If your 7100v works, that is because your BES still has that PIN attached to your account. They need to change it to the PIN of your 8100.

Also, you may have to use your PC to activate it with the BES because you won't have the service books required to reach the BES. You will need Desktop Manager 4.2 in order for that to work.

Generally, the "Data connection refused" message comes up when there is a problem with the provider or your account with your provider, but again, since your 7100v is working, I don't think there is a problem with your Vodafone account.

I really would try to find out if your IT people know what they are doing.
__________________
I h8 txtspk.
Offline  
Old 11-07-2006, 05:23 PM   #11 (permalink)
Spam Reporter
 
dc/dc's Avatar
 
Join Date: Oct 2005
Location: IAD
Model: 6230
Carrier: Voicestream
Posts: 14,530
Post Thanks: 220
Thanked 345 Times in 311 Posts
Default

Quote:
Originally Posted by MythmbHurts
your BB PIN number has to have the BES plan on it wich is given by your provider (vodafone correct) call them and make sure your SIM and BB PIN have and are able to have BES. What ever SIM card you put in tells the BB what Carrier ID should be... If you get data connection refused that means that there is no data service on that SIM card period. I dont think its a problem of the 8100 not being supported yet since many people in the states and over there have the 8100 on there BES and all BES software is the same. If the SIM card works in your 7100 it will work in your 8100 I still really think it a matter of the right services not being "turned on" by your provider... What carrier ID is shown with your SIM card in the 7100? Is your 8100 Unlocked? It has to be unlocked for it to work on another provider than it was issued from. Look up Blackberry carrier unlocking and you will see what I mean. If that 8100 is not unlocked it will not work!! Please check and make sure that the BB is. If you bought it from T-mobile then its locked to T-mobile period you have to pay like $30 to get it unlocked - then you can put what ever SIM in it you want and things will be fine. I can not stress the unlocking part enough since it wont work unless the BB is unlocked from the T-mobile network! Or as you put it SIM locked - YES they are!!!! Untill you get an unlock code and unlock the phone it will not work!
He's already answered most of your questions. He has BlackBerry service, and his 8100 is unlocked. If it was not unlocked, he would receive the message, "Invalid SIM Card."
__________________
I h8 txtspk.
Offline  
Old 11-07-2006, 05:59 PM   #12 (permalink)
New Member
 
Join Date: Nov 2006
Location: Switzerland
Model: 8100
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Wink

Quote:
Originally Posted by dc/dc
He's already answered most of your questions. He has BlackBerry service, and his 8100 is unlocked. If it was not unlocked, he would receive the message, "Invalid SIM Card."
Hey dc/dc

I think you just gave me the hint I needed ! As you correctly stated, the SIM Lock is not an issue, because I can do phone calls and send/receive SMS.. but (!!) probably in the database my SIM is still connected to the PIN of my 7100v, I think that's it !

First thing tomorrow I will try that out, this is pure logic I think..

Thanks a lot for your help, I will let you know!

Have a nice day!
Offline  
Old 11-07-2006, 07:25 PM   #13 (permalink)
Spam Reporter
 
dc/dc's Avatar
 
Join Date: Oct 2005
Location: IAD
Model: 6230
Carrier: Voicestream
Posts: 14,530
Post Thanks: 220
Thanked 345 Times in 311 Posts
Default

Quote:
Originally Posted by sapguru
Hey dc/dc

I think you just gave me the hint I needed ! As you correctly stated, the SIM Lock is not an issue, because I can do phone calls and send/receive SMS.. but (!!) probably in the database my SIM is still connected to the PIN of my 7100v, I think that's it !

First thing tomorrow I will try that out, this is pure logic I think..

Thanks a lot for your help, I will let you know!

Have a nice day!
Excellent! I hope this works for you.
__________________
I h8 txtspk.
Offline  
Old 11-08-2006, 08:59 AM   #14 (permalink)
New Member
 
Join Date: Nov 2006
Location: Switzerland
Model: 8100
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy

Quote:
Originally Posted by dc/dc
Excellent! I hope this works for you.
Hi dc/dc

unfortunately, it's not working . We now think that we do not have the servicebooks on the device, so the bb can't find the server to connect (gateway) and so on.. And if we activate over the desktop manager, it doesn't need it.

Our operator doesn't have a page where we can download those like over webmail. Do you know how we can get the service books onto the bb ? I think we need to do the activation over the air, then it should work.

BTW our SIM and PIN are correct on the server...

Any idea ?

Thanks
Offline  
Old 11-08-2006, 09:31 AM   #15 (permalink)
CrackBerry Addict
 
MythmbHurts's Avatar
 
Join Date: Jun 2006
Location: New York City
Model: 8100
Posts: 642
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK im getting lost here. Your trying to set this up for work BES account. Is there an IT department you can take it to so they can run it on the desktop manager and make life easy? If your BB is lacking the proper sevice books I believe thats going to be the only way you can do it. You should have the correct service books on your 7100 right? If so just save a backup of that device and then transfer those service books to your 8100 using the desktop manager. Thats in the advanced part of backup/restore
__________________
PIN:204D7C8C - USE THE SEARCH BUTTON!!!!
Yahoo: Whips_n_licks
Email:whips_n_licks@yahoo.com-Don't email me unless you searched!!
BB 8100 4.2.0.69
Offline  
Old 11-08-2006, 10:06 AM   #16 (permalink)
New Member
 
Join Date: Nov 2006
Location: Switzerland
Model: 8100
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy

Quote:
Originally Posted by MythmbHurts
OK im getting lost here. Your trying to set this up for work BES account. Is there an IT department you can take it to so they can run it on the desktop manager and make life easy? If your BB is lacking the proper sevice books I believe thats going to be the only way you can do it. You should have the correct service books on your 7100 right? If so just save a backup of that device and then transfer those service books to your 8100 using the desktop manager. Thats in the advanced part of backup/restore
Hi

We were trying to run it on the desktop manager, we have that on our PC and we're connected to the network. I tried to backup the service books from my 7100v (thanks), but after I restored it on 8100, it didn't work. I still have 'edge' in small letters and 'data connection refused'.

But (!!) I think the IT guys are on the right track. Altough they said that they changed the SIM and PIN combination to our new PIN, apparently it wasn't done trough it. Now we just checked if we are in the HLR of the OpCo still registered with SIM & (old) PIN... They refreshed that too, but we're waiting, don't know how fast the HLR refreshes...

Altough we're desperate for a solution, I think we're on the right track.

I'll let you guys know.

(frustrated)

thanks
Offline  
Old 11-08-2006, 07:40 PM   #17 (permalink)
Spam Reporter
 
dc/dc's Avatar
 
Join Date: Oct 2005
Location: IAD
Model: 6230
Carrier: Voicestream
Posts: 14,530
Post Thanks: 220
Thanked 345 Times in 311 Posts
Default

Quote:
Originally Posted by sapguru
Hi dc/dc

unfortunately, it's not working . We now think that we do not have the servicebooks on the device, so the bb can't find the server to connect (gateway) and so on.. And if we activate over the desktop manager, it doesn't need it.

Our operator doesn't have a page where we can download those like over webmail. Do you know how we can get the service books onto the bb ? I think we need to do the activation over the air, then it should work.

BTW our SIM and PIN are correct on the server...

Any idea ?

Thanks
Yeah, if you don't have the service books, you'll need to activate with the Desktop Manager. Make sure that when you installed the Desktop Manager on your PC that you chose the BES option.
__________________
I h8 txtspk.
Offline  
Old 11-09-2006, 03:47 AM   #18 (permalink)
New Member
 
Join Date: Nov 2006
Location: Switzerland
Model: 8100
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Wink

Quote:
Originally Posted by dc/dc
Yeah, if you don't have the service books, you'll need to activate with the Desktop Manager. Make sure that when you installed the Desktop Manager on your PC that you chose the BES option.
hi dc/dc

thanks! Yes we did that, but it's not working... I don't think that we have a problem on our device, it's like you said it's something on the network... I think we're really near to the solution. The responsible guy in IT said that he has to check something on the relay of the bb server, check if my e-mail address is connected to the right PIN. Apparently in the BES db everything is correct..

I hope we'll solve that today, I'll let you know...
Offline  
Old 11-10-2006, 04:17 AM   #19 (permalink)
New Member
 
Join Date: Nov 2006
Location: Switzerland
Model: 8100
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy

Quote:
Originally Posted by sapguru
hi dc/dc

thanks! Yes we did that, but it's not working... I don't think that we have a problem on our device, it's like you said it's something on the network... I think we're really near to the solution. The responsible guy in IT said that he has to check something on the relay of the bb server, check if my e-mail address is connected to the right PIN. Apparently in the BES db everything is correct..

I hope we'll solve that today, I'll let you know...
Hi dc/dc

now I'm completely frustrated . The situation is as follows: They checked everything on my contracts with the provider and so on. The problem is, that my bb 8100 is blocked in the relay of bb in London. We bought those (2 bb) at T-Mobile in Germany, without any SIM lock. Now the IT people believe that on the 8100 is a new technology and a new client installed. They assume that this new client, when the device is turned on the first time, sends out a 'register code' to the Relay saying to whom it belongs (in our case to T-Mobile). But because we have at Swisscom (Vodafone) the bb Relay blocks it in London.

Do you know something about this ? Is there really some client on the bb who send a carrier code out the first time we turn it on ? You said yours works fine with O2 in UK, altough it's a T-Mobile USA device right ? Is it possible that T-Mobile Germany does that thing and T-Mobile USA not ?

If you know something, I would really appreciate your help/hint...

Thanks
Offline  
Old 11-10-2006, 09:34 AM   #20 (permalink)
New Member
 
Join Date: Nov 2006
Location: Switzerland
Model: 8100
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Red face

hi dc/dc

apparently we found it. Our IT services couldn't solve it but could give a hint, as mentioned above.

I called the support of T-Mobile and the guy there told me in 2 minutes what the problem is. Apparently T-Mobile Germany is one or the only vendor who has 2 bb 8100 version, one for Enterprise server and one for Webmail.. and as murphy is not sleeping, we of course have got the webmail ones... so they will never work with BES, we have to exchange the handsets.

Thanks for your help till now!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.