BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-01-2007, 03:12 AM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Jan 2007
Location: Colorado Springs, CO
Model: Pearl
Carrier: Cingular
Posts: 103
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Vista Drivers?

Please Login to Remove!

I just installed Vista on my Dell XPS M170. I searched for Bluetooth devices and it immediately found my Pearl (something that XP refused to do).

I went through the pairing process, but asked for a driver disc. I put in the Desktop Manager disc that came with my Pearl, but it couldn't anything on there. There is also no real driver section on the Blackberry website.

What do I do??
Offline  
Old 02-01-2007, 09:12 AM   #2 (permalink)
CrackBerry Addict
 
JerryD's Avatar
 
Join Date: Oct 2005
Location: Brooklyn, NY
Model: 9000
OS: 5.0.0.106
Carrier: AT&T
Posts: 877
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Flapjack
I just installed Vista on my Dell XPS M170. I searched for Bluetooth devices and it immediately found my Pearl (something that XP refused to do).

I went through the pairing process, but asked for a driver disc. I put in the Desktop Manager disc that came with my Pearl, but it couldn't anything on there. There is also no real driver section on the Blackberry website.

What do I do??
I honestly don't know, but as far as I've heard the BlackBerry wants to use the standard Microsoft Bluetooth Driver. See if you can select one from a list.
__________________
.
.
J

Offline  
Old 02-01-2007, 09:18 AM   #3 (permalink)
Talking BlackBerry Encyclopedia
 
billclark's Avatar
 
Join Date: Mar 2006
Location: Framingham, MA
Model: 8120
Carrier: AT&T
Posts: 253
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

You have to install Desktop Manager 4.2, available for download from RIM here: https://www.blackberry.com/Downloads...93E4F3BB068C22

From the drop down menu, choose Blackberry Desktop Software 4.2. That will install the blackberry drivers.
__________________
Bill Clark
AT&T 8120 Unlocked | AT&T | BES 4.1
PM for PIN

When I was your age, Pluto was still a planet.
Offline  
Old 02-01-2007, 10:52 AM   #4 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Oct 2006
Model: 8900
Carrier: t-mobile
Posts: 227
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I bought Vista Ultimate, but want to hold off...seems like a lot of issues with compatibility. Thanks for the info here! :D
Offline  
Old 02-01-2007, 12:22 PM   #5 (permalink)
Thumbs Must Hurt
 
Join Date: Jan 2007
Location: Colorado Springs, CO
Model: Pearl
Carrier: Cingular
Posts: 103
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

It connects just fine. The problem is once it's connected, Device Manager finds two hardware items that it will not install drivers for, even though I've installed Desktop Manager 4.2.

I'm assuming the two items in Device Manager are the two virtual serial ports...
Offline  
Old 02-01-2007, 02:27 PM   #6 (permalink)
Talking BlackBerry Encyclopedia
 
billclark's Avatar
 
Join Date: Mar 2006
Location: Framingham, MA
Model: 8120
Carrier: AT&T
Posts: 253
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

If you click the little balloon that says "Some devices failed to install, click here for information", it will give you a list of devices and what happened with them. What are the actual device names that it gives?
__________________
Bill Clark
AT&T 8120 Unlocked | AT&T | BES 4.1
PM for PIN

When I was your age, Pluto was still a planet.
Offline  
Old 02-02-2007, 02:35 PM   #7 (permalink)
Thumbs Must Hurt
 
Join Date: Jan 2007
Location: Colorado Springs, CO
Model: Pearl
Carrier: Cingular
Posts: 103
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I don't get that bubble... I get "Windows was unable to install your Bluetooth Peripheral Device.

If I go into Device Manager, they're also called Bluetooth Peripheral Devices.

I'm pretty sure they're the virtual serial ports RIM installs when you first plug in your phone. Not sure why they're not automatically installing in Vista.
Offline  
Old 02-02-2007, 02:37 PM   #8 (permalink)
Thumbs Must Hurt
 
Join Date: Jan 2007
Location: Colorado Springs, CO
Model: Pearl
Carrier: Cingular
Posts: 103
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Actually, it did pop up after the second one. See the attached image (same name as above).
Attached Thumbnails
Vista Drivers?-error.jpg  
Offline  
Old 02-02-2007, 03:41 PM   #9 (permalink)
Thumbs Must Hurt
 
Join Date: Jan 2007
Location: Colorado Springs, CO
Model: Pearl
Carrier: Cingular
Posts: 103
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by billclark
If you click the little balloon that says "Some devices failed to install, click here for information", it will give you a list of devices and what happened with them. What are the actual device names that it gives?
Love your sig!!
Offline  
Old 02-02-2007, 05:06 PM   #10 (permalink)
Talking BlackBerry Encyclopedia
 
billclark's Avatar
 
Join Date: Mar 2006
Location: Framingham, MA
Model: 8120
Carrier: AT&T
Posts: 253
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Are you using the Microsoft-provided Bluetooth stack/drivers for your Bluetooth adapter in your computer, or has your manufacturer released their own Vista-compatible drivers? I had problems pairing my Dell Wireless 350 Bluetooth Module with some devices until Dell finally released their own drivers for the device. Once that was in place, all my pairing issues went away. Sadly, I cannot tell you whether or not it would have solved an issue with my Pearl, because I got the new BB last week, after I already had the new Dell provided drivers installed.
__________________
Bill Clark
AT&T 8120 Unlocked | AT&T | BES 4.1
PM for PIN

When I was your age, Pluto was still a planet.
Offline  
Old 02-02-2007, 07:34 PM   #11 (permalink)
Thumbs Must Hurt
 
Join Date: Jan 2007
Location: Colorado Springs, CO
Model: Pearl
Carrier: Cingular
Posts: 103
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by billclark
Are you using the Microsoft-provided Bluetooth stack/drivers for your Bluetooth adapter in your computer, or has your manufacturer released their own Vista-compatible drivers? I had problems pairing my Dell Wireless 350 Bluetooth Module with some devices until Dell finally released their own drivers for the device. Once that was in place, all my pairing issues went away. Sadly, I cannot tell you whether or not it would have solved an issue with my Pearl, because I got the new BB last week, after I already had the new Dell provided drivers installed.
I'm using the Microsoft BT stack that comes with Vista. Before, I was using the Toshiba stack on XP. It detected the drivers no problem, but I couldn't sync over BT with Desktop Manager...

This is definitely a driver issue, not a BT issue. As I said, for the first time ever, Desktop Manager actually picked up the phone this time. It did not when I was running XP and the Toshiba BT stack.
Offline  
Old 02-15-2007, 02:15 PM   #12 (permalink)
Thumbs Must Hurt
 
Join Date: Jan 2007
Location: Colorado Springs, CO
Model: Pearl
Carrier: Cingular
Posts: 103
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

There are two updates on the BB support page now, dated Feb 6th 2007. I'm gonna install them now.

There is a Desktop Manager 4.2 SP1 and a 4.2 SP1 Device Manager software.
Offline  
Old 02-16-2007, 08:10 PM   #13 (permalink)
Talking BlackBerry Encyclopedia
 
wobly's Avatar
 
Join Date: Jan 2007
Location: Colorado Springs, CO
Model: 8900
OS: 5.0.0.411
Carrier: T-Mobile
Posts: 235
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

I have had no problems syncing my Pearl with Vista. I just told Vista to not ask me to update the drivers for those two Bluetooth Peripheral devices.

I will try the new DM, though.

EDIT: I just read the release notes for DM 4.2 SP1

"New in this release
• System administrators can limit the types of certificates and encryption keys that appear in the Certificate Synch tool of the BlackBerry Desktop Manager.
• All 64-bit versions of Microsoft® Windows® XP, Windows 2003 Server and Microsoft Windows Vista™ are now supported"


Last edited by wobly : 02-16-2007 at 08:13 PM.
Offline  
Old 02-17-2007, 01:31 AM   #14 (permalink)
New Member
 
05slvrscape's Avatar
 
Join Date: Nov 2006
Location: BC, Canada
Model: 8100
Carrier: Rogers
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had no problem with my Pearl on Vista Ultimate. I installed the HP drivers for my bluetooth and it works with that. Vista had 2 unknown bluetooth devices for me when not using the HP drivers after installed they disappeard and I can still sync via bluetooth. Try you manufacturers drivers. I think this is a problem with Bluetooth 2.0
__________________
Pin: 206B9B53
Offline  
Old 02-17-2007, 11:35 AM   #15 (permalink)
BlackBerry Extraordinaire
 
Join Date: Nov 2006
Location: CT
Model: 9550
OS: 5.0
Carrier: ATT
Posts: 1,137
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by 05slvrscape
I had no problem with my Pearl on Vista Ultimate. I installed the HP drivers for my bluetooth and it works with that. Vista had 2 unknown bluetooth devices for me when not using the HP drivers after installed they disappeard and I can still sync via bluetooth. Try you manufacturers drivers. I think this is a problem with Bluetooth 2.0

manufacturer as in Blackberry or the computer manufacturer?
__________________
Fred
Offline  
Old 02-17-2007, 07:51 PM   #16 (permalink)
Thumbs Must Hurt
 
celly's Avatar
 
Join Date: May 2005
Location: Calgary
Model: 9000
OS: WB 8.2
Carrier: Bell
Posts: 126
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by wobly
I have had no problems syncing my Pearl with Vista. I just told Vista to not ask me to update the drivers for those two Bluetooth Peripheral devices.
That error message was driving me nuts. I followed your lead and told Vista not to hassle me any more too. Bluetooth syncing works great with my 7250. I'm using Desktop 4.2 SP1 so I'm also not dealing with that annoying time zone reset either. I think I'm finally over the Vista hurdle with Blackberry.

Now if only I could get my HP 1020 printer to work.
Offline  
Old 02-18-2007, 10:07 AM   #17 (permalink)
Talking BlackBerry Encyclopedia
 
wobly's Avatar
 
Join Date: Jan 2007
Location: Colorado Springs, CO
Model: 8900
OS: 5.0.0.411
Carrier: T-Mobile
Posts: 235
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by celly
Now if only I could get my HP 1020 printer to work.

I have an HP LJ 1012 and it took a few reboots and power-on/off's of the printer for it to recognize, but Vista did recognize it.
Offline  
Old 02-18-2007, 05:20 PM   #18 (permalink)
Thumbs Must Hurt
 
celly's Avatar
 
Join Date: May 2005
Location: Calgary
Model: 9000
OS: WB 8.2
Carrier: Bell
Posts: 126
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by wobly
I have an HP LJ 1012 and it took a few reboots and power-on/off's of the printer for it to recognize, but Vista did recognize it.
According to HP, 1012 drivers were included with Vista. Not the 1020 however. I have a 1012 printer at work that works no problem when I log in via Remote Desktop. HP claims they'll have 1020 drivers in the "first 1/2 of 2007". What a joke. Probably their biggest selling printer right now and they don't have Vista support. There are several workarounds posted all over the web, but not worked for me.
Offline  
Old 09-07-2007, 06:09 PM   #19 (permalink)
BlackBerry Extraordinaire
 
Join Date: Nov 2006
Location: CT
Model: 9550
OS: 5.0
Carrier: ATT
Posts: 1,137
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Flapjack View Post
Actually, it did pop up after the second one. See the attached image (same name as above).
I get the same exact error screen! I can pair my Pearl between it and the Vista LAptop BUT when I go to BB Desktop Software Connection settings and try to detect, it fails to install the right driver and I get this error screen ! Damn!
__________________
Fred
Offline  
Old 09-07-2007, 07:00 PM   #20 (permalink)
New Member
 
Join Date: Sep 2007
Model: 8100
PIN: N/A
Carrier: t-mobile
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default modem problem (8100)

I check on my modem properties on QUERRY it show command not supported
can please somebody help me!!!!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.