BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 03-14-2007, 08:52 PM   #1 (permalink)
New Member
 
Join Date: Mar 2007
Location: AZ
Model: 8100
Carrier: TMO
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Getting my own domain email from Google Apps

Please Login to Remove!

Hi Guys,

I've been lurking around for a while and reading alot since i got my new pearl.... Its damn cool ;)

But, one thing ive been trying to do is driving me crazy...

I have my own domain like a small business lets say its "domain.com" i have an email "myself@domain.com". Now google has a new program called google apps that allows you to transfer your domain email to google and setup gmail accounts for your small business email accounts...

So for instance i would go to mail.google.com/a and login using my business email as "myself@domain.com" and my password and it would log me into my business account.

For the last several days i have been trying to set this account up on my BB but to no avail the email doesnt show up.

Anyone know how to set this up? This is technically a domain email that is simply hosted with gmail so the email is not "x@gmail.com" but i can access it through gmail.

Any tips would be more than welcome as its driving me crazy

Thanks,
Karim0028
Offline  
Old 03-14-2007, 09:05 PM   #2 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Wirelessly posted (8700g: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0) BlackBerry8700/4.1.0 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/100)

I assume you are on BIS, so set it up at your BIS setup just as directed using your email "myself@domain.com" and the password.

Good luck.
Offline  
Old 03-14-2007, 09:11 PM   #3 (permalink)
Thumbs Must Hurt
 
churchill's Avatar
 
Join Date: Jan 2007
Location: seattle
Model: 8320
PIN: 2423A5E5
Carrier: tmobile
Posts: 100
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I just did this the other day. Go thru the google apps setup process and create your email name with your new domain. (IM assuming your a tmo customer). You then have to go to the tmo BIS site and set up that email so its pushed to your phone. Google also has an applet that lets you log onto the email and look at it, but I prefer the push method. Post back here is this doesnt make sense to you.
Offline  
Old 03-14-2007, 09:12 PM   #4 (permalink)
New Member
 
Join Date: Mar 2007
Location: AZ
Model: 8100
Carrier: TMO
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

thats what i have been doing... Its not working....
Offline  
Old 03-14-2007, 09:14 PM   #5 (permalink)
New Member
 
Join Date: Mar 2007
Location: AZ
Model: 8100
Carrier: TMO
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

churchill,

Now, your saying that i cant do this through the setup email account through the BB, i have to do it through TMO?

BC i did it through the BB, it says everything is setup fine, but i dont get any of the email.....
Offline  
Old 03-14-2007, 09:35 PM   #6 (permalink)
New Member
 
Join Date: Mar 2007
Location: AZ
Model: 8100
Carrier: TMO
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

So, i went into the tmobile BIS and tried to alter the server that it goes to. But, it keeps giving me errors.... When i setup the google apps account it makes you change your DNS MX Entry to ASPMX.L.GOOGLE.COM but i tried altering that in Tmobile BIS (under the server section) and it gave me errors....

If someone can help me it would be much appreciated, what am i doing wrong?

Karim0028
Offline  
Old 03-15-2007, 01:50 AM   #7 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Sep 2006
Location: Toronto, Ontario
Model: Bold
Carrier: Rogers Wireless
Posts: 201
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by karim0028
So, i went into the tmobile BIS and tried to alter the server that it goes to. But, it keeps giving me errors.... When i setup the google apps account it makes you change your DNS MX Entry to ASPMX.L.GOOGLE.COM but i tried altering that in Tmobile BIS (under the server section) and it gave me errors....

If someone can help me it would be much appreciated, what am i doing wrong?

Karim0028
i use google apps. this is VERY easy to setup

when u do just ur email and password ur doesnt work right? well thats because by default it tried mail.yourdomain.com and pop.yourdomain.com etc, but its actually google handling ur email

so try AGAIN and when it gives u the error there will be an option for "advanced" and then u can MANUALLY tell it what ur email server address is. just set it to "pop.gmail.com" and then leave ur email/user as [email address] and thats it!

sounds easy doesnt it.... thats because it is

and i also suggest trying the new google apps bb mail program. they have had a gmail client for bb for a while now but it wasnt compatible with google apps email accoutns. this new one is

cheers
Offline  
Old 03-15-2007, 10:21 AM   #8 (permalink)
Thumbs Must Hurt
 
churchill's Avatar
 
Join Date: Jan 2007
Location: seattle
Model: 8320
PIN: 2423A5E5
Carrier: tmobile
Posts: 100
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I use both the google app client (it has a blue mail icon, instead of the red one) AND the push email from tmo bis. I did NOT have any of the problems you are describing in setting up on tmo, but heres two things to check that may help. First, you need to turn ON the POP mail option of your xxxx.mydomain.com gmail account. Then you also MAY need to do a service book send from that send page. Those two things should have you up and going. Failing that, I have had good luck with the TMO bberry support group, so give them a call if all else fails, they know they're stuff more than I thought they would.
Offline  
Old 03-15-2007, 11:49 AM   #9 (permalink)
Knows Where the Search Button Is
 
skawt's Avatar
 
Join Date: Jan 2007
Location: San Mateo, CA
Model: 8320
OS: 4.5.0.xx
Carrier: T-Mobile
Posts: 49
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

One of the main problems I had with Google Apps For Your Domain (GAFYD) was that forwarding is not properly implemented on Google's side. They ignore RFC specifications for mail forwarding. So if I sent e-mail from myself, to myself, it would not get forwarded. Only inbound mail from other people would get forwarded.

Also, no IMAP connectivity. Yes, they have POP and SMTP, but IMAP with SSL connectivity was important to me.

In order to have mail delivered to me immediately with GAFYD, I would set up my mailbox on Google to forward to my Blackberry account, and then set the sender address on my Blackberry account to be that of my Google account. The only other way to receive my email immediately would be to use the blue icon Gmail app instead of the default Blackberry email app. If you don't forward or use the Gmail app, it takes 15 minutes before mail would appear in your inbox due to the limitation of scheduled polling instead of push email delivery.

I've since gone back to hosting my email on my own server, and forward to the blackberry.net account. Mail is delivered instantly, forwarding works properly, and I have much better spam filtering.
Offline  
Old 03-15-2007, 12:57 PM   #10 (permalink)
New Member
 
Join Date: Mar 2007
Location: AZ
Model: 8100
Carrier: TMO
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

"In order to have mail delivered to me immediately with GAFYD, I would set up my mailbox on Google to forward to my Blackberry account, and then set the sender address on my Blackberry account to be that of my Google account. The only other way to receive my email immediately would be to use the blue icon Gmail app instead of the default Blackberry email app. If you don't forward or use the Gmail app, it takes 15 minutes before mail would appear in your inbox due to the limitation of scheduled polling instead of push email delivery."

Now, the setup that i have is that i have my email forwarded to my personal gmail account so i get the mail to my blackberry through my personal gmail BUT, i cant get the reply (from) to seem like its coming from my work email it replies back as my personal gmail.....

Is there a way around that?

Eg: "work@work.com" email gets forwarded to "personal@gmail.com" i setup my BIS with "pesonal@gmail.com" so i get it on my BB. BUT, when i reply email shows the "from" address as "personal@gmail.com" when i want it to be "work@work.com"

-karim0028
Offline  
Old 03-15-2007, 01:41 PM   #11 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Quote:
Originally Posted by karim0028

Now, the setup that i have is that i have my email forwarded to my personal gmail account so i get the mail to my blackberry through my personal gmail BUT, i cant get the reply (from) to seem like its coming from my work email it replies back as my personal gmail.....

Is there a way around that?

Eg: "work@work.com" email gets forwarded to "personal@gmail.com" i setup my BIS with "pesonal@gmail.com" so i get it on my BB. BUT, when i reply email shows the "from" address as "personal@gmail.com" when i want it to be "work@work.com"

-karim0028
Yes, the way around the "reply from" problem is to install your work domain as BIS... without which, it is not installed as part of your BB, therefore you cannot reply from it... You can't have your cake and eat it too.
Offline  
Old 03-15-2007, 03:29 PM   #12 (permalink)
New Member
 
Join Date: Mar 2007
Location: AZ
Model: 8100
Carrier: TMO
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I guess i may not be making it clear.... Getting my work email (which is hosted through Google Apps) as part of the BIS is my intent, BUT, its not working........... That was the intent of my original posting....
Offline  
Old 03-16-2007, 02:43 PM   #13 (permalink)
New Member
 
Join Date: Mar 2007
Location: AZ
Model: 8100
Carrier: TMO
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

bumpty bump.... anybody out there able to help me get this working? I am still not able to get Google Apps working, any other tips im missing?

Thanks in advance
Offline  
Old 03-17-2007, 04:05 PM   #14 (permalink)
Talking BlackBerry Encyclopedia
 
netPOSER's Avatar
 
Join Date: Jun 2005
Model: 9800
Carrier: ATT
Posts: 210
Post Thanks: 0
Thanked 0 Times in 0 Posts
Lightbulb

Quote:
Originally Posted by karim0028
I guess i may not be making it clear.... Getting my work email (which is hosted through Google Apps) as part of the BIS is my intent, BUT, its not working........... That was the intent of my original posting....
I think I tried this the first day Google released Gmail for the BB and I read somewhere it will only work for @gmail.com accounts. Only personal gmail accounts.

My memory is a bit fuzzy on the details though but I'll check.

Edit****
I noticed on this page "Mobile Access" is available for both the free and paid versions:
Google Apps
I just setup another domain so in a few hours I'll know if it works.

Edit***
Try this link:
Google Apps
You will need the "Blue" Gmail icon to use "Mail by Google" for your domain.
Here's what it says at the bottom of the page:
If you currently use the Gmail for mobile application on your Blackberry, you'll need to download the mobile application for Google Apps as well. Gmail for mobile is a different application and is available for download at Gmail (gmail.com/app). A red M icon will appear for Gmail and a blue M icon will appear for Mail by Google (Google Apps).
I just downloaded the Java App for "Mail by Google" and now I have a blue "M" icon that allows me to use my domain email that I configure for Mail by Google.

Last edited by netPOSER : 03-17-2007 at 07:43 PM.
Offline  
Old 03-17-2007, 08:44 PM   #15 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Location: Edmonton, AB
Model: Pearl
Carrier: Rogers
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

h t t p : / / w w w.google.com/support/a/bin/answer.py?answer=33384&topic=10743

(had to put the spaces in because it won't let me link to external sites)

some points (from memory i set it up a while ago)
- make sure pop is activated in the google apps (gmail) options
- your user id is your full email address

Hope that helps. Mine works great.
Offline  
Old 03-17-2007, 08:49 PM   #16 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Location: Edmonton, AB
Model: Pearl
Carrier: Rogers
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

h t t p : / / m a i l.google.com/support/bin/answer.py?answer=14748

oh here's the other page I used when first setting it up. Follow these instructions and the ones from my first post and all should work fine.
Offline  
Old 03-17-2007, 09:12 PM   #17 (permalink)
New Member
 
Join Date: Mar 2007
Location: AZ
Model: 8100
Carrier: TMO
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

What do i have to do to setup POP? What does setting POP do? From my understanding thats if your trying to get your email on outlook or something... But, you do have to use the POP servers mentioned and with the BB i dont see anyway to incorporate the POP servers mentioned. I went and enabled it but still nothing... I've got to be missing something.

I went to my google apps account and enabled POP... Now, in the insturcitons you refer to above they mention ingoing and outgoing servers. smtp.gmail.com and pop.gmail.com do i have to do anything with those?

The problem i think comes from the fact that in TMO IBS the default mail server is mail."mydomain".com, but since im not on that server nothing comes through and every time i try to change it TMO gives me an error....
Offline  
Old 03-17-2007, 09:32 PM   #18 (permalink)
New Member
 
Join Date: Mar 2007
Location: AZ
Model: 8100
Carrier: TMO
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

BTW, Netposer, what i believe your referring to is actually just checking your mail using the google appliication. Which i can easily do, i want my work/small business mail that is hosted on google but uses "myowndomain.com" to be pushed to my BB.

Again, so the email address goes something like this:

[email address] its not a .gmail.com account but i can access my email through the google.com/a

Its not an enterprise server or anything like that, its a small business solution that google offers.....
Offline  
Old 03-17-2007, 09:34 PM   #19 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Location: Edmonton, AB
Model: Pearl
Carrier: Rogers
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok I'll try and explain a bit better.

First enable POP in your google apps mail settings (you said you did that already so it should be good.)

Then log on to your blackberry internet service.

Then add a new email account and for the user id.. use your whole email address: [email address]

Beside the 'general' tab in the settings there should be an 'advanced' tab also... click that (I'm using rogers blackberry internet service but i think they are all the same).

For server put in pop.gmail.com

I also had to check the box next to SSL for it to work.

That's it.. hit save and hopefully you get an email on your blackberry saying that it worked.

*crosses fingers*
Offline  
Old 03-17-2007, 09:38 PM   #20 (permalink)
Knows Where the Search Button Is
 
Join Date: Apr 2005
Location: Edmonton, AB
Model: Pearl
Carrier: Rogers
Posts: 15
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Btw, you are setting up pop on your blackberry the same way you do for outlook etc and no you do not have to use the smtp at all... just the pop.gmail.com setting.

And for the record I'm using my own domain name with the free version of google apps the same as you are trying to do and I love it.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.