BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-13-2007, 09:45 AM   #1 (permalink)
New Member
 
Join Date: Jan 2006
Location: Dublin, Ireland
Model: 8100
Carrier: Vodafone Ireland
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Show "My Number"

Please Login to Remove!

In recent days people I call tell me that my number appears as 'Private' rather than displaying my name. I've had the Pearl for a few months and this has not been an issue until now.

Working in a large organisation one always suspect that the techies have changed some config setting or other when an unknown issue suddenly appears - maybe not. I've double-checked that Show My Number is switched to Yes (also Restrict My Identity is set to No - don't know if that's relevant). I've seen other posts re. Smart Dialling settings but don't know if relevant here ... country code is set ok.

My next step will be to remove the battery and re-boot - this seems to work for some apparently intractable problems!! Before I resort to such last-gasp efforts does anyone have other suggestions/ideas?
Offline  
Old 04-13-2007, 10:28 AM   #2 (permalink)
Knows Where the Search Button Is
 
Helno's Avatar
 
Join Date: Dec 2006
Location: Athens, Ohio
Model: 8100
Carrier: Cingular
Posts: 29
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

who is your carrier? Cingular/ATT offers a 'feature' that lets you block your Name. If you have web access to your account, make sure this hasn't been checked, or call customer service and ask them if it is active.
__________________
"Do things you really care about. You're going to be dead much longer than you're going to be alive"
-Unknown
Offline  
Old 04-13-2007, 10:53 AM   #3 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

cyril, Try the reboot option, yes. And, yes it could be an IT policy.

Also, look at Options, Advanced, SIM Card and make sure your phone number is entered there.
Offline  
Old 04-13-2007, 12:37 PM   #4 (permalink)
New Member
 
Join Date: Mar 2007
Location: Utah
Model: 8100
Carrier: T Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Try pushing the green button on your phone and then options and then general options. Make sure where it says "Restrict My Identity" it says no. If it says yes then that may be why it was doing that???
Offline  
Old 04-13-2007, 02:04 PM   #5 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Thanks, Ciera. The original poster stated at the top that was set correctly.
Offline  
Old 04-13-2007, 02:15 PM   #6 (permalink)
New Member
 
Join Date: Jan 2006
Location: Dublin, Ireland
Model: 8100
Carrier: Vodafone Ireland
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks J - my phone number is NOT there, just a very long "ID" ... 19 digits (not the IMEI or PIN). I'll let everyone know if a re-boot does the trick later!
Offline  
Old 04-17-2007, 09:57 AM   #7 (permalink)
New Member
 
Join Date: Jan 2006
Location: Dublin, Ireland
Model: 8100
Carrier: Vodafone Ireland
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Show "My Number"

I'm back .... alas, several re-boots have failed to resolve the problem The search continues so if anyone has new suggestions....??

Last edited by 1cyril1 : 04-17-2007 at 09:59 AM.
Offline  
Old 04-17-2007, 10:38 AM   #8 (permalink)
New Member
 
alwin Dyson's Avatar
 
Join Date: Apr 2007
Model: 8100
PIN: N/A
Carrier: 02
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by JSanders View Post
cyril, Try the reboot option, yes. And, yes it could be an IT policy.

Also, look at Options, Advanced, SIM Card and make sure your phone number is entered there.
Thanks for the info, half the geeks in O2 in the UK are trying to solve the MY NUMBER issue for me 11/10 top guy
Offline  
Old 04-17-2007, 10:44 AM   #9 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Quote:
Originally Posted by 1cyril1 View Post
I'm back .... alas, several re-boots have failed to resolve the problem The search continues so if anyone has new suggestions....??
Cyril... maybe I missed it if you stated you have done so, but at Options, Advanced, SIM Card, enter your cell phone number there.
Offline  
Old 04-17-2007, 12:22 PM   #10 (permalink)
New Member
 
Join Date: Jan 2006
Location: Dublin, Ireland
Model: 8100
Carrier: Vodafone Ireland
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

... yep, see my reply to you on 13th April.

In Options/Advanced/SIM Card I do get an option to Edit SIM Phone Number which prompts me to enter a "SIM Phone Number" but I'm loathe to interfere with the 19 digit number already there!! Remember, name display wasn't a problem until recently and I doubt greatly that anyone changed my settings (from the server)!

If I decide to enter my telephone number do you know what format is best e.g. + versus 00 prefix? I'm assuming the 19 digit code is a security/PIN number? if it is, would my "SIM Phone Number" be added as a second entry if I proceed?
Offline  
Old 04-17-2007, 12:27 PM   #11 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Cyril,.. I read your 13 April reply, that you see a 19 digit number, that is the SIM ID #. Which is why I asked the question again. You want to edit and input your phone number. It will NOT interfere with the ID#.

I am not sure about Ireland, but I would advise to enter the phone number without the country code. Enter your country code in the Smart Dialing feature.
Offline  
Old 04-17-2007, 01:02 PM   #12 (permalink)
New Member
 
Join Date: Jan 2006
Location: Dublin, Ireland
Model: 8100
Carrier: Vodafone Ireland
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks J ... really appreciate all of your help on this!

I've loaded my number both with/without the leading '0' (Smart Dialing already has +353 for country code; area code is blank). I also re-booted again, just to be sure, but alas no success yet. I'm waiting to hear back from our techies so they may have another angle on it.

Note: one advantage of entering my Phone No. is that I can see it at top of screen when the green button is pressed (lest I forget ). I get a short 'registration' email each time I change the number but am hoping this won't be repeated after each re-boot.
Offline  
Old 04-17-2007, 01:08 PM   #13 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

OK, well, you are getting there. Try it a couple different formats, for instance, in mine, I have the leading 1 in front of our area code.

I am pretty certain the lacking phone number is the issue restricting your ID showing to others.

Last edited by JSanders : 04-17-2007 at 04:21 PM.
Offline  
Old 04-17-2007, 05:00 PM   #14 (permalink)
New Member
 
Join Date: Apr 2007
Model: 8100c
PIN: N/A
Carrier: Cingular
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi there. FYI, there is a known bug out there in Cingular's switch that is causing your phone number to appear as private. If anything has been done to your account within the past two weeks or so, then it would have caused this issue. I had the same problem with mine. You'll need to call your provider (whether that be a direct Cingular store or an authorized retailer) and have them remove the Per Call Blocking Feature (for now) and that should fix your problem. After Cingular is able to resolve the feature problem, the rep will then need to add it back to your account.

I hope this helps!!!
Offline  
Old 04-17-2007, 05:14 PM   #15 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Thanks ccvalentine. The user is on Vodafone in Ireland, in this case, however.
Offline  
Old 05-04-2007, 05:41 AM   #16 (permalink)
New Member
 
Join Date: Jan 2006
Location: Dublin, Ireland
Model: 8100
Carrier: Vodafone Ireland
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

By way of wrap-up on this .... all is well again, the phone provider reset my SIM card at the request of our techie folk. Based on other posts it would appear that the provider should be the first port of call for all similar probs!! Not only that but be persistent as my company has had to do to resolve what had been considered "random anomalous issues" - riddle me that;-/

Many thanks for all the helpful suggestions on this - greatly appreciated!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.