BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 05-23-2007, 09:44 PM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Model: 8100
Carrier: TMobile
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Problems with email after unlocking Pearl...

Please Login to Remove!

Hey guys, I recently posted a thread about having my plan changed. Well, I had it changed with no issues. While on the phone with a TMobile customer service agent, I also had my phone unlocked (well, the request was made and an email sent with my unlock code).

After inputting in the code, I havent been receiving my emails. Also, instead of saying that my service provider is TMobile on my home screen, it just says "DATA CONNECTION..."

Has anyone else have similar issues? Is there a way to fix this? E-mails are an important reason why I pay for the unlimited data plan ;)

Thanks,

Jason
Offline  
Old 05-23-2007, 09:52 PM   #2 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Wirelessly posted (8700g: BlackBerry8700/4.1.0 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/100)

It sounds like your BlackBerry might now be unlocked if you are getting a message "Data Connection..." Which probably ends in Refused.
Look at the link here to determine if your BlackBerry is unlocked.."How can I tell if my BlackBerry is Unlocked":
http://www.blackberryfaq.com/index.php/Main_Page
How many times did you inout the code?
Offline  
Old 05-23-2007, 10:09 PM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Model: 8100
Carrier: TMobile
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the link, I will take a look into it shortly.

I inputted the code twice. The first time it was rejected (probably a mistake on my part). I inputted it a second time and everything seemed fine from there.

Taking a look at the link... now!

Thanks!

Edit: Just took a look and it is definitely unlocked now. So what's up with my emails?

Edit: BTW, I am following the "My Email Stopped Arriving" guide right now. Just tried re-registering with my network. Hope this works. If not, I'll go ahead and send in the service books as well.

Last edited by jasonjoo : 05-23-2007 at 10:12 PM.
Offline  
Old 05-23-2007, 10:16 PM   #4 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Wirelessly posted (8700g: BlackBerry8700/4.1.0 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/100)

Good deal, to look at those FAQs. If you are getting a Data Connection Refused message you won't be getting any service books or emails.

Pull the battery also to allow the BlackBerry to reboot.

Last edited by JSanders : 05-23-2007 at 10:17 PM.
Offline  
Old 05-23-2007, 10:17 PM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Model: 8100
Carrier: TMobile
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ahh I see. That makes sense :/

By reset the SIM card, do I just remove it? Or is there a way to "reset" it? Will take another look at the FAQs.

Thanks again!

Edit: Rebooted twice already (once without removing SIM, and then again with the SIM removed).

Edit: BTW, sometimes it shows TMobile as my carrier (briefly). Then it goes to "DATA CONNECTION..."

Edit: I'm also able to still browse websites... despite the "DATA CONNECTION..." sign.

Last edited by jasonjoo : 05-23-2007 at 10:22 PM.
Offline  
Old 05-23-2007, 10:20 PM   #6 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Wirelessly posted (8700g: BlackBerry8700/4.1.0 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/100)

WEll you are quick. I edited that out of the post, because if you are getting Data Connection refused, that means the SIM card is communicating, and likewise, I bet your phone works for calls anyway, which means the SIM card is "seated" ok. Not reset, but re-seat.
Sorry about the confusion.
Offline  
Old 05-23-2007, 10:32 PM   #7 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Model: 8100
Carrier: TMobile
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

No need to be sorry. Thanks for taking the time to help!

I'm really not sure what is wrong, but after everything, I am still getting the data connection refused sign. I guess I never realized how important receiving my emails on my BB was... well up until now. I really miss that feature.

Is there anything else I can try before contacting TMobile?
Offline  
Old 05-23-2007, 10:34 PM   #8 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Wirelessly posted (8700g: BlackBerry8700/4.1.0 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/100)

Ok. Are you surfing the internet with the BlackBerry browser or Operai Mini?
Do you have a BlackBerry Data Plan?
Did you actually recently switch BlackBerry devices (if so-have you put the NEW device PIN and IMEI# in at your carriers BIS website to register the new deviced on BIS)?
Offline  
Old 05-23-2007, 10:35 PM   #9 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Model: 8100
Carrier: TMobile
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I was using Opera Mini, I will try BlackBerry Browser after I reply to this thread.

I do have the Blackberry Data Plan.

I have not recently switched BB devices.

Edit: With the BB browser, the request bar loads up 100%, but I am unable to browse any particular website (The Blackberry symbol remains).

Last edited by jasonjoo : 05-23-2007 at 10:38 PM.
Offline  
Old 05-23-2007, 10:49 PM   #10 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Wirelessly posted (8700g: BlackBerry8700/4.1.0 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/100)

It sounds like to me that somehow the BlackBerry Data Plan got bumped off your account--reasons I think so are: you can use Opera (which can sometimes get around not having a Data Plan) not the browser, you are not getting email, and you have the data connection message on the home screen. I would call the carrier and confirm the Data Plan is on the account.

Also, go to Options > Advanced > Host routing Table and click to Register Now. Pull the battery again and replace and see if you get anything to work.

Last edited by JSanders : 05-23-2007 at 10:51 PM.
Offline  
Old 05-23-2007, 10:53 PM   #11 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Model: 8100
Carrier: TMobile
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well, I am currently speaking with Tmobile customer service and they think that this problem is due to my plan change and some kind of mix up. I hope they can remedy this problem soon!

BTW, TMobile's customer service is EXCELLENT. Very nice customer representatives.

Will keep everyone updated!

Edit: Jsanders, that is a very good guess I hope it is just that and not a physical problem with my Pearl!
Offline  
Old 05-23-2007, 11:03 PM   #12 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Wirelessly posted (8700g: BlackBerry8700/4.1.0 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/100)

I hope it is nothing larger also, it would make sense. PM me with their solution if it works, I am curious as well.
Offline  
Old 05-23-2007, 11:13 PM   #13 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Model: 8100
Carrier: TMobile
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well, there was no actual problem with the fun or the data service.

After changing my plan which was supposed to be updated next week, I guess my data plan was "cancelled" for the time being. So for now, my data plan has been reinstated, and it will be "refreshed" again next week when my new plan starts. It seems like a hassle, but the customer service representative said that he would make sure to schedule the appropriate changes and leave me a voice mail letting me know everything was fixed.

Thanks for your time and help JSanders! I appreciate it!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.