BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-20-2007, 01:43 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2007
Model: 8100
PIN: N/A
Carrier: AT&T
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BeamBerry slightly messed up my Pearl. Need help restoring.

Please Login to Remove!

So I unsuccessfully installed BeamBerry, and then reinstalled it. Got some error along the way. Long story short, my phone no longer views .txt files. I backed up my phone before I did all this BeamBerry shit. Now, I don't wanna **** up the restore process. Can someone give me some instructions on how I would go about fixing my phone so it will display .txts again? Is it even possible with the backup file I created? If not, is there a way I can reformat my phone so everything is in working order again? Thanks guys.
Offline  
Old 06-20-2007, 01:56 AM   #2 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,667
Post Thanks: 1
Thanked 84 Times in 65 Posts
Default

The backup will only back up data, not apps and system files. The only way to reformat is to wipe the phone with JL_Cmder and reload the OS.

This post should help:

http://www.blackberryforums.com/gene...ipe#post414629
Offline  
Old 06-20-2007, 02:07 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2007
Model: 8100
PIN: N/A
Carrier: AT&T
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

so what do i do if i want to keep my messages and address book? Can I reformat without my SIM in the phone so I can keep my contacts? If not, after I reformat, can I load my restore data that I already have created? If I can't keep my contacts, it's not a big deal because I have it copied on my old phone, but it would be much more conveneient this way. And I don't have a data plan. That's not gonna be a problem for any of this, right? Thanks a lot JC.
Offline  
Old 06-20-2007, 02:16 AM   #4 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,667
Post Thanks: 1
Thanked 84 Times in 65 Posts
Default

You don't need a data plan. You don't need to remove the sim. It sounds like you've already made a backup so simply restore that backup file after you wipe, and reload the OS. I recommend you load the OS that is in the sticky at the top of this forum. Might as well get an OS upgrade while you're at it.
Offline  
Old 06-20-2007, 02:21 AM   #5 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2007
Model: 8100
PIN: N/A
Carrier: AT&T
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Last question. Do I wipe, restore back up file, and then load os, or wipe, load os, and then restore back up file?
Offline  
Old 06-20-2007, 02:32 AM   #6 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,667
Post Thanks: 1
Thanked 84 Times in 65 Posts
Default

1. Make backup of BB
2. Wipe with JL_Cmder
3. Download and install the OS package to the PC.
4. Delete vendor.xml file located in c:\program files\common files\research in motion\apploader
5. Plug in BB, open Desktop Manager and run Application Loader and follow the prompts to load the OS back to the device. (it's normal for the hourglass to spin for up to 20 minutes on the first reboot after the device software is reloaded.)
6. Restore the backup file.


Check the sticky thread for more info. The only extra step you are doing is the wipe and manual restore. Usually, during a normal upgrade the Desktop Manager will backup and restore automatically. You are simply going to do it manually because you are cleaning the device and loading the OS fresh.
Offline  
Old 06-20-2007, 01:43 PM   #7 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2007
Model: 8100
PIN: N/A
Carrier: AT&T
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

So do I need to uninstall my current Desktop Manager before installing 4.2 SP2, or can I just install 4.2 SP2 over the one that I already have?
Offline  
Old 06-20-2007, 03:34 PM   #8 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2007
Model: 8100
PIN: N/A
Carrier: AT&T
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

bump can someone please help? Do I have to uninstall my older version first?
Offline  
Old 06-20-2007, 03:52 PM   #9 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Just install DM4.2 SP2 over the old DM.
Offline  
Old 06-20-2007, 04:23 PM   #10 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2007
Model: 8100
PIN: N/A
Carrier: AT&T
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

And now I have even more problems. What the hell is going on here. I clicked on the file from my desktop and I get this error:
http://img528.imageshack.us/img528/940/capm026kf5.jpg

Then I open it from the Download Manager in my Firefox and I get this:
http://img528.imageshack.us/img528/959/capm027ln9.jpg

So I click OK, and then I get this:
http://img505.imageshack.us/img505/4142/capm028dq8.jpg

I click Launch Application and then NOTHING happens.

Help please? Thank you very, very much in advance.
Offline  
Old 06-20-2007, 04:29 PM   #11 (permalink)
Crimson Tide Moderator
 
JSanders's Avatar
 
Join Date: Oct 2004
Location: North of the moss line
Model: 9xx0
OS: 7.0sumtin
PIN: t low
Carrier: Verizon
Posts: 41,907
Post Thanks: 60
Thanked 244 Times in 182 Posts
Default

Close any and all anti-virus programs you have running.
Offline  
Old 06-20-2007, 09:19 PM   #12 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2007
Model: 8100
PIN: N/A
Carrier: AT&T
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I did. I got the same errors that I posted above. Any other ideas?
Offline  
Old 06-20-2007, 09:22 PM   #13 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2007
Model: 8100
PIN: N/A
Carrier: AT&T
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I mean the only problem I'm having is installing 4.2 SP2. Can I not complete this process with just 4.2.0.14?
Offline  
Old 06-20-2007, 09:44 PM   #14 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2007
Model: 8100
PIN: N/A
Carrier: AT&T
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

And JC, you told me to "2. Wipe with JL_Cmder
3. Download and install the OS package to the PC.
4. Delete vendor.xml file located in c:\program files\common files\research in motion\apploader"

But on this wiki page, How do I wipe the BlackBerry using Jl Cmder? - BlackBerryFAQ

it's telling me to "4. From the PC navigate to c:\program files\common files\research in motion\apploader and delete the file vendor.xml

a) If you have never installed the Handheld OS before then the vendor.xml file will not be on the PC and you can skip this step

5. Plug the device into the PC using the USB cord and make sure Desktop Manager is closed

6. Remove the battery from the device "

and THEN run the wipe. Which one do I do first?
Offline  
Old 06-20-2007, 09:49 PM   #15 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,667
Post Thanks: 1
Thanked 84 Times in 65 Posts
Default

Wirelessly posted (BB 8860: BlackBerry8100/4.2.1 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/100 UP.Browser/5.0.3.3 UP.Link/5.1.2.1)

You are SO over analyzing this.

Wipe the device.
Install the OS to the pc.
Delete vendor.xml
Plug in BB to the pc and open DM and run Application Loader. When its done loading the OS to the device then restore the backup.
Offline  
Old 06-21-2007, 12:42 AM   #16 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2007
Model: 8100
PIN: N/A
Carrier: AT&T
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks a lot JC. REALLY appreciate it.
Offline  
Old 06-21-2007, 12:45 AM   #17 (permalink)
Knows Where the Search Button Is
 
Join Date: Jun 2007
Model: 8100
PIN: N/A
Carrier: AT&T
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Holy crap. I just realized I never completed the process. the Jl_cmder stuff didn't work, and I had to follow the alternate instructions until the OS was installed. I never did the "delete vendor.xml" stuff. Is that alright? Also, how do I get memopad, tasks, and brickbreaker back? Thanks again.
Offline  
Old 06-21-2007, 01:20 AM   #18 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,667
Post Thanks: 1
Thanked 84 Times in 65 Posts
Default

Deleting the vendor.xml is necessary when the OS being installed was not released by the carrier branded on your BB (i.e. Installing AT&T OS on a TMo BB.) If you don't delete the vendor.xml when necessary the OS won't load at all. Since your 8100 is AT&T branded you didn't *need* to delete the vendor.xml. I just always include it in the instructions because inevitably it becomes an issue if I don't.

The only reason I can think of why memopad, tasks and brickbreaker are missing is that they may have been unchecked in the Application Loader. Simply plug in the BB and run Application Loader again and make sure the boxes are checked. If they are not, then simply check them and finish out the installation again and they will be added.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.