BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-21-2007, 10:32 PM   #1 (permalink)
Knows Where the Search Button Is
 
znino's Avatar
 
Join Date: Mar 2007
Model: 8100
Carrier: FIDO
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Issues with FIDO and Blackberry Connect

Please Login to Remove!

Hi,

I have an unlocked Pearl that is Rogers Branded. A few months ago I signed up with Fido for a Blackberry connect plan, went on the fido.blackberry.com website, entered my PIN and IMEI and within 5 minutes, I was setup for Blackberry connect email etc.

A friend of mine just bought an unlocked, Cingular branded pearl. When he tries to enter his PIN and IMEI on fido.blackberry.com to set up the blackberry connect email services, he consistently gets the following error message:

"Please check your PIN and IMEI. The information you entered is incorrect."

The information is, however, being input correctly.

His phone is working fine as a "phone" on the Fido network so it seems unlocked alright but for some reason he is being tossed when trying to register to BB Connect.

He has called Fido but since the only phone they officially sell for Blackberry Connect service is the Nokia E62, they just tell him that his phone is not supported for this service. How stupid is that? First it is a Blackberry native device so how could it not? and second, I have an unlocked pearl and it works fine over Fido. The Fido reps are not to be trusted...it is so frustrating.

I also have another pearl that I just use as a phone on FIDO. It is Rogers branded and unlocked. So I decided to enter that one's PIN and IMEI and surprise, surprise, I also get that error message like my friend. So now I see two phones that won't register yet my other phone has been working for months on the Fido network with Blackberry connect service.

I am baffled! I believe the PIN is something that is fixed with the phone's hardware. Why would it be invalid? At first I thought that maybe it was something like Fido had a range of serial numbers or PINs they considered valid and since Rogers and them are together, perhaps that is why the cingular unlocked phone wasnt registering but since I've tried my second Rogers branded unlocked phone and it doesnt work either I guess that's not it!

Has anyone recently been able to register an unlocked phone to work on Fido's BB Connect service? Can anyone give me any insight to what might be happening?

sorry for the long post but this is very strange indeed.

Help!!!!!!!!!!
Offline  
Old 06-21-2007, 10:36 PM   #2 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,667
Post Thanks: 1
Thanked 84 Times in 65 Posts
Default

Is it possible that the PIN/IMEI's are still in active on an account on another network? That is a common problem with used Blackberrys.
Offline  
Old 06-21-2007, 10:39 PM   #3 (permalink)
Knows Where the Search Button Is
 
znino's Avatar
 
Join Date: Mar 2007
Model: 8100
Carrier: FIDO
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by John Clark View Post
Is it possible that the PIN/IMEI's are still in active on an account on another network? That is a common problem with used Blackberrys.
Well it is supposed to be a new phone. My second rogers branded, unlocked phone that also won't register was definately new and never used, new box and everything so not sure if that's the issue in this case.

I wonder if calling RIM directly would yield some answers. Not sure what department there would help me though!
Offline  
Old 06-21-2007, 10:50 PM   #4 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,667
Post Thanks: 1
Thanked 84 Times in 65 Posts
Default

If it's a new phone, then I don't have an answer....Good luck!
Offline  
Old 06-22-2007, 06:44 AM   #5 (permalink)
New Member
 
Join Date: Feb 2006
Model: 7290
Carrier: o2
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I also have the same problem,

last week Friday 22nd June 2007, I checked the imei and pin combinations on 5 blackerry pearls 8100's. I was able to create an account and everything was fine. I did not need to setup accounts at the time.

Today I have gone to set up the accounts and am getting PIN and IMEI combination invalid.

Phones are not reported as stolen or lost and I can make and receive calls on them fine.

So 1 week ago the combinations were fine and today they are not, strange.

Also I am trying to register onto onto the same network provider as they were issued on.

Any ideaa guys??? This is a strange one
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.