BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-24-2007, 01:00 PM   #1 (permalink)
New Member
 
Join Date: May 2007
Location: Virginia Beach VA
Model: 8100
PIN: N/A
Carrier: T-Mobile
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default New To Blackberry -- Unlock & Microsd Problems

Please Login to Remove!

I apologize if this is double-posting, but after looking through some old threads, I didn't see the answers I'm looking for. I have two issues:

(1) I've had my Pearl with T-Mobile for a little over a month. I've been with T-Mobile for quite a while, so it was no problem for them to send me the unlock code right after I purchased the Pearl. Here's what happened:

T-Mobile emailed me the unlock code and I tried to enter it a few times. Originally, I started with 10 tries left. The code (which was only 7 digits) do not work. I called T-Mobile customer service and they walked me through the same steps that were in the email, but I still kept getting the "Code error, please wait" message after entering the unlock code. After waiting a few weeks, I called again and T-Mobile sent me a new unlock code -- the code is now 16 digits and begins with the same 7 from the original email. I have tried the new code, but still keep getting the same error message. I took the Pearl to a T-Mobile dealer and the rep tried the same procedure with the same results. The rep called T-Mobile customer service, Blackberry customer service and RIM customer service. They all tried the same thing and nothing worked. The Pearl is now well past "0 tries left", but still works and hasn't made any indications that I am locked out. I can still enter the unlock code, even with "0 tries" left, but still get the same error message.

(a) Do I need to do something to re-install/reset the handset from the "0 tries" state? The new 16 digit code may work, I can't recall if it had been tried before I got to the 0 tries left. Or, do I need a new handset to get it unlocked.

(b) The RIM rep told the T-Mobile rep that he showed the phone to be unlocked, but on the SIM card menu, Network is still displaying "Active".

I'm leaving for a long trip overseas in two weeks and really need to get the phone unlocked. Any help is greatly appreciate.

(2) I also bought a 2GB SanDisk microSD card and installed it in the phone. I'm running OS version 4.2.0.64 (Platform 2.2.0.37). From reading some of the other threads, it seems like some people can get the 2GB card to work and others can't. In the media card menu, I have:

Media Card Support: ON
Encryption Mode: NONE
Mass Storage Mode Support: ON
Auto Enable Mass Storage Mode When Connected: YES

But at the bottom of the screen, it states that "A media card is not presently inserted in the device."

Before I give up and go get a 1GB card and see if that works, again, any help with getting this resolved would really help me out.
Offline  
Old 06-24-2007, 03:23 PM   #2 (permalink)
New Member
 
Join Date: May 2007
Location: Virginia Beach VA
Model: 8100
PIN: N/A
Carrier: T-Mobile
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Okay, I gave up on the 2GB microSD card and just got a 1GB card. It works fine. If anyone has any suggestions for the 2GB, I'll still take them, but what I really need help with is the unlocking.

Do you think that since I now have the correct 16 digit code, that I need to reset the handset since I'm at 0 tries left -- if so, how do I do that?
Offline  
Old 06-24-2007, 07:49 PM   #3 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

I've been told that if the code is entered wrong 10 times you will *never* be able to unlock it. It's permanently locked.
Offline  
Old 06-24-2007, 08:06 PM   #4 (permalink)
New Member
 
Join Date: May 2007
Location: Virginia Beach VA
Model: 8100
PIN: N/A
Carrier: T-Mobile
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks. That's what I thought. Tmobile is sending me a new phone since they kept telling me to enter the wrong.code.
Offline  
Old 06-24-2007, 09:25 PM   #5 (permalink)
New Member
 
Join Date: May 2007
Location: Virginia Beach VA
Model: 8100
PIN: N/A
Carrier: T-Mobile
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

By the way, after I got the word that Tmobile was sending me a new phone, I tried using JL_cmdr to wipe the phone and re-install the OS, but even that didn't restore the number of tries left to unlock.
Offline  
Old 06-24-2007, 09:26 PM   #6 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

Nope. You will NEVER be able to unlock that phone.
Offline  
Old 06-28-2007, 08:04 PM   #7 (permalink)
New Member
 
Join Date: May 2007
Location: Virginia Beach VA
Model: 8100
PIN: N/A
Carrier: T-Mobile
Posts: 5
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just to follow up -- I got the new handset and a new unlock code -- all sixteen digits this time -- it worked great, on the first try.
Offline  
Old 06-28-2007, 09:15 PM   #8 (permalink)
CrackBerry Addict
 
coldconfession13's Avatar
 
Join Date: Apr 2007
Location: san antonio,tx
Model: 9550
OS: 5.0.0.230
PIN: 30fd8208
Carrier: Verizon
Posts: 904
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

i had a 2gb sandisk and it worked flawlessly. I was even running the .64 os on tmobile and it read 2gb. You probably have a bad card.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.