BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 10-24-2007, 10:25 AM   #1 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Jun 2007
Model: 9700
PIN: N/A
Carrier: Rogers
Posts: 402
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Unlocked 8320 through T-Mobile on Rogers Network

Please Login to Remove!

I recently got one and have it unlocked for use on Rogers network in Toronto. I do not have a data plan and therefore wifi will not work. According to T-Mobile and Rogers it has something to do with the service books, etc.

The wifi picks up signals and says that I am connected but the wifi logo still stays greyed out and the browsing is done via edge as opposed to wifi.

I hope this helps to clear up alot of the speculation about whether or not it would work in Canada without a data plan.
Offline  
Old 10-24-2007, 12:15 PM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: May 2007
Location: New Mexico
Model: 8320
OS: 4.5.0.55
Carrier: T-Mobile
Posts: 1,461
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

edit

Last edited by sgtcasey : 12-24-2007 at 10:51 PM.
Offline  
Old 10-24-2007, 12:27 PM   #3 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Jun 2007
Model: 9700
PIN: N/A
Carrier: Rogers
Posts: 402
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by sgtcasey View Post
Did you change the browser from Internet Browser to Wi-Fi Browser?

Dave

Yep I did and on the display on my phone, where the signal indicator usually is, OFF appeared in red lettering and when I tried to connect to my browser it sais something about not having data coverage in my area and it did not connect me. Usually I can connect no problem to the broswer, but seeing as I don't have a data plan it costs an arm and a leg.
Offline  
Old 10-24-2007, 12:41 PM   #4 (permalink)
Thumbs Must Hurt
 
mrking's Avatar
 
Join Date: Oct 2007
Model: 8310
OS: 4.5.0.163
PIN: N/A
Carrier: Rogers
Posts: 192
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

u try a battery pull after making the changes?
Offline  
Old 10-24-2007, 01:07 PM   #5 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Jun 2007
Model: 9700
PIN: N/A
Carrier: Rogers
Posts: 402
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by mrking View Post
u try a battery pull after making the changes?
Just tried it and it says that the radio is off and nothing works. I played around with it for awhile and nothing. I just find it hard to believe that I need service books when my phone detects the networks and says I am connected. I just wish there was a surefire way to tell that I was using wifi only and not edge. Under my date and time it says "Rogers" and my network name. Wifi logo is still greyed out though on the display.
Offline  
Old 10-24-2007, 03:01 PM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2007
Model: 8800
PIN: N/A
Carrier: rogers
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

also using an unlocked, tmobile 8320 on rogers, though my wifi works fine (for browsing...opera mini, gmail, only work on edge). im not well versed in these things but if others chime in with what settings to look for/compare im sure we could get yours working...
Offline  
Old 10-24-2007, 03:03 PM   #7 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Jun 2007
Model: 9700
PIN: N/A
Carrier: Rogers
Posts: 402
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by abrody View Post
also using an unlocked, tmobile 8320 on rogers, though my wifi works fine (for browsing...opera mini, gmail, only work on edge). im not well versed in these things but if others chime in with what settings to look for/compare im sure we could get yours working...
Thanks for the message. Do you have a data plan?
Offline  
Old 10-24-2007, 03:06 PM   #8 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2007
Model: 8800
PIN: N/A
Carrier: rogers
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

ive got the $10/10meg navigate plan, no BB plan.
Offline  
Old 10-24-2007, 03:10 PM   #9 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Jun 2007
Model: 9700
PIN: N/A
Carrier: Rogers
Posts: 402
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by abrody View Post
also using an unlocked, tmobile 8320 on rogers, though my wifi works fine (for browsing...opera mini, gmail, only work on edge). im not well versed in these things but if others chime in with what settings to look for/compare im sure we could get yours working...
Strange. I wonder what I am doing wrong. When connected to wifi I assume your wifi logo comes on beside the signal indicator? Does it stay greyed out? Mine does. Under the time and date it will say "Rogers" and my network name as I am currently trying to run it off my home wireless network.

Last edited by pokey : 10-24-2007 at 03:12 PM.
Offline  
Old 10-24-2007, 03:19 PM   #10 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2007
Model: 8800
PIN: N/A
Carrier: rogers
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes, when connected the logo is on next to the signal indicator. its not greyed out, left half (wi) is black, right half (fi) is grey.

when i open the browser wifi logo is grey/white, in top right hand corner.
Offline  
Old 10-24-2007, 03:29 PM   #11 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Jun 2007
Model: 9700
PIN: N/A
Carrier: Rogers
Posts: 402
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by abrody View Post
yes, when connected the logo is on next to the signal indicator. its not greyed out, left half (wi) is black, right half (fi) is grey.

when i open the browser wifi logo is grey/white, in top right hand corner.
I am following u up until I open the browswer then I get "edge" in top right hand corner of browser beside signal indicator. I wonder what the issue is.
Offline  
Old 10-24-2007, 03:31 PM   #12 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Jun 2007
Model: 9700
PIN: N/A
Carrier: Rogers
Posts: 402
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by pokey View Post
I am following u up until I open the browswer then I get "edge" in top right hand corner of browser beside signal indicator. I wonder what the issue is.
It still might be that even with your $10 plan you are getting something that I am not.
Offline  
Old 10-24-2007, 03:40 PM   #13 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2007
Model: 8800
PIN: N/A
Carrier: rogers
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

which browser are you using? did yours come with one called "WAP Browser (Rogers)" and one simply called "Browser"? I'm using "Browser."

go options>advanced options>browser

ive got:

Default browser configuration: Wi-Fi Browser
Default WAP browser configuration: WAP Browser (Rogers)


i assume thats the setting mentioned at the top of this thread, though.
Offline  
Old 10-24-2007, 03:42 PM   #14 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2007
Model: 8800
PIN: N/A
Carrier: rogers
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by pokey View Post
It still might be that even with your $10 plan you are getting something that I am not.
thats possible...would that be a service books thing?

ive got:
DoMore
WAP BrowserConfig
WAP2 Transport
Rogers MMS
Wap Push Config
Wi-Fi TCP/IP Browser
Wi-Fi TCP/IP Transport
Offline  
Old 10-24-2007, 03:56 PM   #15 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Jun 2007
Model: 9700
PIN: N/A
Carrier: Rogers
Posts: 402
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by abrody View Post
thats possible...would that be a service books thing?

ive got:
DoMore
WAP BrowserConfig
WAP2 Transport
Rogers MMS
Wap Push Config
Wi-Fi TCP/IP Browser
Wi-Fi TCP/IP Transport
All my settings are the same as yours and I tried going in through the "browser" that doesn't say Rogers and it worked! Can I be 100% sure I am using wifi as opposed to paying though? Also, when you are close to a spot like Starbucks (if you have tried) I get a "hotspot_bell" network. Will this too give free browsing? I appreciate all your help bud.
Offline  
Old 10-24-2007, 04:07 PM   #16 (permalink)
Knows Where the Search Button Is
 
Join Date: Sep 2007
Model: 8800
PIN: N/A
Carrier: rogers
Posts: 16
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

well look at that. and we didnt even need any of the nerds to help us (says the guy posting his service books on a blackberry forum).

regarding certainty, ive gone into connections and disabled mobile network and wifi browsing still worked...so you'd have to assume youre not being charged. having said that, ive heard that rogers uses data to "back up" wifi (dont see how that makes any sense), and its my 1st month with the device - yet to see a bill - so im not 100% sure. i'd call it 97%. so, im browsing very lightly for now, until i see my 1st bill.

yet to use it in a commercial hotspot so i cant speculate on that.
Offline  
Old 10-24-2007, 04:11 PM   #17 (permalink)
CrackBerry Addict
 
mike_187's Avatar
 
Join Date: Jul 2005
Location: US and A
Model: 8100
Carrier: AT&T
Posts: 794
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

go to options>advaned options>TCP

for the apn put in "internet.com" no quotes
turn wireless off then on that should get you going
__________________
-MC-
Offline  
Old 10-24-2007, 04:18 PM   #18 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Jun 2007
Model: 9700
PIN: N/A
Carrier: Rogers
Posts: 402
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by mike_187 View Post
go to options>advaned options>TCP

for the apn put in "internet.com" no quotes
turn wireless off then on that should get you going

Thanks abrody I tried with "wifi only" and even though it turned my device off I still had use of wifi so I think I got it!!! So much for Rogers saying I needed to pay for data - typical (scammers). Yer right though we should be careful until we see our first bill!

As for the "internet.com" I just did that also. What does this do?

Thanks all for your help!
Offline  
Old 10-24-2007, 04:20 PM   #19 (permalink)
CrackBerry Addict
 
mike_187's Avatar
 
Join Date: Jul 2005
Location: US and A
Model: 8100
Carrier: AT&T
Posts: 794
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by pokey View Post
Thanks abrody I tried with "wifi only" and even though it turned my device off I still had use of wifi so I think I got it!!! So much for Rogers saying I needed to pay for data - typical (scammers). Yer right though we should be careful until we see our first bill!

As for the "internet.com" I just did that also. What does this do?

Thanks all for your help!
that just allows you to use your data without a bb data plan on rogers.. its at least cheaper then bb data plan(dont get the email and BIS), but still be careful for at least the first month.
__________________
-MC-
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.