BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 12-02-2007, 08:45 AM   #1 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Location: Hong Kong
Model: 8100
Carrier: CSL
Posts: 18
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Cannot charge battery, Please help!

Please Login to Remove!

I cannot charge the battery on my Curve. Does anyone know the reason for this? When I plug in the charger, the plug icon shows up for about one second and the disappears. Please help.
Offline  
Old 12-02-2007, 08:47 AM   #2 (permalink)
BlackBerry B Boy
 
jeremyckitching's Avatar
 
Join Date: Apr 2007
Model: 9700
OS: 5.0.0.415
PIN: 215BE1F8
Carrier: T-Mobile U.S.A.
Posts: 4,243
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted (BlackBerry 8700g: BlackBerry8320/4.2.2 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/100)

Do you have another charger you can use? Or do you have a USB cable where you can connect the BlackBerry to the computer (after you install the Desktop Manager program)?
Offline  
Old 12-02-2007, 08:54 AM   #3 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Location: Hong Kong
Model: 8100
Carrier: CSL
Posts: 18
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have tried using another charger and also another battery but the situation is still the same.
Offline  
Old 12-02-2007, 08:57 AM   #4 (permalink)
BlackBerry B Boy
 
jeremyckitching's Avatar
 
Join Date: Apr 2007
Model: 9700
OS: 5.0.0.415
PIN: 215BE1F8
Carrier: T-Mobile U.S.A.
Posts: 4,243
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted (BlackBerry 8700g: BlackBerry8320/4.2.2 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/100)

What about if you connect it to a computer using a USB cable to see if that will charge it. If not, it may be something with the device's USB port.
Offline  
Old 12-02-2007, 08:59 AM   #5 (permalink)
No longer Registered.
 
Join Date: Jun 2007
Model: 9530
OS: 4.7.0.XXX
PIN: G Pong Champ
Carrier: T-Mobile U.S.
Posts: 5,515
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Can you goto Options > Status and tell us your current battery level when this happens.
Offline  
Old 12-02-2007, 09:07 AM   #6 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Location: Hong Kong
Model: 8100
Carrier: CSL
Posts: 18
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I will have to try that tomorrow as my USB cable is at the office. thanks for the advice.
Offline  
Old 12-02-2007, 09:08 AM   #7 (permalink)
BlackBerry B Boy
 
jeremyckitching's Avatar
 
Join Date: Apr 2007
Model: 9700
OS: 5.0.0.415
PIN: 215BE1F8
Carrier: T-Mobile U.S.A.
Posts: 4,243
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted (BlackBerry 8700g: BlackBerry8320/4.2.2 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/100)

Also, do Troy's suggestion and check the battery level, too. If it is at 100% then this may explain that behavior.
Offline  
Old 12-02-2007, 09:42 AM   #8 (permalink)
Knows Where the Search Button Is
 
Join Date: Nov 2006
Location: Hong Kong
Model: 8100
Carrier: CSL
Posts: 18
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

it says 30%
Offline  
Old 11-07-2008, 07:49 AM   #9 (permalink)
New Member
 
Join Date: Nov 2008
Model: 8320
PIN: N/A
Carrier: Rogers
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have exactly the same problem. repalced the battery with a new one. Tried to charge it when it got low. Charge icon comes on for second or two then goes 'away'. BB does not charge. HELP !
Offline  
Old 11-07-2008, 08:07 AM   #10 (permalink)
Knows Where the Search Button Is
 
Join Date: Mar 2005
Model: 8320
Carrier: T-Mobile
Posts: 23
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same problem with my Curve when I use the travel charger but it charges fine thru the computer. Haven't been able to figure out how to resolve this.
Offline  
Old 11-07-2008, 09:21 AM   #11 (permalink)
New Member
 
str3zz's Avatar
 
Join Date: Jan 2008
Model: 9000
OS: 5.0.0.90
PIN: N/A
Carrier: ATT
Posts: 14
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by BAG23 View Post
I have the same problem with my Curve when I use the travel charger but it charges fine thru the computer. Haven't been able to figure out how to resolve this.
I had this problem 2 days ago and i figure it out. if you look inside the hole where your charger connected to on the blackberry. There should be 6 little pin on it. what happen to mine was one of the pin flip up instead of straight. so i just make it straight again and then it start charging again.

hope this will help.

PS: took me 1 hour to make it straight just because little tiny hole and you need very thin 2 pieces of metal, one to hold it from the bottom and the other one force the pin straight from the top.
Offline  
Old 11-10-2008, 09:48 AM   #12 (permalink)
New Member
 
Join Date: Nov 2008
Model: 8320
PIN: N/A
Carrier: Rogers
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem resolved

Quote:
Originally Posted by str3zz View Post
I had this problem 2 days ago and i figure it out. if you look inside the hole where your charger connected to on the blackberry. There should be 6 little pin on it. what happen to mine was one of the pin flip up instead of straight. so i just make it straight again and then it start charging again.

hope this will help.

PS: took me 1 hour to make it straight just because little tiny hole and you need very thin 2 pieces of metal, one to hold it from the bottom and the other one force the pin straight from the top.
I was able to solve the problem by having the charging port replaced. This is the 4th BB I have owned - 3 Pearls and a Curve so far. Al four went defective at or within a year of NORMAL use. Two of them had this same USB port problem. One just stopped working altogether. One had bad track ball. Great technology, super featured phones, but lousy quality control it seems or too many design defects. Actually pretty disappointed.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.