BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-12-2008, 07:40 PM   #1 (permalink)
New Member
 
Join Date: Jan 2005
Model: Curve
Carrier: T Mobile
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Getting Curve to Stay with Wifi over T-Mobile Network

Please Login to Remove!

First off, i used the search button, if its been covered, my bad.


Sevice is good with my phone everywhere but in my apartment, where it isn't great. I was pumped when i found out that i could sync my phone with my 802.11G router and use that connection for calls and web access. Here's the issue, the phone is almost always switching back to the tmobile network, even though i have it set to WiFi preferred. Spent 1.5 hours last night on the phone with Tmobile blackberry department going through all kinds of stuff, and they seem stumped. Is there any good way of making it use the UMA instead of the tmobile network without having to turn off the Tmobile network, if i do that, it works on UMA just fine, but i don't want to have to hassle with switching it every time i come and go.

BTW, they sent me an email with tips, and i already did all this

* Under the 'wireless' tab xxx8211; change the router's channel to '11'. This will prevent radio frequency interference from other wireless equipment. APPLY the setting change and power router OFF/ON to update.
* The following must be enabled in order to support HotSpot@Home:

ŘUDP port 500 xxx8211; enabled in both directions through the firewall
ŘUDP port 4500 xxx8211; enabled in both directions through the firewall
ŘIPSec Passthrough xxx8211; enabled (if available)
ŘQOS xxx8211; Quality of Service xxx8211; enabled (if available)
ŘEnter the IP or MAC address of your phone and assign 140 kbps as a priority bandwidth for this address (if available)

Thanks.

Last edited by robinsok : 02-12-2008 at 07:42 PM.
Offline  
Old 02-12-2008, 08:27 PM   #2 (permalink)
Talking BlackBerry Encyclopedia
 
kd78's Avatar
 
Join Date: Aug 2005
Location: Charlotte
Model: 8900
Carrier: Tmobile
Posts: 342
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wirelessly posted (8320: BlackBerry8320/4.2.2 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/100)

If it works 100% on wifi when you have your mobile network turned off, it doesn't sound like it's a router issue.
Sounds more like something wrong with the handset or its settings.do you have the "wifi preferred" setting on in the connection preferences?
__________________
Tmobile | 7100t, 7105t, 8700g, 8320, 8900
Offline  
Old 02-12-2008, 08:31 PM   #3 (permalink)
New Member
 
Join Date: Jan 2005
Model: Curve
Carrier: T Mobile
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes i do have WiFi preferred selected. I turned off the Mobile network a couple hours ago and it has been working fine on the UMA, so i know that connecting to and using the router is not the problem.

Does the phone typically use UMA all the time when you guys that use this feature are at home?
Offline  
Old 02-12-2008, 09:18 PM   #4 (permalink)
Talking BlackBerry Encyclopedia
 
kd78's Avatar
 
Join Date: Aug 2005
Location: Charlotte
Model: 8900
Carrier: Tmobile
Posts: 342
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes if you have a good clear wifi signal then it should stay on UMA until you move out of range of the access point.

Do you have more than one wifi network configured on your bb from signals near your apartment (like any neighboring networks)? If so, you might want to make sure you move your primary network up to the top of the priority list. Not sure if that has anything to do with it but it seems like when you turn your mobile network back on, it is for some reason thinking the wifi signal is not an appropriate option.
__________________
Tmobile | 7100t, 7105t, 8700g, 8320, 8900
Offline  
Old 02-12-2008, 09:26 PM   #5 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

What kind of router are you using? My *guess* is that you are getting a little bit out of range and the BB says "oh, I'm leaving the wifi area, switch to EDGE." It does this so it will handoff the call.
Offline  
Old 02-12-2008, 10:08 PM   #6 (permalink)
New Member
 
Join Date: Jan 2005
Model: Curve
Carrier: T Mobile
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

There are other wireless networks within range, but i have never connected to any of them. How do i order the networks by priority?

And i doubt that i am out of range. The router is sitting on the desk three feet from the phone. I can connect through UMA, and go into the other rooms and talk just fine when i turn the tmobile network off, so i know the range is pretty decent, it just switches to the tmobile network instead of using it.
Offline  
Old 02-12-2008, 10:11 PM   #7 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

Right, but when you turn off the mobile network it will stay connected to UMA longer since it doesn't have to predict when to facilitate the EDGE handoff. If you stay close to the router does it switch?

Also, what kind of router? You may want to try this:

8320 Stable Wi-Fi UMA Connection Settings (Linksys)
Offline  
Old 02-12-2008, 10:20 PM   #8 (permalink)
New Member
 
Join Date: Jan 2005
Model: Curve
Carrier: T Mobile
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by John Clark View Post
Right, but when you turn off the mobile network it will stay connected to UMA longer since it doesn't have to predict when to facilitate the EDGE handoff. If you stay close to the router does it switch?

Also, what kind of router? You may want to try this:

8320 Stable Wi-Fi UMA Connection Settings (Linksys)
It switches when the phone is within three feet of the router. I just said that it worked in other rooms as a reference to the fact that the range is there. BTW its a linksys WRT54G. I will look at the link you gave, but i'm not sure i know how to change all those settings.
Offline  
Old 02-12-2008, 10:24 PM   #9 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

Try the link above. Any 2.4Gb cordless phones nearby?
Offline  
Old 02-13-2008, 07:31 AM   #10 (permalink)
Talking BlackBerry Encyclopedia
 
kd78's Avatar
 
Join Date: Aug 2005
Location: Charlotte
Model: 8900
Carrier: Tmobile
Posts: 342
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by robinsok View Post
There are other wireless networks within range, but i have never connected to any of them. How do i order the networks by priority?
Again this is a shot in the dark, and probably unlikely, but maybe it is switching over to a less desirable wifi network at times forcing the handoff to edge? Go to MANAGE CONNECTIONS, then WI-FI OPTIONS, then make sure your home network is the first one listed under SAVED WIFI PROFILES. If it is not, you can click the menu button while on your network and click MOVE.

BTW, did you already try a battery pull?
__________________
Tmobile | 7100t, 7105t, 8700g, 8320, 8900
Offline  
Old 02-13-2008, 11:57 AM   #11 (permalink)
New Member
 
Join Date: Jan 2005
Model: Curve
Carrier: T Mobile
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by kd78 View Post
Again this is a shot in the dark, and probably unlikely, but maybe it is switching over to a less desirable wifi network at times forcing the handoff to edge? Go to MANAGE CONNECTIONS, then WI-FI OPTIONS, then make sure your home network is the first one listed under SAVED WIFI PROFILES. If it is not, you can click the menu button while on your network and click MOVE.

BTW, did you already try a battery pull?
I don't think that it is switching to another network, because the name of the network shows on the phones home screen and it hasn't ever been anything but the name of my network at home. I used the phone on UMA last night for a couple hours, and it worked great, but the only way I got it to stay there was my turning the tmobile network off. Hadn't trid a battery pull, but the phone froze up today and I had to, but I won't be home untill later to see what it does.
Offline  
Old 02-13-2008, 03:52 PM   #12 (permalink)
No longer Registered.
 
Join Date: Jun 2007
Model: 9530
OS: 4.7.0.XXX
PIN: G Pong Champ
Carrier: T-Mobile U.S.
Posts: 5,515
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I think you will find John's link helpful. Especlially the part about changing the channel on your router. That made a world of difference for me. I use to always switch back and forth. After changing the channel I have had solid UMA. I know in your T-Mobile email they said channel 11 but try more than just 11.
Offline  
Old 02-13-2008, 03:56 PM   #13 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

Good idea. Other networks in the area can affect your UMA signal, even though the network never completely drops.
Offline  
Old 02-13-2008, 04:49 PM   #14 (permalink)
Talking BlackBerry Encyclopedia
 
kd78's Avatar
 
Join Date: Aug 2005
Location: Charlotte
Model: 8900
Carrier: Tmobile
Posts: 342
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

agreed. Do a network scan from your computer and see what networks you pick up. Check which channels they are on then set your router to something different than them.

I have to have mine set on 3 because my neighbors are already on 1,6, and 11.

Also a battery pull anytime you are having weird issues on a blackberry is usually my first line of defense.
__________________
Tmobile | 7100t, 7105t, 8700g, 8320, 8900
Offline  
Old 06-10-2008, 06:57 PM   #15 (permalink)
New Member
 
Join Date: Jun 2007
Model: 8320
PIN: N/A
Carrier: TMO
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Anything on a Belkin router or should I go to TMO and get a linksys router?
Offline  
Old 06-10-2008, 07:21 PM   #16 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: May 2008
Location: 98003
Model: 9700
OS: 5.0.0.330
PIN: CERS!
Carrier: T-Mobile, Verizon
Posts: 477
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by troydbrown View Post
I think you will find John's link helpful. Especlially the part about changing the channel on your router. That made a world of difference for me. I use to always switch back and forth. After changing the channel I have had solid UMA. I know in your T-Mobile email they said channel 11 but try more than just 11.
agreed, actually, stay away from 1, 6, and 11... those are default channels for a lot of brands of routers.

i'd personally try 3, 7, or 9. also download "network stumbler" and scan your area for all networks to see what their settings are so you can pick a clear channel.

there are also quite a few other router settings to help optimize the connection. we can go into these later once you get home and test your phone since you've done the hard reset.

lastly, the suggestion to do a battery pull is probably your best bet before fuggling around with any other settings.
__________________
my av was not safe for preschoolers.
Offline  
Old 06-11-2008, 01:49 PM   #17 (permalink)
Thumbs Must Hurt
 
neuor's Avatar
 
Join Date: Oct 2005
Location: Detroit
Model: 9630
OS: 5.0.0.484
PIN: By Request
Carrier: Sprint
Posts: 67
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Actually you should only use channels 1, 6, or 11 on 802.11b/g wireless networks. 1, 6, and 11 are the only non-overlapping channels. This Cisco deployment guide explains this pretty clearly: Channel Deployment Issues for 2.4-GHz 802.11 WLANs
If you don't want to read the whole guide, jump down to the conclusion.
__________________
-Garrett
Current: 9630 BIS, 8530 BES
Past: 8330, 8320, 8830, 8100, 7105t
http://garrettkelley.com
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright © 2004-2014 BlackBerryForums.com.
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.