BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 02-16-2008, 09:37 AM   #1 (permalink)
New Member
 
Join Date: Feb 2008
Model: 8300
PIN: N/A
Carrier: Virgin Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 8300 uncaughtexception

Please Login to Remove!

I have an 8300 I have just upgraded the firmware to the latest one according to this sticky.

I get this error message every time I try to send a text message;

uncaught exception java.lang.IllegalArgumentException

I go into menu then click on text/media messages then it asks if I want to [use once] or select a contact. Whether I pick [use once] or select a contact I get that error message thrown. It happens every time.

I can make and receive calls no problem.

I have had the phone unlocked, it was originally locked to Vodafone UK.
Offline  
Old 02-16-2008, 09:39 AM   #2 (permalink)
Talking BlackBerry Encyclopedia
 
Sci-Tek's Avatar
 
Join Date: Jan 2008
Model: 8000
OS: 4.6.0.303
Carrier: TDC
Posts: 359
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

I would try to reflash the phone. Something seems corrupted.
Atleast java error indicate it. Guess you have tried to pull the battery, if still no go, reload OS again.
Offline  
Old 02-16-2008, 09:48 AM   #3 (permalink)
New Member
 
Join Date: Feb 2008
Model: 8300
PIN: N/A
Carrier: Virgin Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

How do I reinstall the OS? I load the desktop manager up and it says there are no available updates.

This error was being thrown when the phone was on the old firmware as well, I thought updating it might fix it but no such luck.

Is there anything that doesn't get updated when updating firmware?
Offline  
Old 02-16-2008, 10:38 AM   #4 (permalink)
BBFAQ Sysop
 
ricpac's Avatar
 
Join Date: Oct 2007
Location: Philippines
Model: 9700
OS: X 10.6
PIN: Alt+Shift+H
Carrier: GLOBE
Posts: 3,760
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

have you already pulled the battery while it's still on? then put it back in after 30s; if you have to reinstall OS, try following the instructions on this link How do I wipe the BlackBerry using Jl Cmder? - BlackBerryFAQ.com
__________________
All your base are belong to us.
Offline  
Old 02-17-2008, 08:26 AM   #5 (permalink)
New Member
 
Join Date: Feb 2008
Model: 8300
PIN: N/A
Carrier: Virgin Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes I did try taking the battery out with the phone still on, left it for 30 seconds and then put it back but still no joy.

I deleted the OS using the guide you supplied ricpac. I think everything went successful on the delete side, I got the 507 error message when trying to reboot.
So I tried to install the OS again, however the application loader wouldnt recognise the blackberry without the battery in so I put the battery in and reinstalled the OS.
I am still getting the same error messsage however.
Any ideas anyone? Thanks for the help so far.
Offline  
Old 02-17-2008, 08:32 AM   #6 (permalink)
Talking BlackBerry Encyclopedia
 
Sci-Tek's Avatar
 
Join Date: Jan 2008
Model: 8000
OS: 4.6.0.303
Carrier: TDC
Posts: 359
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

You won't be able to power the BB without battery.

If the JL_cmder trick that ricpac posted you don't work your phone seems like it wants a warranty replacement. Is it still within warranty?
__________________
Cheers,

Sci-Tek

Only dead fish follow the stream
Offline  
Old 02-17-2008, 08:41 AM   #7 (permalink)
New Member
 
Join Date: Feb 2008
Model: 8300
PIN: N/A
Carrier: Virgin Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

No I don't think that it is still under warranty. Do you have any other suggestions?
Offline  
Old 02-17-2008, 08:43 AM   #8 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: BBPP
OS: 10.3.0
Carrier: T-Mobile USA
Posts: 13,752
Post Thanks: 16
Thanked 503 Times in 489 Posts
Default

mutd85, what about downgrading back to the OS version you were using before the 'upgrade'?
__________________
- Ira

Last edited by aiharkness : 02-17-2008 at 08:46 AM.
Online  
Old 02-17-2008, 08:48 AM   #9 (permalink)
Talking BlackBerry Encyclopedia
 
Sci-Tek's Avatar
 
Join Date: Jan 2008
Model: 8000
OS: 4.6.0.303
Carrier: TDC
Posts: 359
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Well your error is a software error, its very strange if your phone was wiped and you re-installed and got the same error again, did you apply the newest OS or the same version? you could try to downgrade or upgrade regarding of what you first did.
__________________
Cheers,

Sci-Tek

Only dead fish follow the stream
Offline  
Old 02-17-2008, 09:04 AM   #10 (permalink)
New Member
 
Join Date: Feb 2008
Model: 8300
PIN: N/A
Carrier: Virgin Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I applied the OS that's in the sticky on the top of this forum. I've just tried it with a different SIM card and the error message doesn't get thrown, which I think is kind of strange?
Offline  
Old 02-17-2008, 09:37 AM   #11 (permalink)
Talking BlackBerry Encyclopedia
 
Sci-Tek's Avatar
 
Join Date: Jan 2008
Model: 8000
OS: 4.6.0.303
Carrier: TDC
Posts: 359
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

hmm ok that made me think a bit.

Options -> SMS
Check that "leave SMS on SIM card" is set to No.

Posting a screen of my settings, you might want to compare.
Just dont change your service center number, thats unique for each carrier

__________________
Cheers,

Sci-Tek

Only dead fish follow the stream
Offline  
Old 02-17-2008, 10:41 AM   #12 (permalink)
New Member
 
Join Date: Feb 2008
Model: 8300
PIN: N/A
Carrier: Virgin Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I compared my screen to yours and the only differences were Validity Period and Number of Previous Items, which I then changed to match yours.
Still the same error message though.
Thanks for the suggestion, any more ideas?
Offline  
Old 02-17-2008, 10:54 AM   #13 (permalink)
Talking BlackBerry Encyclopedia
 
Sci-Tek's Avatar
 
Join Date: Jan 2008
Model: 8000
OS: 4.6.0.303
Carrier: TDC
Posts: 359
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Well, since it worked with another sim card.. I would contact my carrier and get a new one. You should get one for free or a very small fee.
Depends on where you go. And carrier policy

Worth a try huh?
__________________
Cheers,

Sci-Tek

Only dead fish follow the stream
Offline  
Old 02-17-2008, 05:21 PM   #14 (permalink)
New Member
 
Join Date: Feb 2008
Model: 8300
PIN: N/A
Carrier: Virgin Mobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yeah, thats a good idea. Thanks for all the help
Offline  
Old 02-17-2008, 05:24 PM   #15 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: BBPP
OS: 10.3.0
Carrier: T-Mobile USA
Posts: 13,752
Post Thanks: 16
Thanked 503 Times in 489 Posts
Default

Quote:
Originally Posted by mutd85 View Post
Yeah, thats a good idea. Thanks for all the help
Post an update when you do. I'm curious what the fix turns out to be.
__________________
- Ira
Online  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.