BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-03-2008, 04:19 PM   #1 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8830
PIN: N/A
Carrier: Verizon
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Deleted email on BB is not deleted on Outlook / Server

Please Login to Remove!

I'm a newb here, so please be gentle. Here's the situation.

Deleted emails from Outlook are removed from the Blackberry
Deleted emails from the Blackberry are not deleting from Outlook

On the 8830, Email Reconciliation is set to delete on "Mailbox & Handheld"

We are running BES 4.1.4, and Exchange 2003 / OL 2003, with a Verizon Wireless 8830

I already checked in the BES admin thread that there is no policy to define "Delete On" on the BES.

I've tried setting Delete On to "Handheld" - saved - and went back to "Mailbox & Handheld" - nothing

I've tried resetting the phone several times by taking out the battery.

Am I missing something? Help!
Offline  
Old 04-03-2008, 04:21 PM   #2 (permalink)
BlackBerry God
 
penguin3107's Avatar
 
Join Date: Jan 2005
Model: iOS 5
Carrier: VZW
Posts: 11,701
Post Thanks: 1
Thanked 237 Times in 219 Posts
Default

How long are you waiting?
Deletes from Handheld can take up to 20 minutes to reconcile and delete from your Exchange mailbox.
__________________
BCSA
BES 5.0.3 MR4 :-: Exchange 2007 SP3 RU3
http://port3101.org
Offline  
Old 04-03-2008, 04:35 PM   #3 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8830
PIN: N/A
Carrier: Verizon
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by penguin3107 View Post
How long are you waiting?
Deletes from Handheld can take up to 20 minutes to reconcile and delete from your Exchange mailbox.
Thanks for the reply - the messages are still there from yesterday.
Offline  
Old 04-03-2008, 07:00 PM   #4 (permalink)
BlackBerry God
 
penguin3107's Avatar
 
Join Date: Jan 2005
Model: iOS 5
Carrier: VZW
Posts: 11,701
Post Thanks: 1
Thanked 237 Times in 219 Posts
Default

Quote:
Originally Posted by RyanHutchings View Post
Thanks for the reply - the messages are still there from yesterday.
On the handheld, how are you deleting the emails?
Are you using Delete Prior, or deleting multiple messages at once?

The only way to delete from handheld and mailbox would be to delete the messages one at a time.
Any type of bulk delete will always delete from handheld only.
__________________
BCSA
BES 5.0.3 MR4 :-: Exchange 2007 SP3 RU3
http://port3101.org
Offline  
Old 04-04-2008, 02:59 PM   #5 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8830
PIN: N/A
Carrier: Verizon
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Only one email is being deleted at a time.
Offline  
Old 04-04-2008, 03:08 PM   #6 (permalink)
BlackBerry God
 
penguin3107's Avatar
 
Join Date: Jan 2005
Model: iOS 5
Carrier: VZW
Posts: 11,701
Post Thanks: 1
Thanked 237 Times in 219 Posts
Default

Maybe have your service books resent to you from the BES? Try a new EA?
Not too much else it can be if all the settings are correct.
__________________
BCSA
BES 5.0.3 MR4 :-: Exchange 2007 SP3 RU3
http://port3101.org
Offline  
Old 04-04-2008, 04:19 PM   #7 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8830
PIN: N/A
Carrier: Verizon
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm not sure what all that means. I'm a n00b BES admin
Offline  
Old 04-04-2008, 04:20 PM   #8 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8703e
PIN: N/A
Carrier: Sasktel
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

You think you're new I can't even figure out how to post my question! HELP
Offline  
Old 04-04-2008, 04:26 PM   #9 (permalink)
akg
Talking BlackBerry Encyclopedia
 
akg's Avatar
 
Join Date: Feb 2007
Location: Dallas, TX
Model: 9700
OS: 6.0.0.344
PIN: Mont Blanc
Carrier: AT&T
Posts: 439
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Under server properties, make sure "Hard Deletes Reconciliation" is set to True. I remember when I installed BES it was set to false by default, and when we deleted items on our BB it would not do so in Exchange. After I changed this setting (and rebooted), items deleted from BB with the correct settings would be moved to the deleted items bin in Exchange.
__________________
[SIGPIC][/SIGPIC]BESAdmin

BES 4.1.6 Exchange 2003 SP2
Offline  
Old 04-04-2008, 04:44 PM   #10 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8830
PIN: N/A
Carrier: Verizon
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks akg - I tried that already, but I only restarted the BB service. I'll try rebooting.
Offline  
Old 04-04-2008, 06:07 PM   #11 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8830
PIN: N/A
Carrier: Verizon
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK - I rebooted the server .. after I rebooted I sent a test message and deleted it from the 8830 ... 1 hour later it's still in Outlook - HELP! :(
Offline  
Old 04-04-2008, 07:18 PM   #12 (permalink)
CrackBerry Addict
 
Jagga's Avatar
 
Join Date: Oct 2004
Location: Toronto
Model: Z10
Carrier: Lord Rogers - 107
Posts: 862
Post Thanks: 6
Thanked 6 Times in 5 Posts
Default

Quote:
Originally Posted by penguin3107 View Post
On the handheld, how are you deleting the emails?
Are you using Delete Prior, or deleting multiple messages at once?

The only way to delete from handheld and mailbox would be to delete the messages one at a time.
Any type of bulk delete will always delete from handheld only.
I've seen users do a bulk delete before on BES v4.1 SP2/3/4 and worked to send those deleted emails to the deleted items folder in Outlook 2K3.

Curious, are these emails moved back into Inbox from your FIRST Outlook delete - and then BBDM sync'd back over?

on the handheld, Delete the Desktop [CMIME], Desktop [Sync] service books. Then goto Options> Security Options> General and menu key to Regenerate Encryption key wirelessly from the handheld.

If this still doesn't work, remove the device from the BES. Wipe HH. Wireless E.A. (if you've set that up), and test again (1 email from Outlook) then test multiple deletes (by selection of emails back to back).

IF it STILL doesn't work (I've got a hunch this all won't); then you have an SQL db issue, or a rights issue on Exchange.

Question: Your not a trained BES Admin are you? DO you have helpdesk BES access to the manager or full BES? Just curious.
__________________
Senior help desk administrator (rim_db_admin_sr_helpdesk)
Serious Mobile

Last edited by Jagga : 04-04-2008 at 07:20 PM. Reason: question
Offline  
Old 04-07-2008, 12:45 PM   #13 (permalink)
akg
Talking BlackBerry Encyclopedia
 
akg's Avatar
 
Join Date: Feb 2007
Location: Dallas, TX
Model: 9700
OS: 6.0.0.344
PIN: Mont Blanc
Carrier: AT&T
Posts: 439
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

As has been suggested, try deleting and resending your service books first. Then the only other thing you can really do is remove yourself from the BES, wipe the BB, and do another Enterprise Activation like you did the first time.
__________________
[SIGPIC][/SIGPIC]BESAdmin

BES 4.1.6 Exchange 2003 SP2
Offline  
Old 04-10-2008, 01:30 PM   #14 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8830
PIN: N/A
Carrier: Verizon
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I can see where to delete the service books on the device ... but I'm nervous to do so without first knowing how to resend the service books. Does anyone have a link to a guide, or, hopefully, a quick explanation?

THANKS!
Offline  
Old 04-10-2008, 01:40 PM   #15 (permalink)
BlackBerry God
 
penguin3107's Avatar
 
Join Date: Jan 2005
Model: iOS 5
Carrier: VZW
Posts: 11,701
Post Thanks: 1
Thanked 237 Times in 219 Posts
Default

Quote:
Originally Posted by RyanHutchings View Post
I can see where to delete the service books on the device ... but I'm nervous to do so without first knowing how to resend the service books. Does anyone have a link to a guide, or, hopefully, a quick explanation?

THANKS!
How do I resend service books to a user's device? - BlackBerryFAQ
__________________
BCSA
BES 5.0.3 MR4 :-: Exchange 2007 SP3 RU3
http://port3101.org
Offline  
Old 04-29-2008, 04:38 PM   #16 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8830
PIN: N/A
Carrier: Verizon
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Fixtit!

For any of y'all who are curious, I fixed this issue finally!

I did delete and resend the service books
I reset the "Desktop" setting "Delete On" option to "Mailbox & Handheld"
Verified that the "Wireless Reconcile" option is "On"
Verified that the "On Conflicts" option is "Mailbox Wins"
Saved your settings

I also downloaded the MS Management Studio that allowed me to reset the password for the sa account, and then I changed the BES authentication from Windows to Database.

Tada!
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.