BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-07-2008, 01:01 PM   #1 (permalink)
New Member
 
Join Date: May 2008
Model: none
PIN: N/A
Carrier: none
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question App permissions?

Please Login to Remove!

My BB Curve 8310 seems to be having some application permission configuration issue. When starting some of the applications, it asks me permission.

For example, the Google Mail app : When i start it, it says "You are attempting to open a secure connection, but the server's certificate is not trusted." It gives me the options to Continue, Close connection, View certificate or Trust certificate.

When i select Trust certificate, it sometimes asks me for the password to my Key Store. I finally found out that that is the same password i used to lock my BB, so i entered that.

next, sometimes it tells me that "the following application is requesting access to your Handheld Key Store" and lists the info about the application, along with an OK or Cancel button. I click OK.

Next always it tells me that "the following application is requesting access to your Trusted Key Store" and lists the info about the application, along with an OK or Cancel button. I click OK.

Then i get an error message that says: "Network Error net.rim.device.api.system.ControlledAccessExceptio n: Cause unknown" with an OK button. When i click the OK button, the message goes away, and then nothing else happens.

I have gone into the application permissions, and set everything to "Allow" for the Mail by Google app. This does not fix the problem however. I am a little puzzled by that. I would think that the prompts about wanting to access my key store are caused by the google mail app not having permissions, but i set it all to "allow" and it still prompts me. Am i missing something here?

With Opera Mini, i have a somewhat similar problem: When i try to go to a website, it gives me a message that says "The application Opera Mini has attempted to access a low-level network connection. Would you like to allow this?" There's a Yes and No button. When i click the Yes button, everything proceeds as normal.

I did a battery pull, but that did not fix either issue. I resent the Service Books through the BIS site, but that did not fix it either.

Also something maybe worth mentioning: At one point, as i was downloading and installing a few apps, the BB told me that permissions were now more restricted and that it needed to reset itself. I do not know why settings had changed, or which settings it's talking about. It may have been a result of installing some app, but i do not know for sure. I seem to remember installing one app and it asking for all these permissions and i cancelled out of the dialog instead of saving (allowing) the changes. I do not know if this has something to do with all this? Maybe my default settings got changed by accident from what they are out of the box?
Offline  
Old 06-07-2008, 05:36 PM   #2 (permalink)
BlackBerry Extraordinaire
 
flash24's Avatar
 
Join Date: Aug 2006
Location: San Antonio, TX
Model: 9930
OS: 7.1
PIN: 3319688F
Carrier: Verizon
Posts: 2,178
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Wirelessly posted

Whenever that appears, just select yes.
__________________
http://twitter.com/billydasco

Proud to Serve USAF
Offline  
Old 06-07-2008, 11:38 PM   #3 (permalink)
Thumbs Must Hurt
 
Whoooooo-Kid's Avatar
 
Join Date: Apr 2008
Location: NYC
Model: 9000
Carrier: at&t
Posts: 122
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

why ^
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.