BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-12-2008, 01:03 AM   #1 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8320
PIN: N/A
Carrier: fido
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy BB 8320 wifi problem using fido

Please Login to Remove!

hi, i bought a new t-mobile BB curve 8320 2 weeks ago, but unable connect to wifi. i can scan and see all the available wireless network including my linksys wireless router. don't know how to make it work. pls help!
Offline  
Old 06-12-2008, 01:05 AM   #2 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,667
Post Thanks: 1
Thanked 84 Times in 65 Posts
Default

Do you have a BBConnect data plan with Fido for your Blackberry? If not, you won't be able to do much with your 8320, even on wifi. You will be able to surf the internet with the wifi browser, and that's about it. There should be a setup wifi icon on the main screen of the BB that walks you through the setup. If it doesn't work then it's likely your router settings.
Offline  
Old 06-12-2008, 03:15 AM   #3 (permalink)
Thumbs Must Hurt
 
Join Date: Jun 2007
Location: Toronto
Model: 8900
OS: 5.0.0.190
Carrier: Fido (City, Unlimited)
Posts: 192
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

yeah, i'm also on fido with my 8310 but i'm switching to a 8320, soon.

i have a bb connect data plan from fido. 7MB/$40.

you might want to look in the wifi/uma section of the forums.
Offline  
Old 06-13-2008, 11:49 AM   #4 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8320
PIN: N/A
Carrier: fido
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

thx guys 4 the info. it took me 2 wks to struggle with the wifi and finally i got it working. u guys r rite, it was the router, i just had to add my device's MAC address to the router and it connected no problem. thx again guys.

Last edited by ntrbc : 06-13-2008 at 11:50 AM.
Offline  
Old 06-13-2008, 06:43 PM   #5 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8320
PIN: N/A
Carrier: Fido
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by John Clark View Post
Do you have a BBConnect data plan with Fido for your Blackberry? If not, you won't be able to do much with your 8320, even on wifi. You will be able to surf the internet with the wifi browser, and that's about it. There should be a setup wifi icon on the main screen of the BB that walks you through the setup. If it doesn't work then it's likely your router settings.
Just curious, what router settings should one look for? I just want to have internet access lounging on the couch at home, or at wifi hotspots around town. No need for data plan as I have computers w/internet at home and work.

I'm having similar issues as the OP; but I can connect to my router, just cannot obtain an IP address (yellow circle with a dash, not green with a check).

Here's what I have:
unlocked T-Mobile branded Curve 8320
Fido, no data plan
USR8054 801.11g (at home, two laptops/two desktops connected via wifi)
- WPA-PSK enabled, mac filtering disabled
- BB sees my SSID, input passphrase & it connects to router
- no IP address

I also have an old Linksys 802.11b router at work (similar config - WPA-PSK, no mac filter); BB doesn't see the network at all, let alone connect to it. Are the routers just too old?
Offline  
Old 06-13-2008, 06:46 PM   #6 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,667
Post Thanks: 1
Thanked 84 Times in 65 Posts
Default

Are you sure it doesn't have an IP? Have you looked in Options >Status to see if an IP has been assigned? You will never get a green check with no BB data plan. Once connected you have to use the wifi browser. Go to Options >Advanced Options >Browser and set the default browser to wifi browser (Hotspot Browser in OS 4.5.)
Offline  
Old 06-13-2008, 07:28 PM   #7 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8320
PIN: N/A
Carrier: Fido
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wifi diagnostic gives me this result:

Wi-Fi
Current Profile: peroxide8888
SSID: peroxide8888
AP MAC Address: 00:C0:49:E0:C9:IF
Security Type: Pre-Shared Key (PSK)
Local IP Address: (blank)
Signal Level: -49 dBm
Connection Data Rate: 54 Mbps
Status: IP address no longer valid

VPN
Current Profile:
Concentrator Address:
Contact: (unchecked button)
Authentication: (red x in button)
Secure Device IP:
Status: Error: VPN disabled

UMA
Connection Pref.: Wi-Fi Preferred
UMA Wi-Fi Available: (unchecked button)
Connection: (red x in button)
Error Code: W005.1
Status: ISP Error. Retry.

I also have Opera Mini installed and no BB wifi love; wifi browser is the default, and there are no other options anyway.

*at work right now, will report back later when I'm home.
Offline  
Old 06-13-2008, 07:38 PM   #8 (permalink)
Thumbs Must Hurt
 
Join Date: Jun 2008
Model: 8320
PIN: N/A
Carrier: fido
Posts: 52
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Do you have a limit as to how many IP's your router can give out? Try and reset the router and modem and see if that changes anything
Offline  
Old 06-13-2008, 09:05 PM   #9 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8320
PIN: N/A
Carrier: Fido
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by blackcivic View Post
Do you have a limit as to how many IP's your router can give out? Try and reset the router and modem and see if that changes anything
Well, that's where I'll have to start. Just went to Starbucks and connected to their hotspot with no probs, BB browser and Opera Mini.

Obviously it's an issue with my routers. As mentioned, I wonder if they're just too old? I don't want to have to get a new router just because I have a "new to me" phone (considering my home setup works with everything else).

*edit* Suddenly... everything works. I've made no changes to my router setup, and now get an ip. I can even login to the router via my BB. I'm a bit disappointed that the BB appears to be so weak on wifi (and I'm sitting within 6 ft. of the router).

Last edited by peroxide8888 : 06-16-2008 at 06:44 PM.
Offline  
Old 06-13-2008, 09:47 PM   #10 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,667
Post Thanks: 1
Thanked 84 Times in 65 Posts
Default

Make sure your router's firmware is up to date.
Offline  
Old 06-14-2008, 02:52 AM   #11 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8320
PIN: N/A
Carrier: fido
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

well, i use an old linksys wireless router, and it can save more than 20 MAC addresses. the IP address will be assigned automatically after MAC address is saved. i actually didn't have to do anything with my device. good luck.

Last edited by ntrbc : 06-14-2008 at 02:55 AM.
Offline  
Old 06-14-2008, 07:51 AM   #12 (permalink)
Thumbs Must Hurt
 
Join Date: Jun 2008
Model: 8320
PIN: N/A
Carrier: fido
Posts: 52
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

So does that mean you can connect to your router and get an ip?
Offline  
Old 06-14-2008, 04:44 PM   #13 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8320
PIN: N/A
Carrier: fido
Posts: 8
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

ya, when i connected to my router, the ip was obtained automatically.

Last edited by ntrbc : 06-14-2008 at 05:49 PM.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.