BlackBerry Forums Support Community               

Closed Thread
LinkBack Thread Tools
Old 06-13-2008, 11:50 AM   #1 (permalink)
New Member
Join Date: Jun 2008
Model: 8310
Carrier: ATT
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default My curve is dead…please help

Please Login to Remove!

I have an ATT 8300 that went to a white screen and then died altogether. It CAN be addressed, synced and updated via the USB port, but the phone will not function and the screen will not come on.

It is not flashing any LED pattern, only displays a momentary solid red LED when the battery is inserted.

Any idea of a way to do a circuit board reset or any way I could get it going again?
Old 06-13-2008, 11:52 AM   #2 (permalink)
No longer Registered.
greggebhardt's Avatar
Join Date: Jan 2005
Location: Jacksonville, FLorida
Model: 9000!
Carrier: AT&T
Posts: 3,762
Post Thanks: 0
Thanked 0 Times in 0 Posts

What were you doing when this happened? Had you just done a update or installed software or other function?
Old 06-14-2008, 02:53 AM   #3 (permalink)
Talking BlackBerry Encyclopedia
Join Date: May 2008
Location: 98003
Model: 9700
Carrier: T-Mobile, Verizon
Posts: 477
Post Thanks: 0
Thanked 0 Times in 0 Posts

if it is completely unresponsive after a battery pull, then try using JL_Cmndr to wipe the phone and reload the OS.
my av was not safe for preschoolers.
Old 06-14-2008, 11:31 PM   #4 (permalink)
Thumbs Must Hurt
Join Date: Oct 2007
Model: 8320
PIN: 24408F92
Carrier: Tmobile
Posts: 92
Post Thanks: 0
Thanked 0 Times in 0 Posts

agree with oakie
Old 06-14-2008, 11:49 PM   #5 (permalink)
BBF Moderator
John Clark's Avatar
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,691
Post Thanks: 4
Thanked 101 Times in 73 Posts

Did you have OS 4.5 installed on the device?

I actually had this happen to my 8320 a couple days ago. it went to a white screen and stayed that way. When I removed and inserted the battery it just flashed red and the screen wouldn't light up. I'm on a standby BB and awaiting an exchange from TMobile.

I'm wondering if this is OS related?
Closed Thread

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Copyright © 2004-2014
The names RIM © and BlackBerry © are registered Trademarks of BlackBerry Inc.