BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 10-01-2008, 08:03 PM   #1 (permalink)
Talking BlackBerry Encyclopedia
 
johnlatessa's Avatar
 
Join Date: Oct 2007
Location: Springfield, Illinois
Model: iPh 5
OS: iOS 6.1
Carrier: Verizon
Posts: 270
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default Video issue with ALL 4.5 OS Versions

Please Login to Remove!

I have several short videos that I ripped from DVD using Imtoo's DVD to MP4 ripping/encoding tool.

All of these files played perfectly under the 4.2 and 4.3 OS version.

Yet with every single 4.5 OS version I have tried, they always seem to freeze the player. The video at that point can't be stopped. The screen turns white when the video has finished playing, resulting in the need for a battery pull.

Is there a different format or better format I should be using?

I do however think it is a flaw with the new media player and I'm not optomistic about it being fixed in future 4.5 OS versions.

Any input or advice?

Thanks.
__________________
8703e --> 8830 --> 8300 --> 9530 --> iP3G --> 9550 --> iP3Gs --> 9800 --> iP4 --> 9930 --> iP5
Offline  
Old 10-01-2008, 08:24 PM   #2 (permalink)
iPhone Mod!
 
zerog46's Avatar
 
Join Date: May 2007
Location: In a House
Model: 9650
Carrier: VZW Bold
Posts: 6,749
Post Thanks: 16
Thanked 5 Times in 5 Posts
Default

I use the same program which mp4 format do you use.
__________________
Life is not holding a good hand. Life is playing a poor hand well.
Offline  
Old 10-02-2008, 04:30 PM   #3 (permalink)
Talking BlackBerry Encyclopedia
 
johnlatessa's Avatar
 
Join Date: Oct 2007
Location: Springfield, Illinois
Model: iPh 5
OS: iOS 6.1
Carrier: Verizon
Posts: 270
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

These particular MP4 files were created using the Imtoo 3GP Ripper.

For my "profile" I chose "BlackBerry MP4"

Bitrate was set to 100 and no other options changed except turning sound off.

I am now firmly convinced that this is a flaw in the "new and improved" media player offered with the 4.5 OS.

I've had the same problem on my Curve with 4.5 and my 8830 World Edition with 4.5 as well.

It's too much of a coincidence to be a flaw with the video files themselves as they worked perfectly on the 8830 under 4.2 and the 8330 Curve with 4.3.
__________________
8703e --> 8830 --> 8300 --> 9530 --> iP3G --> 9550 --> iP3Gs --> 9800 --> iP4 --> 9930 --> iP5
Offline  
Old 10-02-2008, 06:45 PM   #4 (permalink)
BlackBerry Extraordinaire
 
Join Date: Dec 2006
Model: I747
OS: 4.1.1
Carrier: at&t
Posts: 2,340
Post Thanks: 43
Thanked 117 Times in 107 Posts
Default

John,

I'm not convinced its a 4.5 issue. I've tinkered with Mediacoder MediaCoder - more than a universal audio/video transcoder and got 4 movies, all in full length, in mp4 format and they play just fine.
__________________
The Search tool and BlackBerryFAQ answer many questions.
Offline  
Old 10-02-2008, 06:59 PM   #5 (permalink)
iPhone Mod!
 
zerog46's Avatar
 
Join Date: May 2007
Location: In a House
Model: 9650
Carrier: VZW Bold
Posts: 6,749
Post Thanks: 16
Thanked 5 Times in 5 Posts
Default

Same here, except with Imtoo, I have DVD Ripper Platinum 4. I use MPEG 4 AVC video.
__________________
Life is not holding a good hand. Life is playing a poor hand well.
Offline  
Old 10-03-2008, 08:23 AM   #6 (permalink)
Talking BlackBerry Encyclopedia
 
johnlatessa's Avatar
 
Join Date: Oct 2007
Location: Springfield, Illinois
Model: iPh 5
OS: iOS 6.1
Carrier: Verizon
Posts: 270
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Well, I'll give both a shot, and see what happens.

Thanks for the heads up =)
__________________
8703e --> 8830 --> 8300 --> 9530 --> iP3G --> 9550 --> iP3Gs --> 9800 --> iP4 --> 9930 --> iP5
Offline  
Old 10-03-2008, 09:05 PM   #7 (permalink)
Talking BlackBerry Encyclopedia
 
johnlatessa's Avatar
 
Join Date: Oct 2007
Location: Springfield, Illinois
Model: iPh 5
OS: iOS 6.1
Carrier: Verizon
Posts: 270
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default Still no luck

I tried several different methods of encoding video, and the 4.5 OS media player just doesn't like them.

You can't even display the full menu as the top portion of it is "hidden" underneath the video display.

This isn't acceptable. The media player does not work with video.

I've tried everything.

I have to go back to 4.3, if I want to watch videos.
__________________
8703e --> 8830 --> 8300 --> 9530 --> iP3G --> 9550 --> iP3Gs --> 9800 --> iP4 --> 9930 --> iP5

Last edited by johnlatessa : 10-03-2008 at 09:08 PM.
Offline  
Old 11-01-2008, 02:56 PM   #8 (permalink)
Talking BlackBerry Encyclopedia
 
johnlatessa's Avatar
 
Join Date: Oct 2007
Location: Springfield, Illinois
Model: iPh 5
OS: iOS 6.1
Carrier: Verizon
Posts: 270
Post Thanks: 1
Thanked 0 Times in 0 Posts
Thumbs up This Problem Has Been SOLVED!

I have experimented with the same series of DVD Rips, using different bit rates, codecs, etc, and here is what I have discovered.

The new and improved 4.5 Media Player doesn't like MP4 files that have no audio track on them. I recalled that when I ripped these segments from DVD, I had disabled the audio because I only wanted the video portion of it.

I discovered this purely by accident, as I recently ripped a couple of DVD movies on to MP4 for use on my Curve. I then noticed that I did not have the trouble that I have previously described in this thread. That got me thinking a bit...

I was intrigued enough to go back to the original DVD and re-rip one of the files, both with sound, and then with no sound. The file with no sound hung the player as previously described. The file that had an audio track played perfectly.

So now I can continue to use my trusty Imtoo 3GP Converter (even though I use MP4), with no change, and since I have to re-rip those original files anyway, I'll now know to not disable the audio, and I can also use an even higher video bit rate.

Imtoo 3GP Converter (ImTOO DVD Ripper - DVD converter, Rip DVD to AVI, MP4, DivX, MPEG)

My settings are the default BlackBerry MP4 settings but the default video bit rate is raised from 300 to 512. I leave the audio settings as they are.

Works like a charm!
__________________
8703e --> 8830 --> 8300 --> 9530 --> iP3G --> 9550 --> iP3Gs --> 9800 --> iP4 --> 9930 --> iP5

Last edited by johnlatessa : 11-01-2008 at 02:57 PM.
Offline  
Old 11-01-2008, 03:20 PM   #9 (permalink)
Talking BlackBerry Encyclopedia
 
pegb856's Avatar
 
Join Date: May 2007
Location: NE Indiana
Model: 8330
OS: 4.5.0.119
PIN: Head
Carrier: Sprint
Posts: 226
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have a bunch of music videos I downloaded, so don't know the details of the mpeg file, however they also have not worked on a single 4.5 OS when they worked perfectly on 4.2 and the other BB devices I have had, 8100, 8300, 8310. I upgraded the OS as soon as I got my 8330 so I never tested them with 4.3. Mine doesn't freeze, it just tells me it cannot play them. I thought maybe a Media card wipe and reformat would help. It didn't.
__________________
As Always...

Happy Berrying!
Offline  
Old 11-01-2008, 03:31 PM   #10 (permalink)
Thumbs Must Hurt
 
ctibbsaz's Avatar
 
Join Date: Sep 2008
Location: Phoenix, AZ
Model: 8900
OS: 5.0.0.190
Carrier: t-mobile
Posts: 194
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I will have to try and see if it hangs mine up, I usually have my Zune to watch movies on since it kicks ass for that, but would not mind having a few on my curve in case I leave my zune. I use Slysofts clone DVD mobile so will see how things go.
__________________
"SEMPER FIDELIS"
Marines are an essential part of everyone's daily diet
Offline  
Old 11-01-2008, 04:31 PM   #11 (permalink)
Talking BlackBerry Encyclopedia
 
johnlatessa's Avatar
 
Join Date: Oct 2007
Location: Springfield, Illinois
Model: iPh 5
OS: iOS 6.1
Carrier: Verizon
Posts: 270
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by pegb856 View Post
I have a bunch of music videos I downloaded, so don't know the details of the mpeg file, however they also have not worked on a single 4.5 OS when they worked perfectly on 4.2 and the other BB devices I have had, 8100, 8300, 8310. I upgraded the OS as soon as I got my 8330 so I never tested them with 4.3. Mine doesn't freeze, it just tells me it cannot play them. I thought maybe a Media card wipe and reformat would help. It didn't.
I've noticed something similar.

In the Imtoo 3GP DVD RIpper, there are options for:

MP4
and
MP4 for BlackBerry

I have not yet determined the differences between them, but MP4 won't play for me either (under 4.5), while MP4 for BlackBerry works like a charm.

If I find anything out, I'll post here.
__________________
8703e --> 8830 --> 8300 --> 9530 --> iP3G --> 9550 --> iP3Gs --> 9800 --> iP4 --> 9930 --> iP5
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.