BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 10-04-2008, 11:07 PM   #1 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8310
PIN: N/A
Carrier: AT&T
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default 8310 acting strangley

Please Login to Remove!

For some reason the track ball on my 8310 is not working. Can't navigate throught menus or move up and down to change anything. Won't let me roll down through menu. Open options and the ball sticks at the top won't let me scroll down. Can't do much right now. Any help would be great. Thanks
Offline  
Old 10-04-2008, 11:11 PM   #2 (permalink)
New Member
 
jsconyers's Avatar
 
Join Date: Jul 2007
Location: In a van down by the river.
Model: NOTE2
OS: 4.1
PIN: <- Where do I find this?
Carrier: Sprint
Posts: 15,069
Post Thanks: 138
Thanked 139 Times in 120 Posts
Default

Sounds like there is some debris under it. Try putting it in standby and pressing down on the trackball and rolling it in all directions to remove any debris that may be under it.
Offline  
Old 10-04-2008, 11:17 PM   #3 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8310
PIN: N/A
Carrier: AT&T
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Tried that thanks but still doing the same things.
Offline  
Old 10-04-2008, 11:21 PM   #4 (permalink)
New Member
 
jsconyers's Avatar
 
Join Date: Jul 2007
Location: In a van down by the river.
Model: NOTE2
OS: 4.1
PIN: <- Where do I find this?
Carrier: Sprint
Posts: 15,069
Post Thanks: 138
Thanked 139 Times in 120 Posts
Default

Have you gotten the device wet at all?

I would try a battery pull to see if that helps. Then maybe try to remove the trackball assembly and clean it thoroughly.

You may need a new assembly, if so try HorizonWirelessOnline.com - Horizon Wireless, The World&rsquo;s Cellular Repair Center .

Best of luck
Offline  
Old 10-04-2008, 11:26 PM   #5 (permalink)
New Member
 
Join Date: Apr 2008
Model: 8310
PIN: N/A
Carrier: AT&T
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Not wet at all. Did three battery pulls. Thanks for the help.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.